Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > customerrors tag in web.config

Reply
Thread Tools

customerrors tag in web.config

 
 
Chumley Walrus
Guest
Posts: n/a
 
      01-22-2005
I'm having trouble seeing my page when I publish it on my live server.
I created a project in VS.net (with MMIT integrated), created a simple
index.aspx mobilewebform page , I can see it in my Mobile Explorer
emulator , but get the following error when trying to look at it from
my remote server, even when changing the CustomErrors mode to Off:



Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within
a "web.config" configuration file located in the root directory of the
current web application. This <customErrors> tag should then have its
"mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>



????
chumley

 
Reply With Quote
 
 
 
 
Juan T. Llibre
Guest
Posts: n/a
 
      01-22-2005
You may be mixing up the error messages.

The customErrors Attributes are

mode="[On|Off|RemoteOnly]"

On: Always display custom errors
Off: Always display ASP.NET error pages
RemoteOnly: Display custom errors to remote clients
and ASP.NET errors to localhost
defaultRedirect="url" - Url to redirect client to when an error occurs

There's no way you'll get custom error messages,
if you set customErrors to "off", as in

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>

That way, you'll only get ASP.NET error messages.

You need to set <customErrors mode ="RemoteOnly"/>
if you only want remote clients to see your custom error
messages.

or

You need to set <customErrors mode ="On"/>
if you want your custom error messages to be
displayed both locally and to remote clients.




Juan T. Llibre
ASP.NET MVP
===========
"Chumley Walrus" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
> I'm having trouble seeing my page when I publish it on my live server.
> I created a project in VS.net (with MMIT integrated), created a simple
> index.aspx mobilewebform page , I can see it in my Mobile Explorer
> emulator , but get the following error when trying to look at it from
> my remote server, even when changing the CustomErrors mode to Off:
>
> Details: To enable the details of this specific error message to be
> viewable on remote machines, please create a <customErrors> tag within
> a "web.config" configuration file located in the root directory of the
> current web application. This <customErrors> tag should then have its
> "mode" attribute set to "Off".
>
>
> <!-- Web.Config Configuration File -->
>
> <configuration>
> <system.web>
> <customErrors mode="Off"/>
> </system.web>
> </configuration>
>
>
>
> ????
> chumley
>




 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
customerrors tag doesnt works Tahir ASP .Net 2 09-04-2008 07:29 AM
<customErrors> tag should have its "mode" attribute set to "Off". jasari Software 4 04-04-2007 07:31 AM
how do u invoke Tag b's Tag Handler from within Tag a's tag Handler? shruds Java 1 01-27-2006 03:00 AM
.NET question about the customErrors Tag =?Utf-8?B?U2FtdWVs?= ASP .Net 6 05-11-2004 01:23 PM
customErrors 404 NRao ASP .Net 1 07-01-2003 04:33 PM



Advertisments