Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > VHDL > Modelsim MXE on wine?

Reply
Thread Tools

Modelsim MXE on wine?

 
 
nospam@nospam.com
Guest
Posts: n/a
 
      06-28-2012
I had MXE (Modelsim Xilinx Edition) running successfully under Wine
until recently. However, following a lot of changes, I 've just
re-installed it, and can't get vsim running. My setup is SL(/RHEL)6,
64-bit, wine 1.2.3. I've installed MXE-III Starter, for both VHDL and
Verilog. When I run vsim I get a pop-up with a long message which
starts:

'can't read "view_master": no such variable when executing
"GUIMAIN"...'

The problem is in the tcl start-up (tcl/vsim/vsim). Anyone else seen
this? Any ideas?

Thanks.
 
Reply With Quote
 
 
 
 
Mister_J Mister_J is offline
Junior Member
Join Date: Jun 2012
Posts: 8
 
      06-29-2012
It seems that MXE is no longer available (http://www.xilinx.com/tools/mxe.htm). You could download the regular Modelsim with native linux support from here : http://model.com/content/modelsim-downloads, but I don't know if you can use the licence you have with MXE.

Jonas
 
Reply With Quote
 
 
 
 
Allan Herriman
Guest
Posts: n/a
 
      06-29-2012
On Thu, 28 Jun 2012 14:45:54 +0100, nospam wrote:

> I had MXE (Modelsim Xilinx Edition) running successfully under Wine
> until recently. However, following a lot of changes, I 've just
> re-installed it, and can't get vsim running. My setup is SL(/RHEL)6,
> 64-bit, wine 1.2.3. I've installed MXE-III Starter, for both VHDL and
> Verilog. When I run vsim I get a pop-up with a long message which
> starts:
>
> 'can't read "view_master": no such variable when executing "GUIMAIN"...'
>
> The problem is in the tcl start-up (tcl/vsim/vsim). Anyone else seen
> this? Any ideas?


I've seen that same error message with Modelsim under Wine. It was a
year or two ago using 64 bit Ubuntu so I can't remember the exact details
but the problem eventually went away when Canonical included a more
recent version of Wine.

The errors went away with Wine 1.4, however I now use Windows 7 on my
work computer and versions of Modelsim post 6.something work fine on that.

Regards,
Allan
(followups not set)
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with modelsim Torsten Bitterlich VHDL 3 04-24-2008 10:52 PM
xilinx logiblox and modelsim SE 5.6 Tim Terry VHDL 1 07-21-2003 03:25 PM
VHDL Simulation in ModelSim Manfred Balik VHDL 0 07-15-2003 02:12 PM
ModelSim Error Msg Yogi V. VHDL 3 07-03-2003 10:48 AM
Re: ModelSim 5.7 and xilinx libraries David Bishop VHDL 1 06-28-2003 04:53 PM



Advertisments