Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Doesnot allow to debug or asks for username and password in visual studio.net academic 2003

Reply
Thread Tools

Doesnot allow to debug or asks for username and password in visual studio.net academic 2003

 
 
Anita
Guest
Posts: n/a
 
      01-14-2005
I have problem opening my existing projects or newly created project. It
asks me for user name and password and if I provide then it allows me to
open but when I debug either it gives error message that you are not the
debugger user (although I am administrator of my computer) or while running
it doesnot connect to the database server. I am using NT authentication.
Please help.
Thanks,
Anita


 
Reply With Quote
 
 
 
 
Suhaib Khan
Guest
Posts: n/a
 
      01-14-2005
You need to add the account to "Debugger Users" group to debug the
application.

Database connection - send more detail about your network setupo like
whether databse server and your machine or in same domain or not.

"Anita" <(E-Mail Removed)> wrote in message
news:<#MO4QFo#(E-Mail Removed)>...

> I have problem opening my existing projects or newly created project.


> It


> asks me for user name and password and if I provide then it allows me to


> open but when I debug either it gives error message that you are not the


> debugger user (although I am administrator of my computer) or while

running

> it doesnot connect to the database server. I am using NT authentication.


> Please help.


> Thanks,


> Anita


>


>



 
Reply With Quote
 
 
 
 
Anita Gupta
Guest
Posts: n/a
 
      01-15-2005
My account is on the saas the database server. Database server name is
cerebrum and domain name is som. My computer's name is axg68 and my
login is anita. I am trying to use my domain user account like som\anita
and I am the administrator and debugger user of my computer. My
computer's hard drive was crashed and I was able to restore it to a new
hard drive but I think I lost some of the information. I uninstalled and
reinstalled iis and visual studio.net but it is not fixing the problem.
Along with NT authentication I have also selected allow anonymous access
and their I provided my user name and password and deselected the option
allow IIS to change password for the virtual directory in my local IIS.
Whenever I open a project it asks me for the user name and password and
after supplying the login information it allows me to open the project
and when I try to debug or run it again asks me for the login
information and then it gives database connection error message. If I
remove NT authentication from the IIS virtual directory then it doesnot
asks me for the login information while opening the project but then it
does not allow me to debug. It tells me that I am not a debugger user.
Now I do not understand how to fix it. Before hard drive crash it was
working fine.
Thanks,
Anita




*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
 
Reply With Quote
 
eruth
Guest
Posts: n/a
 
      01-18-2005
I had this issue - when trying to debug an ASP.Net application from the
VS2003 IDE I got a box popping up telling me to enter the name &
password of an account that had permissions to debug on the server.

It was one of two things that fixed it - not sure which one it was
though!
Firstly, I added the IWAM_MACHINENAME account into the debuggers group,
then I made sure within visual studio that only ASP.Net debugging was
enabled, and _NOT_ ASP debugging (look in the project's properties). I
then rebooted my pc (not sure if this is a necessary step, you may get
away with restarting IIS) and it all worked.



HTH

Emma

 
Reply With Quote
 
Anita Gupta
Guest
Posts: n/a
 
      01-18-2005

Thanks Emma,
I will try this and see if it works or not.
Anita


*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
 
Reply With Quote
 
Anita Gupta
Guest
Posts: n/a
 
      01-18-2005
I checked both. I added IWAM_Machinename in the debugger user and enable
ASP.NET debugging is set to true. Now it doesnot ask for user name and
password when I open the project but it doenot let me debugg. Error is
"Error while trying to run the project. Unable to start debugging on the
web server. you donot have permission to debugs the server. Verify that
you are a member of the "Debugger Users" group on the server." Now I
really donot know what to do.
Any help will be appreciated.
Anita

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
 
Reply With Quote
 
Anita Gupta
Guest
Posts: n/a
 
      01-18-2005
Hi,
The problem is solved and I would like to share with you all. Somehow it
was not trusting on my on own localhost. I added http://localhost to the
trusted sites option in internet explorer -> tools ->internet options ->
security tab.
thanks for all your help
anita



*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VPN client asks for username and password when connecting! Dave Cisco 7 12-22-2005 09:55 AM
Asp Page asks for username & password Ashutosh ASP General 2 10-07-2005 12:41 PM
Visual Basic .NET 2003 vs. Visual Studio .NET 2003 TJ MCAD 1 09-23-2005 07:13 PM
How to verify username and password in Visual C pm a C Programming 1 07-05-2005 05:57 PM
Visual Studio .Net 2003 (Academic Version) Sufficient? Lance MCAD 1 01-03-2004 12:15 PM



Advertisments