Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > How to TimeOut a long running Request ??

Reply
Thread Tools

How to TimeOut a long running Request ??

 
 
=?Utf-8?B?U2hhbGluaQ==?=
Guest
Posts: n/a
 
      01-05-2005
If I have an ASPX page that is just sleeping for 3 minutes ormore and later
does some processing and the ExecutionTimeout parameter in the machine.config
is 90 seconds then the page does not timeout after 90 seconds.
Even if the ExecutionTimeout parameter in the web.config is set or the
Server.ScriptTimeout is set in the aspx.cs still the page does not timeout
after the timeout period.
Can someone please tell us as to how we can timeout an aspx page that is
doing some lengthy processing? Also when exactly does the ExecutionTimeout
take effect?
 
Reply With Quote
 
 
 
 
William F. Robertson, Jr.
Guest
Posts: n/a
 
      01-05-2005
I am not sure if this is your situation, but I could never get a "Request
Timed Out." when I was running the browser and the server on my local
machine. I had to use my browser to hit a remote machine. My
machine.config timeout is 90 seconds, and it does timeout remotely. Are you
running everything on your local machine?

bill

"Shalini" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> If I have an ASPX page that is just sleeping for 3 minutes ormore and

later
> does some processing and the ExecutionTimeout parameter in the

machine.config
> is 90 seconds then the page does not timeout after 90 seconds.
> Even if the ExecutionTimeout parameter in the web.config is set or the
> Server.ScriptTimeout is set in the aspx.cs still the page does not timeout
> after the timeout period.
> Can someone please tell us as to how we can timeout an aspx page that is
> doing some lengthy processing? Also when exactly does the ExecutionTimeout
> take effect?



 
Reply With Quote
 
 
 
 
=?Utf-8?B?U2hhbGluaQ==?=
Guest
Posts: n/a
 
      01-06-2005
I am not getting the timeout in any case whether I am ruuning the application
locally or remotely. I have tried several times. Even though the
'ExecutionTimeout' in machine.config is set to 90 seconds, the request
doesnot timeout. The 'debug' attribute in web.config is set to true. Is some
other setting required to be made? If not then what is the reason for the
timeout not happening? Could anyone please elaborate?

"William F. Robertson, Jr." wrote:

> I am not sure if this is your situation, but I could never get a "Request
> Timed Out." when I was running the browser and the server on my local
> machine. I had to use my browser to hit a remote machine. My
> machine.config timeout is 90 seconds, and it does timeout remotely. Are you
> running everything on your local machine?
>
> bill
>
> "Shalini" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > If I have an ASPX page that is just sleeping for 3 minutes ormore and

> later
> > does some processing and the ExecutionTimeout parameter in the

> machine.config
> > is 90 seconds then the page does not timeout after 90 seconds.
> > Even if the ExecutionTimeout parameter in the web.config is set or the
> > Server.ScriptTimeout is set in the aspx.cs still the page does not timeout
> > after the timeout period.
> > Can someone please tell us as to how we can timeout an aspx page that is
> > doing some lengthy processing? Also when exactly does the ExecutionTimeout
> > take effect?

>
>
>

 
Reply With Quote
 
Juan T. Llibre [MVP]
Guest
Posts: n/a
 
      01-06-2005
re:
>The 'debug' attribute in web.config is set to true.


'ExecutionTimeout' only applies if the debug
attribute in the compilation element is set to false.




Juan T. Llibre
===========
"Shalini" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>I am not getting the timeout in any case whether I am ruuning the
>application
> locally or remotely. I have tried several times. Even though the
> 'ExecutionTimeout' in machine.config is set to 90 seconds, the request
> doesnot timeout. The 'debug' attribute in web.config is set to true. Is
> some
> other setting required to be made? If not then what is the reason for the
> timeout not happening? Could anyone please elaborate?
>
> "William F. Robertson, Jr." wrote:
>
>> I am not sure if this is your situation, but I could never get a "Request
>> Timed Out." when I was running the browser and the server on my local
>> machine. I had to use my browser to hit a remote machine. My
>> machine.config timeout is 90 seconds, and it does timeout remotely. Are
>> you
>> running everything on your local machine?
>>
>> bill
>>
>> "Shalini" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>> > If I have an ASPX page that is just sleeping for 3 minutes ormore and

>> later
>> > does some processing and the ExecutionTimeout parameter in the

>> machine.config
>> > is 90 seconds then the page does not timeout after 90 seconds.
>> > Even if the ExecutionTimeout parameter in the web.config is set or the
>> > Server.ScriptTimeout is set in the aspx.cs still the page does not
>> > timeout
>> > after the timeout period.
>> > Can someone please tell us as to how we can timeout an aspx page that
>> > is
>> > doing some lengthy processing? Also when exactly does the
>> > ExecutionTimeout
>> > take effect?

>>
>>
>>



---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004


 
Reply With Quote
 
=?Utf-8?B?SW5kaXJh?=
Guest
Posts: n/a
 
      01-10-2005
Thanx a lot everyone.
Struggled a lot with this problem.



"Juan T. Llibre [MVP]" wrote:

> re:
> >The 'debug' attribute in web.config is set to true.

>
> 'ExecutionTimeout' only applies if the debug
> attribute in the compilation element is set to false.
>
>
>
>
> Juan T. Llibre
> ===========
> "Shalini" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> >I am not getting the timeout in any case whether I am ruuning the
> >application
> > locally or remotely. I have tried several times. Even though the
> > 'ExecutionTimeout' in machine.config is set to 90 seconds, the request
> > doesnot timeout. The 'debug' attribute in web.config is set to true. Is
> > some
> > other setting required to be made? If not then what is the reason for the
> > timeout not happening? Could anyone please elaborate?
> >
> > "William F. Robertson, Jr." wrote:
> >
> >> I am not sure if this is your situation, but I could never get a "Request
> >> Timed Out." when I was running the browser and the server on my local
> >> machine. I had to use my browser to hit a remote machine. My
> >> machine.config timeout is 90 seconds, and it does timeout remotely. Are
> >> you
> >> running everything on your local machine?
> >>
> >> bill
> >>
> >> "Shalini" <(E-Mail Removed)> wrote in message
> >> news:(E-Mail Removed)...
> >> > If I have an ASPX page that is just sleeping for 3 minutes ormore and
> >> later
> >> > does some processing and the ExecutionTimeout parameter in the
> >> machine.config
> >> > is 90 seconds then the page does not timeout after 90 seconds.
> >> > Even if the ExecutionTimeout parameter in the web.config is set or the
> >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
> >> > timeout
> >> > after the timeout period.
> >> > Can someone please tell us as to how we can timeout an aspx page that
> >> > is
> >> > doing some lengthy processing? Also when exactly does the
> >> > ExecutionTimeout
> >> > take effect?
> >>
> >>
> >>

>
>
> ---
> Outgoing mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
>
>
>

 
Reply With Quote
 
Alvin Bruney [MVP]
Guest
Posts: n/a
 
      01-10-2005
FYI:
I've never known that executionTimeout to actually work irespective of the
settings applied.

--
Regards,
Alvin Bruney
[ASP.NET MVP http://mvp.support.microsoft.com/default.aspx]
Got tidbits? Get it here... http://tinyurl.com/27cok
"Indira" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Thanx a lot everyone.
> Struggled a lot with this problem.
>
>
>
> "Juan T. Llibre [MVP]" wrote:
>
>> re:
>> >The 'debug' attribute in web.config is set to true.

>>
>> 'ExecutionTimeout' only applies if the debug
>> attribute in the compilation element is set to false.
>>
>>
>>
>>
>> Juan T. Llibre
>> ===========
>> "Shalini" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>> >I am not getting the timeout in any case whether I am ruuning the
>> >application
>> > locally or remotely. I have tried several times. Even though the
>> > 'ExecutionTimeout' in machine.config is set to 90 seconds, the request
>> > doesnot timeout. The 'debug' attribute in web.config is set to true. Is
>> > some
>> > other setting required to be made? If not then what is the reason for
>> > the
>> > timeout not happening? Could anyone please elaborate?
>> >
>> > "William F. Robertson, Jr." wrote:
>> >
>> >> I am not sure if this is your situation, but I could never get a
>> >> "Request
>> >> Timed Out." when I was running the browser and the server on my local
>> >> machine. I had to use my browser to hit a remote machine. My
>> >> machine.config timeout is 90 seconds, and it does timeout remotely.
>> >> Are
>> >> you
>> >> running everything on your local machine?
>> >>
>> >> bill
>> >>
>> >> "Shalini" <(E-Mail Removed)> wrote in message
>> >> news:(E-Mail Removed)...
>> >> > If I have an ASPX page that is just sleeping for 3 minutes ormore
>> >> > and
>> >> later
>> >> > does some processing and the ExecutionTimeout parameter in the
>> >> machine.config
>> >> > is 90 seconds then the page does not timeout after 90 seconds.
>> >> > Even if the ExecutionTimeout parameter in the web.config is set or
>> >> > the
>> >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
>> >> > timeout
>> >> > after the timeout period.
>> >> > Can someone please tell us as to how we can timeout an aspx page
>> >> > that
>> >> > is
>> >> > doing some lengthy processing? Also when exactly does the
>> >> > ExecutionTimeout
>> >> > take effect?
>> >>
>> >>
>> >>

>>
>>
>> ---
>> Outgoing mail is certified Virus Free.
>> Checked by AVG anti-virus system (http://www.grisoft.com).
>> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
>>
>>
>>



 
Reply With Quote
 
Juan T. Llibre
Guest
Posts: n/a
 
      01-10-2005
It seems to have worked for Indira.



Juan T. Llibre
ASP.NET MVP
===========
"Alvin Bruney [MVP]" <vapor at steaming post office> wrote in message
news:%(E-Mail Removed)...
> FYI:
> I've never known that executionTimeout to actually work irespective of the
> settings applied.
> Regards,
> Alvin Bruney


> "Indira" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> Thanx a lot everyone.
>> Struggled a lot with this problem.
>>
>>
>>
>> "Juan T. Llibre [MVP]" wrote:
>>
>>> re:
>>> >The 'debug' attribute in web.config is set to true.
>>>
>>> 'ExecutionTimeout' only applies if the debug
>>> attribute in the compilation element is set to false.
>>>
>>>
>>>
>>>
>>> Juan T. Llibre
>>> ===========
>>> "Shalini" <(E-Mail Removed)> wrote in message
>>> news:(E-Mail Removed)...
>>> >I am not getting the timeout in any case whether I am ruuning the
>>> >application
>>> > locally or remotely. I have tried several times. Even though the
>>> > 'ExecutionTimeout' in machine.config is set to 90 seconds, the request
>>> > doesnot timeout. The 'debug' attribute in web.config is set to true.
>>> > Is
>>> > some
>>> > other setting required to be made? If not then what is the reason for
>>> > the
>>> > timeout not happening? Could anyone please elaborate?
>>> >
>>> > "William F. Robertson, Jr." wrote:
>>> >
>>> >> I am not sure if this is your situation, but I could never get a
>>> >> "Request
>>> >> Timed Out." when I was running the browser and the server on my local
>>> >> machine. I had to use my browser to hit a remote machine. My
>>> >> machine.config timeout is 90 seconds, and it does timeout remotely.
>>> >> Are
>>> >> you
>>> >> running everything on your local machine?
>>> >>
>>> >> bill
>>> >>
>>> >> "Shalini" <(E-Mail Removed)> wrote in message
>>> >> news:(E-Mail Removed)...
>>> >> > If I have an ASPX page that is just sleeping for 3 minutes ormore
>>> >> > and
>>> >> later
>>> >> > does some processing and the ExecutionTimeout parameter in the
>>> >> machine.config
>>> >> > is 90 seconds then the page does not timeout after 90 seconds.
>>> >> > Even if the ExecutionTimeout parameter in the web.config is set or
>>> >> > the
>>> >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
>>> >> > timeout
>>> >> > after the timeout period.
>>> >> > Can someone please tell us as to how we can timeout an aspx page
>>> >> > that
>>> >> > is
>>> >> > doing some lengthy processing? Also when exactly does the
>>> >> > ExecutionTimeout
>>> >> > take effect?
>>> >>
>>> >>
>>> >>
>>>
>>>
>>> ---
>>> Outgoing mail is certified Virus Free.
>>> Checked by AVG anti-virus system (http://www.grisoft.com).
>>> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
>>>
>>>
>>>

>
>



 
Reply With Quote
 
Alvin Bruney [MVP]
Guest
Posts: n/a
 
      01-10-2005
indira,
you mind saying what you tweaked in addition to the config file setting to
get this to work?

--
Regards,
Alvin Bruney
[ASP.NET MVP http://mvp.support.microsoft.com/default.aspx]
Got tidbits? Get it here... http://tinyurl.com/27cok
"Juan T. Llibre" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
> It seems to have worked for Indira.
>
>
>
> Juan T. Llibre
> ASP.NET MVP
> ===========
> "Alvin Bruney [MVP]" <vapor at steaming post office> wrote in message
> news:%(E-Mail Removed)...
>> FYI:
>> I've never known that executionTimeout to actually work irespective of
>> the settings applied.
>> Regards,
>> Alvin Bruney

>
>> "Indira" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>>> Thanx a lot everyone.
>>> Struggled a lot with this problem.
>>>
>>>
>>>
>>> "Juan T. Llibre [MVP]" wrote:
>>>
>>>> re:
>>>> >The 'debug' attribute in web.config is set to true.
>>>>
>>>> 'ExecutionTimeout' only applies if the debug
>>>> attribute in the compilation element is set to false.
>>>>
>>>>
>>>>
>>>>
>>>> Juan T. Llibre
>>>> ===========
>>>> "Shalini" <(E-Mail Removed)> wrote in message
>>>> news:(E-Mail Removed)...
>>>> >I am not getting the timeout in any case whether I am ruuning the
>>>> >application
>>>> > locally or remotely. I have tried several times. Even though the
>>>> > 'ExecutionTimeout' in machine.config is set to 90 seconds, the
>>>> > request
>>>> > doesnot timeout. The 'debug' attribute in web.config is set to true.
>>>> > Is
>>>> > some
>>>> > other setting required to be made? If not then what is the reason for
>>>> > the
>>>> > timeout not happening? Could anyone please elaborate?
>>>> >
>>>> > "William F. Robertson, Jr." wrote:
>>>> >
>>>> >> I am not sure if this is your situation, but I could never get a
>>>> >> "Request
>>>> >> Timed Out." when I was running the browser and the server on my
>>>> >> local
>>>> >> machine. I had to use my browser to hit a remote machine. My
>>>> >> machine.config timeout is 90 seconds, and it does timeout remotely.
>>>> >> Are
>>>> >> you
>>>> >> running everything on your local machine?
>>>> >>
>>>> >> bill
>>>> >>
>>>> >> "Shalini" <(E-Mail Removed)> wrote in message
>>>> >> news:(E-Mail Removed)...
>>>> >> > If I have an ASPX page that is just sleeping for 3 minutes ormore
>>>> >> > and
>>>> >> later
>>>> >> > does some processing and the ExecutionTimeout parameter in the
>>>> >> machine.config
>>>> >> > is 90 seconds then the page does not timeout after 90 seconds.
>>>> >> > Even if the ExecutionTimeout parameter in the web.config is set or
>>>> >> > the
>>>> >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
>>>> >> > timeout
>>>> >> > after the timeout period.
>>>> >> > Can someone please tell us as to how we can timeout an aspx page
>>>> >> > that
>>>> >> > is
>>>> >> > doing some lengthy processing? Also when exactly does the
>>>> >> > ExecutionTimeout
>>>> >> > take effect?
>>>> >>
>>>> >>
>>>> >>
>>>>
>>>>
>>>> ---
>>>> Outgoing mail is certified Virus Free.
>>>> Checked by AVG anti-virus system (http://www.grisoft.com).
>>>> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
>>>>
>>>>
>>>>

>>
>>

>
>



 
Reply With Quote
 
=?Utf-8?B?SW5kaXJh?=
Guest
Posts: n/a
 
      01-24-2005
Nothin else.
I just made sure 'executionTimeout' attribute of httpRuntime element is set
to its default value of 90 seconds in the machine.config and that it is not
being overridden in web.config.
I just needed to change the value of the 'debug' attribute to true and the
executionTimeout took effect.

"Alvin Bruney [MVP]" wrote:

> indira,
> you mind saying what you tweaked in addition to the config file setting to
> get this to work?
>
> --
> Regards,
> Alvin Bruney
> [ASP.NET MVP http://mvp.support.microsoft.com/default.aspx]
> Got tidbits? Get it here... http://tinyurl.com/27cok
> "Juan T. Llibre" <(E-Mail Removed)> wrote in message
> news:%(E-Mail Removed)...
> > It seems to have worked for Indira.
> >
> >
> >
> > Juan T. Llibre
> > ASP.NET MVP
> > ===========
> > "Alvin Bruney [MVP]" <vapor at steaming post office> wrote in message
> > news:%(E-Mail Removed)...
> >> FYI:
> >> I've never known that executionTimeout to actually work irespective of
> >> the settings applied.
> >> Regards,
> >> Alvin Bruney

> >
> >> "Indira" <(E-Mail Removed)> wrote in message
> >> news:(E-Mail Removed)...
> >>> Thanx a lot everyone.
> >>> Struggled a lot with this problem.
> >>>
> >>>
> >>>
> >>> "Juan T. Llibre [MVP]" wrote:
> >>>
> >>>> re:
> >>>> >The 'debug' attribute in web.config is set to true.
> >>>>
> >>>> 'ExecutionTimeout' only applies if the debug
> >>>> attribute in the compilation element is set to false.
> >>>>
> >>>>
> >>>>
> >>>>
> >>>> Juan T. Llibre
> >>>> ===========
> >>>> "Shalini" <(E-Mail Removed)> wrote in message
> >>>> news:(E-Mail Removed)...
> >>>> >I am not getting the timeout in any case whether I am ruuning the
> >>>> >application
> >>>> > locally or remotely. I have tried several times. Even though the
> >>>> > 'ExecutionTimeout' in machine.config is set to 90 seconds, the
> >>>> > request
> >>>> > doesnot timeout. The 'debug' attribute in web.config is set to true.
> >>>> > Is
> >>>> > some
> >>>> > other setting required to be made? If not then what is the reason for
> >>>> > the
> >>>> > timeout not happening? Could anyone please elaborate?
> >>>> >
> >>>> > "William F. Robertson, Jr." wrote:
> >>>> >
> >>>> >> I am not sure if this is your situation, but I could never get a
> >>>> >> "Request
> >>>> >> Timed Out." when I was running the browser and the server on my
> >>>> >> local
> >>>> >> machine. I had to use my browser to hit a remote machine. My
> >>>> >> machine.config timeout is 90 seconds, and it does timeout remotely.
> >>>> >> Are
> >>>> >> you
> >>>> >> running everything on your local machine?
> >>>> >>
> >>>> >> bill
> >>>> >>
> >>>> >> "Shalini" <(E-Mail Removed)> wrote in message
> >>>> >> news:(E-Mail Removed)...
> >>>> >> > If I have an ASPX page that is just sleeping for 3 minutes ormore
> >>>> >> > and
> >>>> >> later
> >>>> >> > does some processing and the ExecutionTimeout parameter in the
> >>>> >> machine.config
> >>>> >> > is 90 seconds then the page does not timeout after 90 seconds.
> >>>> >> > Even if the ExecutionTimeout parameter in the web.config is set or
> >>>> >> > the
> >>>> >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
> >>>> >> > timeout
> >>>> >> > after the timeout period.
> >>>> >> > Can someone please tell us as to how we can timeout an aspx page
> >>>> >> > that
> >>>> >> > is
> >>>> >> > doing some lengthy processing? Also when exactly does the
> >>>> >> > ExecutionTimeout
> >>>> >> > take effect?
> >>>> >>
> >>>> >>
> >>>> >>
> >>>>
> >>>>
> >>>> ---
> >>>> Outgoing mail is certified Virus Free.
> >>>> Checked by AVG anti-virus system (http://www.grisoft.com).
> >>>> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
> >>>>
> >>>>
> >>>>
> >>
> >>

> >
> >

>
>
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Having compilation error: no match for call to (const __gnu_cxx::hash<long long int>) (const long long int&) veryhotsausage C++ 1 07-04-2008 05:41 PM
urllib timeout hole - long timeout if site doesn't send headers. John Nagle Python 0 01-03-2008 06:22 PM
WebService ignoring timeout properties? (Server was unable to process request. --> Timeout exired) Lars-Erik Aabech ASP .Net Web Services 3 04-29-2005 02:21 AM
Unable to timeout a long running request =?Utf-8?B?TWljcm9zb2Z0IENlbnRyZSBPZiBFeGNlbGxlbmNl?= ASP .Net 4 01-07-2005 01:33 PM
Timeout::timeout and Socket timeout Mark Probert Ruby 1 10-06-2004 09:30 AM



Advertisments