Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP.NET and Active Schema

Reply
Thread Tools

ASP.NET and Active Schema

 
 
=?Utf-8?B?bXN1aw==?=
Guest
Posts: n/a
 
      11-30-2004
All,

I have a ASP.NET page that has been converted from a .htm page which has a
LINK and style tag underlined in red. When I hold the mouse pointer over
them I get the following message: "The active schema does not support the
element 'style'" but when I run the page I get no errors and it displays
fine. What is going on here and is this an error?

Thanks
Msuk
 
Reply With Quote
 
 
 
 
Scott Allen
Guest
Posts: n/a
 
      11-30-2004
When the WebForm renders.

You can see this if you find the .vb file the ASP.NET runtime
generates from the ASPX page. It will be in the Temporary ASP.NET
Files directory where the framework is installed and the relavant part
would look something like:

Public Class temp_aspx
...

Sub Output()
Response.Write("Foo")
End Sub

...


Private Sub __Render__control1( _
ByVal __output As HtmlTextWriter, _
ByVal parameterContainer As Control)

parameterContainer.Controls(0).RenderControl(__out put)

Output()

End Sub

...

End Class

--
Scott
http://www.OdeToCode.com/blogs/scott/

On Tue, 30 Nov 2004 01:45:03 -0800, "msuk"
<(E-Mail Removed)> wrote:

>All,
>
>I have a ASP.NET page that has been converted from a .htm page which has a
>LINK and style tag underlined in red. When I hold the mouse pointer over
>them I get the following message: "The active schema does not support the
>element 'style'" but when I run the page I get no errors and it displays
>fine. What is going on here and is this an error?
>
>Thanks
>Msuk


 
Reply With Quote
 
 
 
 
=?Utf-8?B?bXN1aw==?=
Guest
Posts: n/a
 
      11-30-2004
Hi,

Sorry I dont understand what this has to do with my problem could you please
explain further?

Thanks
Msuk

"Scott Allen" wrote:

> When the WebForm renders.
>
> You can see this if you find the .vb file the ASP.NET runtime
> generates from the ASPX page. It will be in the Temporary ASP.NET
> Files directory where the framework is installed and the relavant part
> would look something like:
>
> Public Class temp_aspx
> ...
>
> Sub Output()
> Response.Write("Foo")
> End Sub
>
> ...
>
>
> Private Sub __Render__control1( _
> ByVal __output As HtmlTextWriter, _
> ByVal parameterContainer As Control)
>
> parameterContainer.Controls(0).RenderControl(__out put)
>
> Output()
>
> End Sub
>
> ...
>
> End Class
>
> --
> Scott
> http://www.OdeToCode.com/blogs/scott/
>
> On Tue, 30 Nov 2004 01:45:03 -0800, "msuk"
> <(E-Mail Removed)> wrote:
>
> >All,
> >
> >I have a ASP.NET page that has been converted from a .htm page which has a
> >LINK and style tag underlined in red. When I hold the mouse pointer over
> >them I get the following message: "The active schema does not support the
> >element 'style'" but when I run the page I get no errors and it displays
> >fine. What is going on here and is this an error?
> >
> >Thanks
> >Msuk

>
>

 
Reply With Quote
 
Scott Allen
Guest
Posts: n/a
 
      11-30-2004
Oh, I apologize msuk, I don't how that post ended up here!

In regards to your problem, I think it is a message you can safely
ignore. The IDE tries to be helpful and smart but it isn't flexible
enough to handle all the valid syntax and constructs that can go into
HTML / ASPX. It has a list of things that are valid, but it is only a
subset of all the things that are really valid. Know what I mean?

--
Scott
http://www.OdeToCode.com/blogs/scott/


On Tue, 30 Nov 2004 06:33:08 -0800, "msuk"
<(E-Mail Removed)> wrote:

>Hi,
>
>Sorry I dont understand what this has to do with my problem could you please
>explain further?
>
>Thanks
>Msuk
>


 
Reply With Quote
 
=?Utf-8?B?bXN1aw==?=
Guest
Posts: n/a
 
      11-30-2004
Hi,

thanks for your response, is their anyway to switch this off or load the
correct HTML/ASPX schema's?

Thanks
Msuk

"Scott Allen" wrote:

> Oh, I apologize msuk, I don't how that post ended up here!
>
> In regards to your problem, I think it is a message you can safely
> ignore. The IDE tries to be helpful and smart but it isn't flexible
> enough to handle all the valid syntax and constructs that can go into
> HTML / ASPX. It has a list of things that are valid, but it is only a
> subset of all the things that are really valid. Know what I mean?
>
> --
> Scott
> http://www.OdeToCode.com/blogs/scott/
>
>
> On Tue, 30 Nov 2004 06:33:08 -0800, "msuk"
> <(E-Mail Removed)> wrote:
>
> >Hi,
> >
> >Sorry I dont understand what this has to do with my problem could you please
> >explain further?
> >
> >Thanks
> >Msuk
> >

>
>

 
Reply With Quote
 
Scott Allen
Guest
Posts: n/a
 
      11-30-2004
I believe you can turn it off under Tools -> Options -> Text Editor ->
Html/XML -> Html Specific -> Enable HTML Validation. Whew, what a
mouthful.

You can modify these schemas. I've never tried but I believe there are
some articles floating around on the subject. I can see the .xsd files
it uses for validation in
<vs.net install dir>\Common7\Packages\schemas\html

--
Scott
http://www.OdeToCode.com/blogs/scott/


On Tue, 30 Nov 2004 07:27:04 -0800, "msuk"
<(E-Mail Removed)> wrote:

>Hi,
>
>thanks for your response, is their anyway to switch this off or load the
>correct HTML/ASPX schema's?
>
>Thanks
>Msuk
>
>"Scott Allen" wrote:
>
>> Oh, I apologize msuk, I don't how that post ended up here!
>>
>> In regards to your problem, I think it is a message you can safely
>> ignore. The IDE tries to be helpful and smart but it isn't flexible
>> enough to handle all the valid syntax and constructs that can go into
>> HTML / ASPX. It has a list of things that are valid, but it is only a
>> subset of all the things that are really valid. Know what I mean?
>>
>> --
>> Scott
>> http://www.OdeToCode.com/blogs/scott/
>>
>>
>> On Tue, 30 Nov 2004 06:33:08 -0800, "msuk"
>> <(E-Mail Removed)> wrote:
>>
>> >Hi,
>> >
>> >Sorry I dont understand what this has to do with my problem could you please
>> >explain further?
>> >
>> >Thanks
>> >Msuk
>> >

>>
>>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with schema-validation and property "http://apache.org/xml/properties/schema/external-schemaLocation" Markus Java 1 11-23-2005 02:41 PM
w3c Schema naming patterns and template-based schema generation Steve Jorgensen XML 0 08-09-2005 08:05 AM
[XML Schema] Including a schema document with absent target namespace to a schema with specified target namespace Stanimir Stamenkov XML 3 04-25-2005 09:59 AM
[ASL] the Active Schema Language : a new schema technology Philippe Poulard XML 0 03-21-2005 09:23 AM
XML schema regular expressions question and recommended XML Schema book Fred Smith XML 1 02-05-2004 11:12 AM



Advertisments