Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > Net::Ldap pb with SASL under multidomain MS Lan.

Reply
Thread Tools

Net::Ldap pb with SASL under multidomain MS Lan.

 
 
jean-charles Gibier
Guest
Posts: n/a
 
      07-21-2008
Hello,

I had to connect several Ldap servers under MS Lan via Net::Ldap module
My Attempts fails and I receive an "invalid credential".
I suspect that SASL layer does not handle this service as SSPI does.
Can someone confirm ?
Is there any other solution to do that ?


 
Reply With Quote
 
 
 
 
jean-charles Gibier
Guest
Posts: n/a
 
      07-21-2008

"jean-charles Gibier" <(E-Mail Removed)> a écrit dans le
message de news: 48849f97$0$24362$(E-Mail Removed)...
> Hello,
>
> I had to connect several Ldap servers under MS Lan via Net::Ldap module


I forgot :
several ldap servers "located in external ms domains"


> My Attempts fails and I receive an "invalid credential".
> I suspect that SASL layer does not handle this service as SSPI does.
> Can someone confirm ?
> Is there any other solution to do that ?
>
>



 
Reply With Quote
 
 
 
 
Jean-Charles Gibier
Guest
Posts: n/a
 
      07-21-2008
Leon Timmermans a écrit :
> On Mon, 21 Jul 2008 16:38:16 +0200, jean-charles Gibier wrote:
>
>> Hello,
>>
>> I had to connect several Ldap servers under MS Lan via Net::Ldap module
>> My Attempts fails and I receive an "invalid credential". I suspect that
>> SASL layer does not handle this service as SSPI does. Can someone
>> confirm ?
>> Is there any other solution to do that ?

>
> Really, we can't help you if you give that little information. Can you
> give a little more. A code sample, some information about how the AD is
> configured, etc...
>


I am sorry. I think I am a little disconnected with the topic because my
problem is not really in the code. The object is definitely well
instantiated and I can bind the AD server as far the "ldap user" is in
the same domain.
But if I want "bind" an "external" one I can't. I think this is due to
the limitation of the authentication layer used by the module.
I just want to know if i am right and if maybe someone is aware of that.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
implementing user based sasl mechanism sasl_novice Java 0 05-30-2008 05:17 AM
ASP.NET and SASL Amar ASP .Net Security 5 01-06-2006 04:26 PM
LDAP and SASL Amar ASP .Net Security 3 12-30-2005 05:26 AM
ssue on Net::LDAP sasl issue on windows 2000. Durairaj Avasi Perl Misc 1 04-09-2004 05:12 PM
LDAP_STRONG_AUTH_REQUIRED sasl issue with open ldap. Durairaj Avasi Perl 0 04-09-2004 02:08 PM



Advertisments