Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > Perl system call fails under windows 2003 server

Reply
Thread Tools

Perl system call fails under windows 2003 server

 
 
rahulkats@gmail.com
Guest
Posts: n/a
 
      06-14-2007
Hi,

I'm having trouble with perl system call. The system call calls
ntbackup.exe , the windows inbuilt utiility but the system errors out
by saying cannot find ntbackup.exe even after giving the full path.
I'm using windows 2003 server with Perl 5.8

Any suggestions?

Thanks

 
Reply With Quote
 
 
 
 
Ian Wilson
Guest
Posts: n/a
 
      06-15-2007
http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> Hi,
>
> I'm having trouble with perl system call. The system call calls
> ntbackup.exe , the windows inbuilt utiility but the system errors out
> by saying cannot find ntbackup.exe even after giving the full path.
> I'm using windows 2003 server with Perl 5.8
>
> Any suggestions?
>


This script works fine on my Windows XP PC:

#!perl
use strict;
use warnings;
my $args = 'ntbackup.exe';
system ($args) == 0
or die "system '$args' failed - $?";

What happens if you cut & paste (do not retype) the above into notepad,
save as tb.pl on your 2003 server and, from a command prompt type `perl
tb.pl`?

Cut & paste the script, the command line and any error message back into
a posting here.

Have you read `perldoc -f system`?
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ASPI32.DLL fails to load under Win Server 2003 64-bit =?Utf-8?B?R2lzIEJ1bg==?= Windows 64bit 0 08-03-2007 06:36 PM
Accessing ARGV[n] under SciTE fails; no problem under Command Window Richard Ruby 4 01-25-2007 05:58 PM
Windows 2003 Server or Exchange Server 2003 first????? Ozzie MCSA 1 11-30-2004 01:10 AM
Perl cgi on Windows 2003 Server fails Hallvard ?strem Perl Misc 8 06-16-2004 10:05 AM
LogonUser() Works Under NT4.0, Fails Under Win2K Mike ASP General 6 11-13-2003 09:13 PM



Advertisments