Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > Problem installing Test::Base

Reply
Thread Tools

Problem installing Test::Base

 
 
John Oliver
Guest
Posts: n/a
 
      04-10-2007
[root@sdtvm07 perl]# rpmbuild --rebuild
perl-Test-Base-0.52-2.fc6.src.rpm
Installing perl-Test-Base-0.52-2.fc6.src.rpm
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
warning: user mockbuild does not exist - using root
warning: group mockbuild does not exist - using root
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.27092
+ umask 022
+ cd /usr/src/redhat/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /usr/src/redhat/BUILD
+ rm -rf Test-Base-0.52
+ /usr/bin/gzip -dc /usr/src/redhat/SOURCES/Test-Base-0.52.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd Test-Base-0.52
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.27092
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd Test-Base-0.52
+ LANG=C
+ export LANG
+ unset DISPLAY
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
Checking if your kit is complete...
Looks good
Writing Makefile for Test::Base
+ make
cp lib/Test/Base/Filter.pm blib/lib/Test/Base/Filter.pm
cp lib/Module/Install/TestBase.pm blib/lib/Module/Install/TestBase.pm
cp lib/Test/Base.pm blib/lib/Test/Base.pm
Manifying blib/man3/Module::Install::TestBase.3pm
Manifying blib/man3/Test::Base::Filter.3pm
Manifying blib/man3/Test::Base.3pm
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.88840
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd Test-Base-0.52
+ LANG=C
+ export LANG
+ unset DISPLAY
+ rm -rf /var/tmp/perl-Test-Base-0.52-2-root-root
+ make pure_install
PERL_INSTALL_ROOT=/var/tmp/perl-Test-Base-0.52-2-root-root
Installing
/var/tmp/perl-Test-Base-0.52-2-root-root/usr/lib/perl5/vendor_perl/5.8.5/Test/Base.pm
Installing
/var/tmp/perl-Test-Base-0.52-2-root-root/usr/lib/perl5/vendor_perl/5.8.5/Test/Base/Filter.pm
Installing
/var/tmp/perl-Test-Base-0.52-2-root-root/usr/lib/perl5/vendor_perl/5.8.5/Module/Install/TestBase.pm
Installing
/var/tmp/perl-Test-Base-0.52-2-root-root/usr/share/man/man3/Module::Install::TestBase.3pm
Installing
/var/tmp/perl-Test-Base-0.52-2-root-root/usr/share/man/man3/Test::Base.3pm
Installing
/var/tmp/perl-Test-Base-0.52-2-root-root/usr/share/man/man3/Test::Base::Filter.3pm
Writing
/usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi/auto/Test/Base/.packlist
+ find /var/tmp/perl-Test-Base-0.52-2-root-root -type f -name .packlist
-exec rm -f '{}' ';'
+ find /var/tmp/perl-Test-Base-0.52-2-root-root -depth -type d -exec
rmdir '{}' ';'
+ chmod -R u+rwX,go+rX,go-w /var/tmp/perl-Test-Base-0.52-2-root-root/usr
+ /usr/lib/rpm/find-debuginfo.sh /usr/src/redhat/BUILD/Test-Base-0.52
0 blocks
find: /var/tmp/perl-Test-Base-0.52-2-root-root/usr/lib/debug: No such
file or directory
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip
/usr/bin/objdump
Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.53881
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd Test-Base-0.52
+ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/*.t
t/append.................ok
t/arguments..............ok
t/array..................ok
t/autoload...............ok
t/base64.................ok
t/blocks-scalar..........ok
t/blocks_grep............ok
t/chomp..................ok
t/chop...................ok
t/compact................ok
t/compile................ok
t/delimiters.............ok
t/description............ok
t/diff_is................NOK 1/3
# Failed test 'little diff
# @@ -1,7 +1,7 @@
# 1..1
# not ok 1 - little diff
# \# Failed test 'little diff'
# -\# in /tmp/test-blocks-321 at line 3.
# +\# at /tmp/test-blocks-321 line 3.
# \# got: 'a b c'
# \# expected: 'a b x'
# \# Looks like you failed 1 test of 1.
# '
# at t/diff_is.t line 16.
t/diff_is................NOK 2/3
# Failed test 'big diff
# @@ -15,5 +15,5 @@
# \# four
# \# +five
# \# '
# -\# in /tmp/test-blocks-321 at line 3.
# +\# at /tmp/test-blocks-321 line 3.
# \# Looks like you failed 1 test of 1.
# '
# at t/diff_is.t line 16.
t/diff_is................NOK 3/3
# Failed test 'diff with space - note: doesn't help point out the
extra space (yet)
# @@ -13,5 +13,5 @@
# \# +two
# \# three
# \# '
# -\# in /tmp/test-blocks-321 at line 3.
# +\# at /tmp/test-blocks-321 line 3.
# \# Looks like you failed 1 test of 1.
# '
# at t/diff_is.t line 16.
# Looks like you failed 3 tests of 3.
t/diff_is................dubious
Test returned status 3 (wstat 768, 0x300)
DIED. FAILED tests 1-3
Failed 3/3 tests, 0.00% okay
t/dumper.................ok
t/embed_perl.............ok
t/escape.................ok
t/eval...................ok
t/eval_all...............ok
t/eval_stderr............ok
t/eval_stdout............ok
t/export.................ok
t/filter_arguments.......ok
t/filter_delay...........ok
t/filter_functions.......ok
t/filters-append.........ok
t/filters................ok
t/filters_map............ok
t/first_block............ok
t/flatten................ok
t/get_url................skipped
all skipped: Need to figure out network testing
t/hash...................ok
t/head...................ok
t/internals..............ok
t/is.....................ok
t/jit-run................ok
t/join-deep..............ok
t/join...................ok
t/last...................ok
t/late...................ok
t/lazy-filters...........ok
t/lines..................ok
t/list...................ok
t/main_filters...........ok
t/multi-level-inherit....ok
t/name...................ok
t/next...................ok
t/no_diff................ok
t/no_plan................ok
t/normalize..............ok
t/only-with-implicit.....ok
t/only...................ok
t/oo.....................ok
t/oo_run.................ok
t/parentheses............ok
t/prepend................ok
t/preserve-order.........ok
t/prototypes.............ok
t/quick-plan.............ok
t/quick_test.............ok
t/read_file..............ok
t/regexp.................ok
t/repeated-filters.......ok
t/require................ok
t/reserved_names.........ok
t/reverse-deep...........ok
t/reverse................ok
t/run-args...............ok
t/run_compare............ok
t/run_is.................ok
t/run_is_deeply..........ok
t/run_like...............ok
t/run_unlike.............ok
t/simple.................ok
t/skip...................ok
t/slice..................ok
t/sort-deep..............ok
t/sort...................ok
t/spec_file..............ok
t/spec_string............ok
t/split-deep.............ok
t/split-regexp...........ok
t/split..................ok
t/strict-warnings........ok
t/strict.................ok
t/subclass-autoclass.....ok
t/subclass-import........ok
t/subclass...............ok
t/subclass_late..........ok
1/1 skipped: various reasons
t/tail...................ok
t/tie_output.............ok
t/trim...................ok
t/unchomp................ok
t/use-test-more..........ok
t/write_file.............ok
t/xxx....................ok
t/yaml...................ok
t/zero-blocks............ok
Failed Test Stat Wstat Total Fail List of Failed
-------------------------------------------------------------------------------
t/diff_is.t 3 768 3 3 1-3
1 test and 1 subtest skipped.
Failed 1/98 test scripts. 3/423 subtests failed.
Files=98, Tests=423, 23 wallclock secs ( 4.70 cusr + 13.92 csys = 18.62
CPU)
Failed 1/98 test programs. 3/423 subtests failed.
make: *** [test_dynamic] Error 255
error: Bad exit status from /var/tmp/rpm-tmp.53881 (%check)


RPM build errors:
user mockbuild does not exist - using root
group mockbuild does not exist - using root
user mockbuild does not exist - using root
group mockbuild does not exist - using root
Bad exit status from /var/tmp/rpm-tmp.53881 (%check)

--
* John Oliver http://www.john-oliver.net/ *
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing wireless USB Adapter =?Utf-8?B?cmZz?= Wireless Networking 2 07-10-2005 05:58 AM
Problem installing wireless card w/ Windows =?Utf-8?B?UmFuZGFsbA==?= Wireless Networking 0 03-28-2005 09:55 PM
problem installing firefox Brian Barringer Firefox 1 02-17-2005 06:01 PM
Problem installing modules on redhat 9 - strange connection problem championsleeper Perl Misc 0 01-26-2005 12:19 PM
Problem w/ Windows 98SE installing 802.11g router Wireless Networking 3 01-21-2005 01:08 AM



Advertisments