Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > Warning: Persistent ASP 0240 Bug in ActivePerl 5.8

Reply
Thread Tools

Warning: Persistent ASP 0240 Bug in ActivePerl 5.8

 
 
David Dickinson
Guest
Posts: n/a
 
      12-23-2006
Hello,

Running the following ASP web page on any version of ActivePerl 5.8.x under
any version of Win32/IIS returns an error:

----- BEGIN ASP CODE -----
<%@ LANGUAGE="PerlScript" %>
<%
$Response->End();
%>
----- END ASP CODE -----

The script will run correctly the first time but, if the page is refreshed
in the web browser, the following error message is displayed:

----- BEGIN ERROR MESSAGE -----
Active Server Pages error 'ASP 0240'

Script Engine Exception

/test.asp

A ScriptEngine threw exception 'C0000005' in
'IActiveScript::SetScriptState()' from 'CActiveScriptEngine::ReuseEngine()'.
----- END ERROR MESSAGE -----

Refreshing the web page in the browser allows for normal continuation. A
VBScript version of the same code does not result in this error message.

This problem has dire consequences. Many scripts which use, for instance,
$Response->Redirect() to a page that contains a $Response->End() can die.
All that the web site visitor sees is the error message. They don't know
that they can simply refresh the web page to get past the error.

This bug (ActiveState Bug 65223) has, as far as I know, existed in every
version of ActivePerl 5.8.

--
David Dickinson


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Persistent field and Persistent properties - difference gk Java 7 10-12-2010 09:43 PM
Upgrading from 32 bit ActivePerl-5.8.8.817 to 64 bit ActivePerl-5.8.8.819 Ted Perl Misc 7 12-16-2006 03:45 AM
There seems to be a bug in persistent cookies. =?Utf-8?B?dmJNYXJr?= ASP .Net 0 08-08-2005 03:25 PM
IIS 5.1 500 error in .asp pages after installing PHP/ActivePerl David ASP General 1 04-06-2004 01:17 PM
asp and activeperl on same iis5.0 machine bbxrider ASP General 2 12-03-2003 06:03 PM



Advertisments