Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > XML::Parser Installation error: XML-Parser-2.34

Reply
Thread Tools

XML::Parser Installation error: XML-Parser-2.34

 
 
Sean
Guest
Posts: n/a
 
      10-02-2006
I downloaded the XML-Parser module from
http://search.cpan.org/~msergeant/XML-Parser/Parser.pm
and I untar the source ball to $HOME/local/XML-Parser-2.34.
Can someone give me some helps? I appreciate!

Here is what I did and what errors I got:

1) sean$cd local/XML-Parser-2.34
2) XML-Parser-2.34$ ls
Changes Expat MANIFEST Makefile.PL Parser Parser.pm README blib
pm_to_blib samples t
3) XML-Parser-2.34$ perl Makefile.PL PREFIX=$HOME/local/perl
Writing Makefile for XML:arser::Expat
Writing Makefile for XML:arse
4) XML-Parser-2.34$ make
make[1]: Entering directory `/home/sean/local/XML-Parser-2.34/Expat'
cc -c -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBIAN
-fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -O2 -DVERSION=\"2.34\" -DXS_VERSION=\"2.34\"
-fPIC "-I/usr/lib/perl/5.8/CORE" Expat.c
Expat.xs:12:19: error: expat.h: No such file or directory
Expat.xs:60: error: syntax error before 'XML_Parser'
Expat.xs:60: warning: no semicolon at end of struct or union
Expat.xs:78: error: syntax error before ':' token
Expat.xs:79: error: syntax error before ':' token
Expat.xs:80: error: syntax error before ':' token
Expat.xs:106: error: syntax error before '}' token
Expat.xs:106: warning: data definition has no type or storage class
......(lots of similar errors)
make[1]: *** [Expat.o] Erro

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Airport Express in Win XP Prof SP2 installation problems. Jan-Willem Wireless Networking 1 02-03-2005 11:33 PM
No installation of USB wireless client Ray Wireless Networking 2 11-07-2004 03:30 AM
XP Pro installation and wireless problem =?Utf-8?B?SmVmZiBH?= Wireless Networking 2 10-20-2004 11:36 PM
Wireless connectivity lost after SP2 installation =?Utf-8?B?SGVucmlr?= Wireless Networking 5 10-20-2004 06:04 PM



Advertisments