Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Validation controls not working

Reply
Thread Tools

Validation controls not working

 
 
=?Utf-8?B?Q3JhaWcgSEI=?=
Guest
Posts: n/a
 
      10-28-2004
I have build a web form using asp.net validation controls to make sure the
users fill in the required fields and enter a valid email address for one of
the fields.

This works when I test it on the development server, but when I upload the
files to the production server, the validation controls don't do anything.
The production server has the .net framework, but not visual studio installed

Any ideas ? Thanks,
Craig
 
Reply With Quote
 
 
 
 
=?Utf-8?B?RGF2ZQ==?=
Guest
Posts: n/a
 
      10-28-2004
I Have had the same problem on Windows 2003. We had to re-install the .NET
Framework from scratch to get the controls working as was unable to find a
suitable answer to the problem.

"Craig HB" wrote:

> I have build a web form using asp.net validation controls to make sure the
> users fill in the required fields and enter a valid email address for one of
> the fields.
>
> This works when I test it on the development server, but when I upload the
> files to the production server, the validation controls don't do anything.
> The production server has the .net framework, but not visual studio installed
>
> Any ideas ? Thanks,
> Craig

 
Reply With Quote
 
 
 
 
=?Utf-8?B?c3Jpbmk=?=
Guest
Posts: n/a
 
      10-28-2004
Hi Craig,
Seems like the validation scripts are not correctly installed on the
production server. Try running aspnet_regiis -c and check.
Also check if the .net framework version is the same on both the servers or
not. (This might not always cause a problem though.)
HTH
srini

"Craig HB" wrote:

> I have build a web form using asp.net validation controls to make sure the
> users fill in the required fields and enter a valid email address for one of
> the fields.


 
Reply With Quote
 
Saravana
Guest
Posts: n/a
 
      10-28-2004
There can be two reasons for this.
1. If other controls like textbox is not displaying in the screen, then .NET
Framework is not installed properly. For more details refer this link,
http://www.extremeexperts.com/Net/FA...Appearing.aspx

2. Your validation scripts are not installed properly in IIS root directory.
To register client script again, use the following syntax
aspnet_regiis -c (to get the client-side scripts library added to your Web)


--
Saravana
http://dotnetjunkies.com/WebLog/saravana/
www.ExtremeExperts.com


"Craig HB" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> I have build a web form using asp.net validation controls to make sure the
> users fill in the required fields and enter a valid email address for one

of
> the fields.
>
> This works when I test it on the development server, but when I upload the
> files to the production server, the validation controls don't do anything.
> The production server has the .net framework, but not visual studio

installed
>
> Any ideas ? Thanks,
> Craig



 
Reply With Quote
 
=?Utf-8?B?Q3JhaWcgSEI=?=
Guest
Posts: n/a
 
      10-28-2004
Saravana , srini

you are both right : the validation scripts are not correctly installed. I
ran "aspnet_regiis -c" and it worked.

Thanks for the help,
Craig
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
validation controls not working, on 2003 server Jason Shohet ASP .Net 3 02-24-2004 07:16 PM
Validation Controls not working on different servers Juma ASP .Net 3 11-06-2003 04:59 PM
validation controls not working on production server earwicker ASP .Net 2 10-28-2003 04:30 PM
Re: ASP.Net Validation controls not working in netscape Srinivasa Raghavan Sethuraman ASP .Net 0 07-29-2003 09:14 PM
ASP.Net Validation controls not working in netscape Srinivasa Raghavan ASP .Net 3 07-29-2003 04:05 PM



Advertisments