Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > Beginner: Installing Perl Program

Reply
Thread Tools

Beginner: Installing Perl Program

 
 
Tomi Häsä
Guest
Posts: n/a
 
      05-16-2005
I installed Perl (ActivePerl 5.8.6 Build 811) for Windows 2000 to
directory C:\Perl. I think Perl was installed succesfully, because I
can execute the test program:

C:\Perl\eg>perl example.pl
Hello from ActivePerl!

But when I try to install MIME-tools 6.110 (needs Perl), I get the
following:

C:\mimetools\MIME-tools-6.200_02>perl Makefile.PL
Checking if your kit is complete...
Looks good
Warning: prerequisite IO::Stringy 1.211 not found.
Warning: prerequisite Mail::Field 1.05 not found.
Warning: prerequisite Mail::Header 1.01 not found.
Warning: prerequisite Mail::Internet 1.0203 not found.
Warning: prerequisite Unicode::Map 0.112 not found.
Writing Makefile for MIME-tools

C:\mimetools\MIME-tools-6.200_02>make test
make.exe: *** No rule to make target `C:\Perl\lib^', needed by
`Makefile'. Stop.

C:\MIMETO~1\MIME-T~1.200>make install
make.exe: *** No rule to make target `C:\Perl\lib^', needed by
`Makefile'. Stop.

Here's the Makefile.PL:

--->---------------------------------------->---
#!/usr/bin/perl
use ExtUtils::MakeMaker;
WriteMakefile(
NAME => "MIME-tools",
VERSION => "6.200_02",
# VERSION_FROM => "lib/MIME/Tools.pm",
PREREQ_PM => {"Mail::Header" => 1.01,
"Mail::Internet" => 1.0203,
"Mail::Field" => 1.05,

"MIME::QuotedPrint" => 2.03,
"MIME::Base64" => 2.04,
"IO::Stringy" => 1.211,
"File::Spec" => 0.6,
"File:ath" => 1,
"Unicode::String" => 2.06,
"Unicode::Map" => 0.112,
},
'dist' => {
# PREOP =>"cvu_perl_preop -B -f -m MIME::Tools",
PREOP => "pod2text lib/MIME/Tools.pm >! README",
COMPRESS =>'gzip',
SUFFIX =>'gz',
},
);
---<----------------------------------------<---

 
Reply With Quote
 
 
 
 
A. Sinan Unur
Guest
Posts: n/a
 
      05-16-2005
"Tomi Häsä" <(E-Mail Removed)> wrote in news:1116277548.973107.26340
@g47g2000cwa.googlegroups.com:

> I installed Perl (ActivePerl 5.8.6 Build 811) for Windows 2000 to
> directory C:\Perl. I think Perl was installed succesfully, because I
> can execute the test program:
>
> C:\Perl\eg>perl example.pl
> Hello from ActivePerl!
>
> But when I try to install MIME-tools 6.110 (needs Perl), I get the
> following:


If you are using ActiveState Perl, you should use ppm to search for and
install packages. That way, you don't have to have a compiler compatible
with the one that was used to compile ActiveState's distribution.

Please look in the "ActiveState Perl" program group, accessible through
the Start -> Programs menu. There are links to documentation, and the
ppm shell in there.

ppm will automatically download and install any prerequisites as well.

Sinan
--
A. Sinan Unur <(E-Mail Removed)>
(reverse each component and remove .invalid for email address)

comp.lang.perl.misc guidelines on the WWW:
http://mail.augustmail.com/~tadmc/cl...uidelines.html
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FAQ 1.13 Is it a Perl program or a Perl script? PerlFAQ Server Perl Misc 0 04-11-2011 04:00 AM
FAQ 1.13 Is it a Perl program or a Perl script? PerlFAQ Server Perl Misc 0 01-20-2011 11:00 AM
Is it a Perl program or a Perl script? business one way Digital Photography 0 01-05-2008 04:40 PM
Perl 'system' Creates Program That Dies When First C Program Dies Christopher M. Lusardi Perl Misc 3 10-19-2003 11:53 AM
Perl Help - Windows Perl script accessing a Unix perl Script dpackwood Perl 3 09-30-2003 02:56 AM



Advertisments