Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > Problem installing module

Reply
Thread Tools

Problem installing module

 
 
Geoff Soper
Guest
Posts: n/a
 
      01-22-2005
I'm trying to install Digest::SHA1 in my userspace on my web hosting
account. I'm not familiar with the process but think I have followed the
instructions properly i.e.:

perl Makefile.PL PREFIX=/home/alphaworks/perl_modules
make
make test
make install

But then when trying to use this module I get
Can't locate Digest/SHA1.pm in @INC (@INC contains:
/home/alphaworks/perl_modules ...

The precise output from the terminal during installation and a check to see
what was addedis shown below. I would have expected
/home/alphaworks/perl_modules/Digest/SHA1.pm to exist though.

Can anyone see what is going wrong here?

Thanks,
Geoff

************************************************** *****************

bash-2.05a$ perl Makefile.PL PREFIX=/home/alphaworks/perl_modules/
Checking if your kit is complete...
Looks good
Writing Makefile for Digest::SHA1

bash-2.05a$ make
cp SHA1.pm blib/lib/Digest/SHA1.pm
/usr/bin/perl -I/usr/lib/perl5/5.6.1/i386-linux -I/usr/lib/perl5/5.6.1
/usr/lib/perl5/5.6.1/ExtUtils/xsubpp -typemap
/usr/lib/perl5/5.6.1/ExtUtils/typemap -typemap typemap SHA1.xs > SHA1.xsc &&
mv SHA1.xsc SHA1.c
gcc -c -fno-strict-aliasing -I/usr/local/include -O2 -march=i386 -mcpu=i686
-DVERSION=\"2.10\" -DXS_VERSION=\"2.10\" -fPIC -I/usr/lib/perl5/5.6.1/i386-linux/CORE
SHA1.c
Running Mkbootstrap for Digest::SHA1 ()
chmod 644 SHA1.bs
rm -f blib/arch/auto/Digest/SHA1/SHA1.so
LD_RUN_PATH="" gcc -shared -L/usr/local/lib SHA1.o -o
blib/arch/auto/Digest/SHA1/SHA1.so
chmod 755 blib/arch/auto/Digest/SHA1/SHA1.so
cp SHA1.bs blib/arch/auto/Digest/SHA1/SHA1.bs
chmod 644 blib/arch/auto/Digest/SHA1/SHA1.bs
Manifying blib/man3/Digest::SHA1.3pm

bash-2.05a$ make test
PERL_DL_NONLAZY=1
/usr/bin/perl -Iblib/arch -Iblib/lib -I/usr/lib/perl5/5.6.1/i386-linux -I/usr/lib/perl5/5.6.1
-e 'use Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;'
t/*.t
t/badfile....ok
t/bits.......ok
t/sha1.......ok
All tests successful.
Files=3, Tests=17, 0 wallclock secs ( 0.05 cusr + 0.04 csys = 0.09 CPU)

bash-2.05a$ make install
Installing
/home/alphaworks/perl_modules/lib/perl5/site_perl/5.6.1/i386-linux/auto/Digest/SHA1/SHA1.so
Installing
/home/alphaworks/perl_modules/lib/perl5/site_perl/5.6.1/i386-linux/auto/Digest/SHA1/SHA1.bs
Files found in blib/arch: installing files in blib/lib into architecture
dependent library tree
Installing
/home/alphaworks/perl_modules/lib/perl5/site_perl/5.6.1/i386-linux/Digest/SHA1.pm
Installing /home/alphaworks/perl_modules/share/man/man3/Digest::SHA1.3pm
Writing
/home/alphaworks/perl_modules//lib/perl5/site_perl/5.6.1/i386-linux/auto/Digest/SHA1/.packlist
/bin/sh: /perllocal.pod: Permission denied
make: [doc_site_install] Error 1 (ignored)
Appending installation info to
/home/alphaworks/perl_modules//lib/5.6.1/i386-linux/perllocal.pod

bash-2.05a$ cat
/home/alphaworks/perl_modules//lib/5.6.1/i386-linux/perllocal.pod
cat: /home/alphaworks/perl_modules//lib/5.6.1/i386-linux/perllocal.pod: No
such file or directory

bash-2.05a$ ls -lR /home/alphaworks/perl_modules/
/home/alphaworks/perl_modules/:
total 8
drwxr-xr-x 3 alphawor alphawor 4096 Jan 22 12:23 lib
drwxr-xr-x 3 alphawor alphawor 4096 Jan 22 12:23 share
/home/alphaworks/perl_modules/lib:
total 4
drwxr-xr-x 3 alphawor alphawor 4096 Jan 22 12:23 perl5
/home/alphaworks/perl_modules/lib/perl5:
total 4
drwxr-xr-x 3 alphawor alphawor 4096 Jan 22 12:23 site_perl
/home/alphaworks/perl_modules/lib/perl5/site_perl:
total 4
drwxr-xr-x 3 alphawor alphawor 4096 Jan 22 12:23 5.6.1
/home/alphaworks/perl_modules/lib/perl5/site_perl/5.6.1:
total 4
drwxr-xr-x 4 alphawor alphawor 4096 Jan 22 12:23 i386-linux
/home/alphaworks/perl_modules/lib/perl5/site_perl/5.6.1/i386-linux:
total 8
drwxr-xr-x 3 alphawor alphawor 4096 Jan 22 12:23 auto
drwxr-xr-x 2 alphawor alphawor 4096 Jan 22 12:23 Digest
/home/alphaworks/perl_modules/lib/perl5/site_perl/5.6.1/i386-linux/auto:
total 4
drwxr-xr-x 3 alphawor alphawor 4096 Jan 22 12:23 Digest
/home/alphaworks/perl_modules/lib/perl5/site_perl/5.6.1/i386-linux/auto/Digest:
total 4
drwxr-xr-x 2 alphawor alphawor 4096 Jan 22 12:23 SHA1
/home/alphaworks/perl_modules/lib/perl5/site_perl/5.6.1/i386-linux/auto/Digest/SHA1:
total 20
-r--r--r-- 1 alphawor alphawor 0 Jan 22 12:22 SHA1.bs
-r-xr-xr-x 1 alphawor alphawor 19498 Jan 22 12:22 SHA1.so
/home/alphaworks/perl_modules/lib/perl5/site_perl/5.6.1/i386-linux/Digest:
total 8
-r--r--r-- 1 alphawor alphawor 6823 Apr 5 2004 SHA1.pm
/home/alphaworks/perl_modules/share:
total 4
drwxr-xr-x 3 alphawor alphawor 4096 Jan 22 12:23 man
/home/alphaworks/perl_modules/share/man:
total 4
drwxr-xr-x 2 alphawor alphawor 4096 Jan 22 12:23 man3
/home/alphaworks/perl_modules/share/man/man3:
total 12
-r--r--r-- 1 alphawor alphawor 11546 Jan 22 12:22 Digest::SHA1.3pm


 
Reply With Quote
 
 
 
 
Gunnar Hjalmarsson
Guest
Posts: n/a
 
      01-22-2005
Geoff Soper wrote:
> I'm trying to install Digest::SHA1 in my userspace on my web hosting
> account. I'm not familiar with the process but think I have followed the
> instructions properly i.e.:
>
> perl Makefile.PL PREFIX=/home/alphaworks/perl_modules
> make
> make test
> make install
>
> But then when trying to use this module I get
> Can't locate Digest/SHA1.pm in @INC (@INC contains:
> /home/alphaworks/perl_modules ...
>
> The precise output from the terminal during installation and a check to see
> what was addedis shown below. I would have expected
> /home/alphaworks/perl_modules/Digest/SHA1.pm to exist though.


<snip>

> /home/alphaworks/perl_modules/lib/perl5/site_perl/5.6.1/i386-linux/Digest/SHA1.pm

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

--
Gunnar Hjalmarsson
Email: http://www.gunnar.cc/cgi-bin/contact.pl
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: Problem when Installing PyML module modules with mingw32 Rich Healey Python 0 11-05-2008 04:49 AM
Re: Problem when Installing PyML module modules with mingw32 Rich Healey Python 0 11-05-2008 02:25 AM
Re: module docstring, documentation,anything? please note is the module type/object NOT some module Maric Michaud Python 0 06-24-2006 12:42 PM
installing my own module: module not recognized Darren Dale Python 2 07-20-2004 01:51 PM
Problem installing BerkeleyDB Module Gerard Perl 0 07-05-2004 12:06 AM



Advertisments