Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > PAR with active state: Compress::Zlib object version 1.22 does notmatch bootstrap parameter 1.16

Reply
Thread Tools

PAR with active state: Compress::Zlib object version 1.22 does notmatch bootstrap parameter 1.16

 
 
Graham Wood
Guest
Posts: n/a
 
      06-25-2004
Can anyone advise me how to get pp to work with activestate perl
Binary build 638 provided by ActiveState Corp. http://www.ActiveState.com
ActiveState is a division of Sophos.
Built Apr 13 2004 19:24:21

I've just installed this build of Perl on win2k and then the PAR module
as supplied by ActiveState and running pp gives me this error.

Do I have to get a C compiler and the source for version 1.16 of the
Compress::Zlib module or is there a less labour intensive way of getting
executables built with lots of modules included without having to buy a
license for something?

I'm assuming I can't hack anything without rebuilding the xs parts of
the compress::Zlib module.

Suggestions welcome

Thanks

Graham

 
Reply With Quote
 
 
 
 
Alan Stewart
Guest
Posts: n/a
 
      06-25-2004
On Fri, 25 Jun 2004 17:48:39 +0100, Graham Wood
<(E-Mail Removed)> wrote:

>Can anyone advise me how to get pp to work with activestate perl
>Binary build 638 provided by ActiveState Corp. http://www.ActiveState.com
>ActiveState is a division of Sophos.
>Built Apr 13 2004 19:24:21
>
>I've just installed this build of Perl on win2k and then the PAR module
>as supplied by ActiveState and running pp gives me this error.
>
>Do I have to get a C compiler and the source for version 1.16 of the
>Compress::Zlib module or is there a less labour intensive way of getting
>executables built with lots of modules included without having to buy a
>license for something?
>
>I'm assuming I can't hack anything without rebuilding the xs parts of
>the compress::Zlib module.
>
>Suggestions welcome
>
>Thanks
>
>Graham


It's a mismatch between the version of Zlib with your ActiveState Perl
and the Zlib in the pre-built PAR package. Someone could build the PAR
package to match, but you don't have a compiler and I don't have Zlib
1.22 installed.

You could download the zip file copy of ActiveState build 635 and
extract just site\lib\Compress\ and site\lib\auto\Compress\ to
downgrade to version 1.16.

Or try the PAR mailing list to see if anyone has a pre-built to match.

Alan

 
Reply With Quote
 
 
 
 
Graham Wood
Guest
Posts: n/a
 
      06-26-2004
Alan Stewart wrote:
> You could download the zip file copy of ActiveState build 635 and
> extract just site\lib\Compress\ and site\lib\auto\Compress\ to
> downgrade to version 1.16.


Thanks Allen, I'll try the binary 635 build option.

Graham

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The located assembly's manifest definition with name '.....' does notmatch the assembly reference JB ASP .Net 0 05-06-2008 03:28 PM
Re: Where to get stand alone Dot Net Framework version 1.1, version 2.0, version 3.0, version 3.5, version 2.0 SP1, version 3.0 SP1 ? PA Bear [MS MVP] ASP .Net 0 02-05-2008 03:28 AM
Re: Where to get stand alone Dot Net Framework version 1.1, version 2.0, version 3.0, version 3.5, version 2.0 SP1, version 3.0 SP1 ? V Green ASP .Net 0 02-05-2008 02:45 AM
DBD::mysql object version 2.9003 does not match bootstrap parameter vetolimits@yahoo.com Perl Misc 0 03-04-2005 03:59 PM
IO object version 1.21 does not match bootstrap parameter 1.18 Eugene Borukhovich Perl Misc 3 11-26-2004 09:23 PM



Advertisments