Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > SSH and Math::Pari prereq on AIX5.1

Reply
Thread Tools

SSH and Math::Pari prereq on AIX5.1

 
 
W. Van Hooste
Guest
Posts: n/a
 
      06-15-2004
problem
I try to install Net::SSH:erl (instead of Net::SSH). And have lots
of problems with the compilation of prereq Math:ari and GP/PARI...


environment
I'm installing on a RS/6000 with a PPC604 processor but want to do the
same on more recent ones like POWER4 (I am using AIX 5.1).


details
No idea if the problem is GP/PARI or Math:ari but GP/PARI returns
some incorrect values but installes, and Math:ari failes during the
"make test"...

The AIX detection in GP/PARI does not seem to be correct. I tried
editing arch-osname and the Makefile and even tried the GP/PARI alpha
version - withouth improved results.

==> I think this should be "RS/6000" or "Power" instead of "aix"
....Processor of family `aix' detected
#### Do not know how to build for assembler `aix'. ####
#### Reversing to assembler-less type `port'. ####
#### ####
#### If you think your processor's assembler is supported ####
#### by PARI, edit libPARI/Makefile.PL and report. ####
#### ####
#### Alternatively, specify machine=YOURTYPE on the ####
#### perl Makefile.PL line ####
#### Recognized types: ####
#### alpha hppa m86k none sparcv7 sparcv8 sparcv8_micro ####
#### sparcv8_super ix86 ####

==>During compilation of Math:ari I notice that it completely
ignores the fact i have no native C-compiler but use gcc...
cc: unrecognized option `-qmaxmem=16384'
cc: unrecognized option `-q32'
cc: unrecognized option `-qlonglong'

==>but it compiles nevertheless!
Target "all" is up to date.
....
Target "makemakerdflt" is up to date.
/usr/bin/make -- OK

==>And then we have the dissapointment...
t/00_Pari...........ok 127/127FAILED test 109
Failed 1/127 tests, 99.21% okay
t/PlotRect..........# Can't locate Term/Gnuplot.pm in @INC, ignoring
the test
skipped: Can't locate Term/Gnuplot.pm in @INC
t/analyz............ok
t/elliptic..........ok
t/graph.............# Can't locate Term/Gnuplot.pm in @INC, ignoring
plotting
t/graph.............ok, 1/28 skipped: plot() - can't test it yet
t/linear............ok
t/nfields...........ok 23/161PARI: *** Warning: insufficient
precision for f
t/nfields...........ok 156/161PARI: *** Warning: not a fundamental
discrimin
t/nfields...........ok
t/number............ok
t/objets............ok, 1/62 skipped: test producing error unsupported
yet (impo
t/ploth.............# Can't locate Term/Gnuplot.pm in @INC, ignoring
plotting
t/ploth.............ok, 10/34 skipped: various reasons
t/polyser...........ok
t/program...........ok, 13/37 skipped: various reasons
t/sumiter...........ok
t/trans.............ok
Failed Test Status Wstat Total Fail Failed List of failed
-------------------------------------------------------------------------------
t/00_Pari.t 127 1 0.79% 109
1 test and 25 subtests skipped.
Failed 1/14 test scripts, 92.86% okay. 1/823 subtests failed, 99.88%
okay.
make: The error code from the last command is 255.
Stop.
/usr/bin/make test -- NOT OK
Running make install
make test had returned bad status, won't install without force

==>I did try force install and then installation of Crypt::Random
(prereq) failed with PARI errors!


All help is welcome!
 
Reply With Quote
 
 
 
 
Ilya Zakharevich
Guest
Posts: n/a
 
      06-16-2004
[A complimentary Cc of this posting was sent to
W. Van Hooste
<(E-Mail Removed)>], who wrote in article <(E-Mail Removed) >:

> ==>During compilation of Math:ari I notice that it completely
> ignores the fact i have no native C-compiler but use gcc...
> cc: unrecognized option `-qmaxmem=16384'
> cc: unrecognized option `-q32'
> cc: unrecognized option `-qlonglong'


Apparently, your Perl is misconfigured. README/INSTALL to see how
(un)supported such a configuration is.

> Failed Test Status Wstat Total Fail Failed List of failed
> -------------------------------------------------------------------------------
> t/00_Pari.t 127 1 0.79% 109


I do not remember what 109 checks. Can't check it for a couple of weeks too...

> ==>I did try force install and then installation of Crypt::Random
> (prereq) failed with PARI errors!


Crypt::Random was absolutely broken (w.r.t. PARI object creation)
until very recently. Any appearance of it working was a pure
coincidence.

Hope this helps,
Ilya

P.S. My mail is extremely unreliable in the last two weeks.
 
Reply With Quote
 
 
 
 
W. Van Hooste
Guest
Posts: n/a
 
      06-17-2004
http://www.velocityreviews.com/forums/(E-Mail Removed) (W. Van Hooste) wrote in message news:<(E-Mail Removed). com>...
> problem
> I try to install Net::SSH:erl (instead of Net::SSH). And have lots
> of problems with the compilation of prereq Math:ari and GP/PARI...


I decided NOT to use Net::SSH:erl; to mutch: prereq's, broken
packages, unsupported systems and not flexible enough. I wanted to
provide the password interactive (1 time only) and run stuff using SCP
and SSH on abouth 100 systems (all AIX). Net::SSH:erl makes it
possible to provide that password via a scalar. My current (and
second) choice => Bundle::Expect handles this nicely...
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
net/ssh in ruby. ssh.exec fails salamond Ruby 0 02-17-2011 03:16 AM
NET:SSH fails authentification with :keys - ssh works Tench Johnson Ruby 1 04-23-2010 12:11 AM
python ssh and Tetia SSH server loial Python 0 02-10-2009 01:06 PM
Python ssh with SSH Tectia server loial Python 0 02-03-2009 03:38 PM
SSH Module: Accessing CLI box using SSH and not getting the return output?? Deepika Perl Misc 2 11-14-2006 04:48 AM



Advertisments