Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > A problem while testing MPEG-LibMPEG3-0.01

Reply
Thread Tools

A problem while testing MPEG-LibMPEG3-0.01

 
 
xern
Guest
Posts: n/a
 
      12-04-2003
The error message is as follows.

Can't load 'blib/arch/auto/MPEG/LibMPEG3/LibMPEG3.so' for module
MPEG::LibMPEG3:
blib/arch/auto/MPEG/LibMPEG3/LibMPEG3.so: undefined symbol:
mpeg3_seek_percentage at
/usr/local/lib/perl5/5.8.1/i686-linux/DynaLoader.pm line 229. at
test.pl line 18

I've got libmpeg3.a successfully installed, and have written a C
program to test libmpeg3, which was good. I'm curious about why this
error would happen. The author's email seems broken, so I cannot reach
him for the answer. Hope someone can give me the solution.

Thanks in advance.
 
Reply With Quote
 
 
 
 
Ben Morrow
Guest
Posts: n/a
 
      12-04-2003

http://www.velocityreviews.com/forums/(E-Mail Removed) (xern) wrote:
> The error message is as follows.
>
> Can't load 'blib/arch/auto/MPEG/LibMPEG3/LibMPEG3.so' for module
> MPEG::LibMPEG3:
> blib/arch/auto/MPEG/LibMPEG3/LibMPEG3.so: undefined symbol:
> mpeg3_seek_percentage at
> /usr/local/lib/perl5/5.8.1/i686-linux/DynaLoader.pm line 229. at
> test.pl line 18
>
> I've got libmpeg3.a successfully installed, and have written a C
> program to test libmpeg3, which was good. I'm curious about why this
> error would happen. The author's email seems broken, so I cannot reach
> him for the answer. Hope someone can give me the solution.


Are the versions compatible? What do you get from

nm /path/to/libmpeg3.a | grep mpeg3_seek_percentage

?

Ben

--
'Deserve [death]? I daresay he did. Many live that deserve death. And some die
that deserve life. Can you give it to them? Then do not be too eager to deal
out death in judgement. For even the very wise cannot see all ends.'
:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-:-: (E-Mail Removed)
 
Reply With Quote
 
 
 
 
xern
Guest
Posts: n/a
 
      12-08-2003
Ben Morrow <(E-Mail Removed)> wrote in message news:<bqo0ms$sn2$(E-Mail Removed)>...
> (E-Mail Removed) (xern) wrote:
> > The error message is as follows.
> >
> > Can't load 'blib/arch/auto/MPEG/LibMPEG3/LibMPEG3.so' for module
> > MPEG::LibMPEG3:
> > blib/arch/auto/MPEG/LibMPEG3/LibMPEG3.so: undefined symbol:
> > mpeg3_seek_percentage at
> > /usr/local/lib/perl5/5.8.1/i686-linux/DynaLoader.pm line 229. at
> > test.pl line 18
> >
> > I've got libmpeg3.a successfully installed, and have written a C
> > program to test libmpeg3, which was good. I'm curious about why this
> > error would happen. The author's email seems broken, so I cannot reach
> > him for the answer. Hope someone can give me the solution.

>
> Are the versions compatible? What do you get from
>
> nm /path/to/libmpeg3.a | grep mpeg3_seek_percentage
>

Hmm, seems the perl module doesn't follow up to libmpeg3.

Anyway, thanks.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
testing testing 123 neville Computer Support 7 06-28-2005 05:06 PM
testing testing neville Computer Support 16 06-05-2005 09:02 PM
testing testing neville Computer Support 2 05-27-2005 09:57 AM
testing testing 123 daniel edwards Computer Support 4 05-20-2004 10:36 PM
testing--news2004--testing Boomer Computer Support 3 09-24-2003 06:54 PM



Advertisments