Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > Installing DBD::Sybase on MAC

Reply
Thread Tools

Installing DBD::Sybase on MAC

 
 
Vijoy Varghese
Guest
Posts: n/a
 
      10-20-2003
Hello Group,

I want to access a MSSQL database(on WIN-NT) from my MAC.
After some googling I found that for this I have to install
DBD:Sybase. But before that I need to install the 'Sybase OpenClient
Libraries' and then edit the SYBASE variablein CONFIG file of
DBD:Sybase installation so that it points to the 'Sybase OpenClient
Libraries'.
So first of all I had to install the OpenClient libraries, for this
after some googling i found that I can get it from
http://linux.sybase.com. But with my little knowledge about Sybase, I
was lost in that webpage and confused about what to download.

Then again some googling and found this link
http://www.linuxgazette.com/issue18/sybase.html, even though it is a
bit aged page(most links are broken), I got the name
'ctlib-linux-elf.tar.gz'. Did some googling on that name and found
this link
URL http://ring.csi.ad.jp/archives/net/w...nux-elf.tar.gz,
the file is that of 1997. I extracted the contents to /usr/local
Everything fine upto this...

Then I tried to install DBD::Sybase
Edited the SYBASE variable in CONFIG to '/usr/local/sybase' and then
ran perl Makefile.PL
This is what I got as output

##### Start ###########
[diffeocuments/vijoy/DBD-Sybase-1.01] admin# perl Makefile.PL
Sybase OpenClient 10.0.3 found.
The DBD::Sybase module need access to a Sybase server to run the
tests.
To clear an entry please enter 'undef'
Sybase server to use (default: troll): undef
User ID to log in to Sybase (default: sa): undef
Password (default: undef): undef
Sybase database to use on undef (default: undef): undef
Checking if your kit is complete...
Looks good
Note (probably harmless): No library found for -ldl
Multiple copies of Driver.xst found in: /Library/Perl/darwin/auto/DBI
/Library/Perl/darwin/auto/DBI at Makefile.PL line 55
Using DBI 1.37 installed in /Library/Perl/darwin/auto/DBI
Writing Makefile for DBD::Sybase
###### End ###########

About multiple copis of Driver.xst, I can see only one copy out there.
Contents of /Library/Perl/darwin/auto/DBI
#### Start ####
-rw-r--r-- 1 root admin 1976 Jul 1 12:55 .packlist
-r--r--r-- 1 root admin 0 Jul 1 12:55 DBI.bs
-r-xr-xr-x 1 root admin 93680 Jul 1 12:55 DBI.bundle
-r--r--r-- 1 root admin 18391 May 13 06:54 DBIXS.h
-r--r--r-- 1 root admin 15513 May 13 07:00 Driver.xst
-r--r--r-- 1 root admin 3254 Sep 13 2002 Driver_xst.h
-r--r--r-- 1 root admin 2531 Feb 26 2003 dbd_xsh.h
-r--r--r-- 1 root admin 3475 Feb 6 2002 dbi_sql.h
-r--r--r-- 1 root admin 14789 Jul 15 2002 dbipport.h
#### End ####

So I thought this is some 'harmless' error and continued with the
installation.
Next was 'make', and I got this
#### Start ####
[thediffeocuments/vijoy/DBD-Sybase-1.01] admin# make
cp dbd-sybase.pod blib/lib/DBD/dbd-sybase.pod
cp Sybase.pm blib/lib/DBD/Sybase.pm
/usr/bin/perl -p -e "s/~DRIVER~/Sybase/g" <
/Library/Perl/darwin/auto/DBI/Driver.xst > Sybase.xsi
/usr/bin/perl /Library/Perl/ExtUtils/xsubpp -typemap
/Library/Perl/ExtUtils/typemap Sybase.xs > Sybase.xsc && mv
Sybase.xsc Sybase.c
cc -c -I/usr/local/sybase/include -I/Library/Perl/darwin/auto/DBI
-pipe -fno-common -no-cpp-precomp -fno-strict-aliasing -O3
-DVERSION=\"1.01\" -DXS_VERSION=\"1.01\"
"-I/Library/Perl/darwin/CORE" Sybase.c
cc -c -I/usr/local/sybase/include -I/Library/Perl/darwin/auto/DBI
-pipe -fno-common -no-cpp-precomp -fno-strict-aliasing -O3
-DVERSION=\"1.01\" -DXS_VERSION=\"1.01\"
"-I/Library/Perl/darwin/CORE" dbdimp.c
Running Mkbootstrap for DBD::Sybase ()
chmod 644 Sybase.bs
rm -f blib/arch/auto/DBD/Sybase/Sybase.bundle
LD_RUN_PATH="/usr/local/sybase/lib:/usr/lib" cc
-L/usr/local/sybase/lib -flat_namespace -bundle -undefined suppress
Sybase.o dbdimp.o -o blib/arch/auto/DBD/Sybase/Sybase.bundle
-L/usr/local/sybase/lib -lct -lcs -ltcl -lcomn -lintl -linsck -lm
ld: malformed table of contents in: /usr/local/sybase/lib/libct.a
(ranlib struct 0 library member offset not a multiple of 4 bytes,
can't load from it)
ld: malformed table of contents in: /usr/local/sybase/lib/libcs.a
(ranlib struct 1 library member offset not a multiple of 4 bytes,
can't load from it)
ld: malformed table of contents in: /usr/local/sybase/lib/libcomn.a
(ranlib struct 0 library member offset not a multiple of 4 bytes,
can't load from it)
ld: malformed table of contents in: /usr/local/sybase/lib/libintl.a
(ranlib struct 0 library member offset not a multiple of 4 bytes,
can't load from it)
make: *** [blib/arch/auto/DBD/Sybase/Sybase.bundle] Error 1
#### End ####

What could be wrong?

Please help,

Thanking you
Vijoy Varghese
 
Reply With Quote
 
 
 
 
Michael Peppler
Guest
Posts: n/a
 
      10-21-2003
On Sun, 19 Oct 2003 22:51:51 -0700, Vijoy Varghese wrote:

> Hello Group,
>
> I want to access a MSSQL database(on WIN-NT) from my MAC.
> After some googling I found that for this I have to install
> DBD:Sybase. But before that I need to install the 'Sybase OpenClient
> Libraries' and then edit the SYBASE variablein CONFIG file of
> DBD:Sybase installation so that it points to the 'Sybase OpenClient
> Libraries'.
> So first of all I had to install the OpenClient libraries, for this
> after some googling i found that I can get it from
> http://linux.sybase.com. But with my little knowledge about Sybase, I
> was lost in that webpage and confused about what to download.
>
> Then again some googling and found this link
> http://www.linuxgazette.com/issue18/sybase.html, even though it is a
> bit aged page(most links are broken), I got the name
> 'ctlib-linux-elf.tar.gz'.


First, Sybase's OpenClient package doesn't work with MS-SQL 7.x or 2K.
Second, how could the *linux* version of OpenClient ever work on your
MacOSX box??? The underlying architecture is completely different!

Anyway - you should look at FreeTDS (http://www.freetds.org/) for a
library that will allow you to access MS-SQL from your MacOSX box.

Michael
--
Michael Peppler Data Migrations, Inc.
http://www.velocityreviews.com/forums/(E-Mail Removed) http://www.mbay.net/~mpeppler
Sybase T-SQL/OpenClient/OpenServer/C/Perl developer available for short or
long term contract positions - http://www.mbay.net/~mpeppler/resume.html

 
Reply With Quote
 
 
 
 
Vijoy Varghese
Guest
Posts: n/a
 
      10-22-2003
Thank you Michael
Hehehe, the only reply I got was from the 'author of DBD::Sybase'? I
am excited...

A few questions...


"Michael Peppler" <(E-Mail Removed)> wrote in message

> First, Sybase's OpenClient package doesn't work with MS-SQL 7.x or 2K.
> Second, how could the *linux* version of OpenClient ever work on your
> MacOSX box??? The underlying architecture is completely different!


What about installing 'Free BSD Intel' from
http://linux.sybase.com/ase/11033download.html.
Will this work on a Mac osX and DBD::Sybase?
If it does, should I install both files to get it work with
DBD::Sybase?

sybase-ocsd-10.0.4-FreeBSD-6.i386.tgz AND
sybase-ase-11.0.3.3-FreeBSD-6.i386.tgz

> Anyway - you should look at FreeTDS (http://www.freetds.org/) for a
> library that will allow you to access MS-SQL from your MacOSX box.

At the same time, I am trying to install freetds on Mac, but some
complications with libtool and Mac, anyways I am getting good support
from freetds mailing-group
[http://lists.ibiblio.org/pipermail/f...4/014109.html], so
hoping to solve my problems soon.

Regards
Vijoy~
 
Reply With Quote
 
Michael Peppler
Guest
Posts: n/a
 
      10-22-2003
On Tue, 21 Oct 2003 22:10:05 -0700, Vijoy Varghese wrote:

> "Michael Peppler" <(E-Mail Removed)> wrote in message
>
>> First, Sybase's OpenClient package doesn't work with MS-SQL 7.x or 2K.
>> Second, how could the *linux* version of OpenClient ever work on your
>> MacOSX box??? The underlying architecture is completely different!

>
> What about installing 'Free BSD Intel' from
> http://linux.sybase.com/ase/11033download.html.
> Will this work on a Mac osX and DBD::Sybase?
> If it does, should I install both files to get it work with
> DBD::Sybase?
>
> sybase-ocsd-10.0.4-FreeBSD-6.i386.tgz AND
> sybase-ase-11.0.3.3-FreeBSD-6.i386.tgz


No - this FreeBSD on intel - it won't work on your PPC Mac!

Michael
--
Michael Peppler Data Migrations, Inc.
(E-Mail Removed) http://www.mbay.net/~mpeppler
Sybase T-SQL/OpenClient/OpenServer/C/Perl developer available for short or
long term contract positions - http://www.mbay.net/~mpeppler/resume.html

 
Reply With Quote
 
Vijoy Varghese
Guest
Posts: n/a
 
      10-23-2003
"Michael Peppler" <(E-Mail Removed)> wrote in message news:<(E-Mail Removed)>. ..
> On Tue, 21 Oct 2003 22:10:05 -0700, Vijoy Varghese wrote:


> No - this FreeBSD on intel - it won't work on your PPC Mac!


Okay, thanks Micheal, any ways, i dumped this open client from sybase,
and went for freebsd.

If your a person looking for a solution for a similar goad (access
mssql from mac), please check these posts...

http://lists.ibiblio.org/pipermail/f...q4/014109.html
http://lists.ibiblio.org/pipermail/f...q4/014139.html

HTH,
Regards
Vijoy~
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Python 3000 on Leopard (Mac OS) fails... André Python 6 11-27-2007 07:21 PM
Mac os x 10.4.11: Error installing Python 2.5.1 David Python 5 11-18-2007 05:29 AM
I'm having trouble installing TomCat on my mac. reyes Java 3 10-12-2007 01:40 PM
Installing mod_python on mac os 10.4.7 7stud Python 14 07-30-2007 08:21 AM
What is the reasoning behind Windows "installing" programs and the way Mac does? Marc Computer Support 8 05-06-2005 09:00 PM



Advertisments