Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > POD docs and ANSI escapes

Reply
Thread Tools

POD docs and ANSI escapes

 
 
Sisyphus
Guest
Posts: n/a
 
      09-27-2003
Hi,
On my linux box 'perldoc' (but not 'man') is failing to interpret the
ANSI escapes. How do I remedy this ?

I'm seeing:
ESC[1mNAMEESC[0m
instead of:
NAME

(Is this answered in the faq somewhere ? I have a feeling it is, but
couldn't find it.)

Cheers,
Rob
--
To reply by email u have to take out the u in kalinaubears.

 
Reply With Quote
 
 
 
 
James Willmore
Guest
Posts: n/a
 
      09-27-2003
On Sat, 27 Sep 2003 22:29:36 +1000
Sisyphus <(E-Mail Removed)> wrote:
> Hi,
> On my linux box 'perldoc' (but not 'man') is failing to interpret
> the ANSI escapes. How do I remedy this ?
>
> I'm seeing:
> ESC[1mNAMEESC[0m
> instead of:
> NAME
>
> (Is this answered in the faq somewhere ? I have a feeling it is, but
>
> couldn't find it.)


The "quick fix" is to run perldoc with the '-t' option.

I tend to remember having the same issue, but it was a _long_ time
ago. I _think_ you _may_ have to change the language setting to
something more "sane" (like en_US). Do an 'echo $LANG' if in bash to
see what it's set to now. However, I could be wrong about this.

HTH

--
Jim

Copyright notice: all code written by the author in this post is
released under the GPL. http://www.gnu.org/licenses/gpl.txt
for more information.

a fortune quote ...
I'm a Lisp variable -- bind me!

 
Reply With Quote
 
 
 
 
Steve Grazzini
Guest
Posts: n/a
 
      09-27-2003
James Willmore <(E-Mail Removed)> wrote:
> On Sat, 27 Sep 2003 22:29:36 +1000
> Sisyphus <(E-Mail Removed)> wrote:
> > Hi,
> > On my linux box 'perldoc' (but not 'man') is failing to interpret
> > the ANSI escapes. How do I remedy this ?
> >
> > I'm seeing:
> > ESC[1mNAMEESC[0m
> > instead of:
> > NAME
> >
> > (Is this answered in the faq somewhere ? I have a feeling it is, but
> >
> > couldn't find it.)

>
> The "quick fix" is to run perldoc with the '-t' option.


You can also set the LESS environment variable to "-r".

--
Steve
 
Reply With Quote
 
Sisyphus
Guest
Posts: n/a
 
      09-28-2003
Steve Grazzini wrote:
> James Willmore <(E-Mail Removed)> wrote:
>
>>On Sat, 27 Sep 2003 22:29:36 +1000
>>Sisyphus <(E-Mail Removed)> wrote:
>>
>>>Hi,
>>>On my linux box 'perldoc' (but not 'man') is failing to interpret
>>>the ANSI escapes. How do I remedy this ?
>>>


>>
>>The "quick fix" is to run perldoc with the '-t' option.

>
>
> You can also set the LESS environment variable to "-r".
>


Thanks guys.

Cheers,
Rob


--
To reply by email u have to take out the u in kalinaubears.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pre-ansi to ansi c++ conversion? Frank Iannarilli C++ 2 07-21-2009 11:05 PM
Are there statistics packages in ANSI C and/or ANSI C++? lbrtchx@gmail.com C Programming 11 04-28-2008 03:00 AM
Are there statistics packages in ANSI C and/or ANSI C++? lbrtchx@gmail.com C++ 1 04-24-2008 06:44 PM
Is array of POD still a POD type? Ajax Chelsea C++ 1 12-01-2003 01:56 PM
A (probable) error in perltoot ( perl5/5.8.0/pod/perltoot.pod, line number 756 ) Himanshu Garg Perl Misc 1 09-21-2003 03:28 AM



Advertisments