Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > ---Module Installation Image::Info

Reply
Thread Tools

---Module Installation Image::Info

 
 
Bill Zhao
Guest
Posts: n/a
 
      09-15-2003
Hi, Dear all

I am old starter of per and is showing a program to my boss but
the program error without Image::Info
I then start to install this module but the result is wrong.
The beow is screen copy:

Somebody can help me to fix this progrmam.

Bill Zhao


==========================Screencopy============== ==================
[root@bz2003 mapivi0144]# perl -MCPAN -e shell

cpan shell -- CPAN exploration and modules installation (v1.59_54)
ReadLine support available (try 'install Bundle::CPAN')

cpan> install Image::Info
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Database was generated on Sun, 14 Sep 2003 15:45:40 GMT
Running install for module Image::Info
Running make for G/GA/GAAS/Image-Info-1.12.tar.gz

CPAN: MD5 security checks disabled because MD5 not installed.
Please consider installing the MD5 module.

Scanning cache /root/.cpan/build for sizes
Image-Info-1.12/
Image-Info-1.12/test.ppm
Image-Info-1.12/test.png
Image-Info-1.12/Changes
Image-Info-1.12/test.xpm
Image-Info-1.12/MANIFEST
Image-Info-1.12/t/
Image-Info-1.12/t/exif.t
Image-Info-1.12/t/string.t
Image-Info-1.12/t/dim.t
Image-Info-1.12/t/png.t
Image-Info-1.12/t/bmp.t
Image-Info-1.12/lib/
Image-Info-1.12/lib/Image/
Image-Info-1.12/lib/Image/Info/
Image-Info-1.12/lib/Image/Info/XBM.pm
Image-Info-1.12/lib/Image/Info/BMP.pm
Image-Info-1.12/lib/Image/Info/TIFF.pm
Image-Info-1.12/lib/Image/Info/XPM.pm
Image-Info-1.12/lib/Image/Info/GIF.pm
Image-Info-1.12/lib/Image/Info/JPEG.pm
Image-Info-1.12/lib/Image/Info/PPM.pm
Image-Info-1.12/lib/Image/Info/PNG.pm
Image-Info-1.12/lib/Image/Info/SVG.pm
Image-Info-1.12/lib/Image/TIFF.pm
Image-Info-1.12/lib/Image/Info.pm
Image-Info-1.12/test.txt
Image-Info-1.12/test.xbm
Image-Info-1.12/test.jpg
Image-Info-1.12/test.svg
Image-Info-1.12/test.pbm
Image-Info-1.12/test.pgm
Image-Info-1.12/exifdump
Image-Info-1.12/imgdump
Image-Info-1.12/test.gif
Image-Info-1.12/Info.pm.tmpl
Image-Info-1.12/Makefile.PL
Image-Info-1.12/README
Image-Info-1.12/test.rle
Removing previously used /root/.cpan/build/Image-Info-1.12

CPAN.pm: Going to build G/GA/GAAS/Image-Info-1.12.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for Image::Info
cp lib/Image/Info/BMP.pm blib/lib/Image/Info/BMP.pm
cp lib/Image/Info/SVG.pm blib/lib/Image/Info/SVG.pm
cp lib/Image/Info/TIFF.pm blib/lib/Image/Info/TIFF.pm
cp lib/Image/Info.pm blib/lib/Image/Info.pm
cp lib/Image/Info/XBM.pm blib/lib/Image/Info/XBM.pm
cp lib/Image/Info/GIF.pm blib/lib/Image/Info/GIF.pm
cp lib/Image/Info/JPEG.pm blib/lib/Image/Info/JPEG.pm
cp lib/Image/Info/PNG.pm blib/lib/Image/Info/PNG.pm
cp lib/Image/Info/XPM.pm blib/lib/Image/Info/XPM.pm
cp lib/Image/Info/PPM.pm blib/lib/Image/Info/PPM.pm
cp lib/Image/TIFF.pm blib/lib/Image/TIFF.pm
Manifying blib/man3/Image::Info::XPM.3pm
Manifying blib/man3/Image::Info::BMP.3pm
Manifying blib/man3/Image::Info::SVG.3pm
Manifying blib/man3/Image::Info.3pm
Manifying blib/man3/Image::Info::XBM.3pm
/usr/bin/make -- OK
Running make test
PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
-I/usr/lib/perl5/5.6.1/i386-linux -I/usr/lib/perl5/5.6.1 -e 'use
Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;' t/*.t
t/bmp...............ok

t/dim...............ok

t/exif..............dubious

Test returned status 0 (wstat 11, 0xb)
t/png...............ok

t/string............dubious

Test returned status 0 (wstat 11, 0xb)
Failed Test Status Wstat Total Fail Failed List of Failed
--------------------------------------------------------------------------------
t/exif.t 0 11 ?? ?? % ??
t/string.t 0 11 ?? ?? % ??
Failed 2/5 test scripts, 60.00% okay. 0/8 subtests failed, 100.00% okay.
make: *** [test_dynamic] Error 2
/usr/bin/make test -- NOT OK
Running make install
-----------------------------------------------------------------------------------
===================Screen copy end===========================

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Airport Express in Win XP Prof SP2 installation problems. Jan-Willem Wireless Networking 1 02-03-2005 11:33 PM
No installation of USB wireless client Ray Wireless Networking 2 11-07-2004 03:30 AM
XP Pro installation and wireless problem =?Utf-8?B?SmVmZiBH?= Wireless Networking 2 10-20-2004 11:36 PM
Wireless connectivity lost after SP2 installation =?Utf-8?B?SGVucmlr?= Wireless Networking 5 10-20-2004 06:04 PM



Advertisments