Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Perl > Perl Misc > Perl build script woes doing Source Safe get

Reply
Thread Tools

Perl build script woes doing Source Safe get

 
 
Marc S. Gibian
Guest
Posts: n/a
 
      08-22-2003
I have a Perl script that I have been using to perform builds. This
script uses the source safe command line to fetch files into the
workspace before doing any building. It does very rigorous error
checking to be sure no problems go unnoticed during the build process.
The fetch portion of this script has worked well for a number of
months.

Yesterday I implemented a new feature. The original script fetched the
latest version of all files, performed the build, and then at the very
end attached a build label to the latest version of all files (hoping
there had been no divergence between the fetch and the label steps).
My change is to very early in the build label the latest version of
the files, and then fetch the labeled version of all files. This is
failing, reporting an error 25600, "No such file or directory".

I tested one last variation... I took the current script and removed
the label argument from the get command and this is now failing with
the same 25600 error.

The command line(s) I am using are:

ss get $/project -R -I-Y -V"MYBUILDLABEL"

ss get $/project -R -I-Y

Immediately prior to the get I do a ss Workfold to set the working
folder to the desired target location, and that is succeeding with no
problem. I have tried running the command line by hand in a shell
window and THAT works without error.

My questions:

1 - Why is source safe reporting a non-zero error code? What error is
it reporting?

2 - Is my script just being overly sensitive to warnings and such, or
is there something here I can fix so that the "get" begins returning
zero (again)?

Thanks very much for your help,
Marc
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
C++ calling perl script - Not able to get the stack arguments pushedrom XPUSH in perl script Yogi Perl Misc 1 09-13-2012 11:30 AM
How to check if the value of a variable is numeric in build maven build script? nalakainfo Java 0 01-31-2007 04:55 AM
Adding a web application project to source control (Visual Source Safe) ~~~ .NET Ed ~~~ ASP .Net 1 02-26-2005 02:20 PM
SWsoft Acronis Disk Director Suite 9.0 Build 508, Acronis OS Selector 8.0 Build 917, Acronis Partition Expert 2003 Build 292, Acronis Power Utilities 2004 Build 502, F-SECURE.ANTI vIRUS.PROXY v1.10.17.WINALL, F-SECURE.ANTI vIRUS v5.50.10260 for CITRI vvcd Computer Support 0 09-25-2004 01:38 AM
Perl Help - Windows Perl script accessing a Unix perl Script dpackwood Perl 3 09-30-2003 02:56 AM



Advertisments