Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > File or assembly name or one of its dependencies, was not found.

Reply
Thread Tools

File or assembly name or one of its dependencies, was not found.

 
 
jlea
Guest
Posts: n/a
 
      10-04-2004
I'm receiving the error message shown below when I try to load an aspx file
(C# web application) on our server. The web application works fine if I
remove the reference to the dll so I know the application and IIS are both
ok. I ran depends on the dll and all referenced dlls are either in system32
or in the bin directory of the web application. I suspect it is some kind of
security issue.

Any help will be greatly appreciated.

Jon Lea

Parser Error Message: File or assembly name LeapSoft.Engr.Utils, or one of
its dependencies, was not found.

=== Pre-bind state information ===
LOG: DisplayName = LeapSoft.Engr.Utils
(Partial)
LOG: Appbase = file:///E:/Pub/JL/TestWebApplication1
LOG: Initial PrivatePath = bin
Calling assembly : (Unknown).
===

LOG: Policy not being applied to reference at this time (private, custom,
partial, or location-based assembly bind).
LOG: Post-policy reference: LeapSoft.Engr.Utils
LOG: Attempting download of new URL
file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/jltestwebsite1/3b1b703f/74d67837/LeapSoft.Engr.Utils.DLL.
LOG: Attempting download of new URL
file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/jltestwebsite1/3b1b703f/74d67837/LeapSoft.Engr.Utils/LeapSoft.Engr.Uti
ls.DLL.
LOG: Attempting download of new URL
file:///E:/Pub/JL/TestWebApplication1/bin/LeapSoft.Engr.Utils.DLL.
LOG: Policy not being applied to reference at this time (private, custom,
partial, or location-based assembly bind).
LOG: Post-policy reference: LeapSoft.Engr.Utils, Version=1.0.1733.19648,
Culture=neutral, PublicKeyToken=null


 
Reply With Quote
 
 
 
 
=?Utf-8?B?Q293Ym95IChHcmVnb3J5IEEuIEJlYW1lcikgLSBNVlA=?=
Guest
Posts: n/a
 
      10-04-2004
The error you are getting is a code access security exception. This means the
assembly you are working with (your project) cannot access the other assembly
or the other assembly cannot access some software it needs to work.

You can edit the machine.config to open security policy (there is also a
tool for this). Better yet, you can adjust the security for your particular
project (noting that an executable that is distributed to clients needs to
have the same security).

For your global assemblies, you can put them in the Global Assembly cache
and erase most exceptions. Most likely the issue is the assemblies in
System32.


---

Gregory A. Beamer
MVP; MCP: +I, SE, SD, DBA

***************************
Think Outside the Box!
***************************

"jlea" wrote:

> I'm receiving the error message shown below when I try to load an aspx file
> (C# web application) on our server. The web application works fine if I
> remove the reference to the dll so I know the application and IIS are both
> ok. I ran depends on the dll and all referenced dlls are either in system32
> or in the bin directory of the web application. I suspect it is some kind of
> security issue.
>
> Any help will be greatly appreciated.
>
> Jon Lea
>
> Parser Error Message: File or assembly name LeapSoft.Engr.Utils, or one of
> its dependencies, was not found.
>
> === Pre-bind state information ===
> LOG: DisplayName = LeapSoft.Engr.Utils
> (Partial)
> LOG: Appbase = file:///E:/Pub/JL/TestWebApplication1
> LOG: Initial PrivatePath = bin
> Calling assembly : (Unknown).
> ===
>
> LOG: Policy not being applied to reference at this time (private, custom,
> partial, or location-based assembly bind).
> LOG: Post-policy reference: LeapSoft.Engr.Utils
> LOG: Attempting download of new URL
> file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
> Files/jltestwebsite1/3b1b703f/74d67837/LeapSoft.Engr.Utils.DLL.
> LOG: Attempting download of new URL
> file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
> Files/jltestwebsite1/3b1b703f/74d67837/LeapSoft.Engr.Utils/LeapSoft.Engr.Uti
> ls.DLL.
> LOG: Attempting download of new URL
> file:///E:/Pub/JL/TestWebApplication1/bin/LeapSoft.Engr.Utils.DLL.
> LOG: Policy not being applied to reference at this time (private, custom,
> partial, or location-based assembly bind).
> LOG: Post-policy reference: LeapSoft.Engr.Utils, Version=1.0.1733.19648,
> Culture=neutral, PublicKeyToken=null
>
>
>

 
Reply With Quote
 
 
 
 
jlea
Guest
Posts: n/a
 
      10-04-2004
Thanks for the good info. Where in the .NET IDE or IIS do I adjust the
security for the project? Jon.

"Cowboy (Gregory A. Beamer) - MVP" <(E-Mail Removed)> wrote
in message news:(E-Mail Removed)...
> The error you are getting is a code access security exception. This means

the
> assembly you are working with (your project) cannot access the other

assembly
> or the other assembly cannot access some software it needs to work.
>
> You can edit the machine.config to open security policy (there is also a
> tool for this). Better yet, you can adjust the security for your

particular
> project (noting that an executable that is distributed to clients needs to
> have the same security).
>
> For your global assemblies, you can put them in the Global Assembly cache
> and erase most exceptions. Most likely the issue is the assemblies in
> System32.
>
>
> ---
>
> Gregory A. Beamer
> MVP; MCP: +I, SE, SD, DBA
>
> ***************************
> Think Outside the Box!
> ***************************
>
> "jlea" wrote:
>
> > I'm receiving the error message shown below when I try to load an aspx

file
> > (C# web application) on our server. The web application works fine if I
> > remove the reference to the dll so I know the application and IIS are

both
> > ok. I ran depends on the dll and all referenced dlls are either in

system32
> > or in the bin directory of the web application. I suspect it is some

kind of
> > security issue.
> >
> > Any help will be greatly appreciated.
> >
> > Jon Lea
> >
> > Parser Error Message: File or assembly name LeapSoft.Engr.Utils, or one

of
> > its dependencies, was not found.
> >
> > === Pre-bind state information ===
> > LOG: DisplayName = LeapSoft.Engr.Utils
> > (Partial)
> > LOG: Appbase = file:///E:/Pub/JL/TestWebApplication1
> > LOG: Initial PrivatePath = bin
> > Calling assembly : (Unknown).
> > ===
> >
> > LOG: Policy not being applied to reference at this time (private,

custom,
> > partial, or location-based assembly bind).
> > LOG: Post-policy reference: LeapSoft.Engr.Utils
> > LOG: Attempting download of new URL
> > file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
> > Files/jltestwebsite1/3b1b703f/74d67837/LeapSoft.Engr.Utils.DLL.
> > LOG: Attempting download of new URL
> > file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
> >

Files/jltestwebsite1/3b1b703f/74d67837/LeapSoft.Engr.Utils/LeapSoft.Engr.Uti
> > ls.DLL.
> > LOG: Attempting download of new URL
> > file:///E:/Pub/JL/TestWebApplication1/bin/LeapSoft.Engr.Utils.DLL.
> > LOG: Policy not being applied to reference at this time (private,

custom,
> > partial, or location-based assembly bind).
> > LOG: Post-policy reference: LeapSoft.Engr.Utils, Version=1.0.1733.19648,
> > Culture=neutral, PublicKeyToken=null
> >
> >
> >



 
Reply With Quote
 
jlea
Guest
Posts: n/a
 
      10-04-2004
I forgot to mention that the server is Win2000. When I run the same web
application from an NT machine (using IE) to my XP-Pro machine (running IIS)
within the intranet, all is good.

"jlea" <(E-Mail Removed)> wrote in message
news:uq%(E-Mail Removed)...
> Thanks for the good info. Where in the .NET IDE or IIS do I adjust the
> security for the project? Jon.
>
> "Cowboy (Gregory A. Beamer) - MVP" <(E-Mail Removed)>

wrote
> in message news:(E-Mail Removed)...
> > The error you are getting is a code access security exception. This

means
> the
> > assembly you are working with (your project) cannot access the other

> assembly
> > or the other assembly cannot access some software it needs to work.
> >
> > You can edit the machine.config to open security policy (there is also a
> > tool for this). Better yet, you can adjust the security for your

> particular
> > project (noting that an executable that is distributed to clients needs

to
> > have the same security).
> >
> > For your global assemblies, you can put them in the Global Assembly

cache
> > and erase most exceptions. Most likely the issue is the assemblies in
> > System32.
> >
> >
> > ---
> >
> > Gregory A. Beamer
> > MVP; MCP: +I, SE, SD, DBA
> >
> > ***************************
> > Think Outside the Box!
> > ***************************
> >
> > "jlea" wrote:
> >
> > > I'm receiving the error message shown below when I try to load an aspx

> file
> > > (C# web application) on our server. The web application works fine if

I
> > > remove the reference to the dll so I know the application and IIS are

> both
> > > ok. I ran depends on the dll and all referenced dlls are either in

> system32
> > > or in the bin directory of the web application. I suspect it is some

> kind of
> > > security issue.
> > >
> > > Any help will be greatly appreciated.
> > >
> > > Jon Lea
> > >
> > > Parser Error Message: File or assembly name LeapSoft.Engr.Utils, or on

e
> of
> > > its dependencies, was not found.
> > >
> > > === Pre-bind state information ===
> > > LOG: DisplayName = LeapSoft.Engr.Utils
> > > (Partial)
> > > LOG: Appbase = file:///E:/Pub/JL/TestWebApplication1
> > > LOG: Initial PrivatePath = bin
> > > Calling assembly : (Unknown).
> > > ===
> > >
> > > LOG: Policy not being applied to reference at this time (private,

> custom,
> > > partial, or location-based assembly bind).
> > > LOG: Post-policy reference: LeapSoft.Engr.Utils
> > > LOG: Attempting download of new URL
> > > file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
> > > Files/jltestwebsite1/3b1b703f/74d67837/LeapSoft.Engr.Utils.DLL.
> > > LOG: Attempting download of new URL
> > > file:///C:/WINNT/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
> > >

>

Files/jltestwebsite1/3b1b703f/74d67837/LeapSoft.Engr.Utils/LeapSoft.Engr.Uti
> > > ls.DLL.
> > > LOG: Attempting download of new URL
> > > file:///E:/Pub/JL/TestWebApplication1/bin/LeapSoft.Engr.Utils.DLL.
> > > LOG: Policy not being applied to reference at this time (private,

> custom,
> > > partial, or location-based assembly bind).
> > > LOG: Post-policy reference: LeapSoft.Engr.Utils,

Version=1.0.1733.19648,
> > > Culture=neutral, PublicKeyToken=null
> > >
> > >
> > >

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
File or assembly name ... or one of its dependencies, was not found Fabian ASP .Net 1 01-27-2005 01:21 PM
System.IO.FileNotFoundException: File or assembly name xlq0jgak.dll, or one of its dependencies, was not found. Martinh ASP .Net 0 08-15-2004 04:30 PM
File or assembly name System, or one of its dependencies, was not found. aallee83 ASP .Net 2 05-26-2004 07:16 AM
File or assembly name "yufnisoc.dll", or one of its dependencies, was not found. D.C. ASP .Net 0 11-04-2003 10:07 PM
Strange, Illogical ASP.NET Bug: "File or assembly name, or one of its dependencies not found" Philipp Schumann ASP .Net 2 10-25-2003 05:05 PM



Advertisments