Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > Unrecognized tag prefix or device filter (Visual Studio 2010)

Reply
Thread Tools

Unrecognized tag prefix or device filter (Visual Studio 2010)

 
 
KhD KhD is offline
Junior Member
Join Date: Jul 2011
Posts: 2
 
      02-27-2012
I am trying my hands on Visual Studio 2010 (Asp.Net 4.0) for the first time. I want to use Ajax controls, mainly ComboBox control.

I followed the step-by-step procedure mentioned in this link to download and install AjavControlToolkit.

I also followed this link for steps to add ComboBox to my webpage.

But no matter what I do, there is a green line under the control and I'm getting the error "Unrecognized tag prefix or device filter 'ajax'".

My web.config file looks like this:

Code:
 <configuration>
       <system.web>
    <pages>
        <controls>
            <add tagPrefix="ajax" namespace="AjaxControlToolkit" assembly="AjaxControlToolkit"/>
            <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
            <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        </controls>
    </pages>
    <compilation debug="true" targetFramework="4.0">
        <assemblies>
            <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
            <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/></assemblies></compilation>
  </system.web>
    </configuration>
The aspx page looks like this:

Code:
<form id="form1" runat="server">
       <div>
        <asp:ScriptManager ID="sm" runat="server"></asp:ScriptManager>
        <ajax:ComboBox runat="server" AutoCompleteMode="SuggestAppend">
          <asp:ListItem>ddd</asp:ListItem>
          <asp:ListItem>fff</asp:ListItem>
          <asp:ListItem>gggg</asp:ListItem>
          <asp:ListItem>hhhhh</asp:ListItem>
        </ajax:ComboBox>    
       </div>
    </form>
I have even tried deleting the schema files from C:\Documents and Settings\xxx\Application Data\Microsoft\VisualStudio\10.0\ReflectedSchemas location.

Please help me in successfully implementing the Combobox control. Thanks!

Edited:

As a different approach, I created a new website and installed the latest version of AjaxControlToolkit using NuGet. I rebuilt the solution. I still could not see the Ajax controls in intellisense. Is there anything else that needs to be done to implement it? Please help!!
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help - Unrecognized tag prefix or device filter 'asp' and other weird errors in aspx file Alan Silver ASP .Net 0 02-06-2006 03:34 PM
Unrecognized tag prefix or device filter 'asp' Alan Silver ASP .Net 0 01-31-2006 05:16 PM
Unrecognized tag prefix or device filter 'asp' Simon ASP .Net 0 11-29-2005 07:26 AM
Unrecognized tag prefix or device filter 'asp' Simon ASP .Net 0 11-25-2005 02:30 PM
'asp' is an unrecognized tag prefix or device filter Roger Helliwell ASP .Net 2 11-22-2004 10:43 AM



Advertisments