Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > HTML > Site works in IE, fails in Firefox

Reply
Thread Tools

Site works in IE, fails in Firefox

 
 
Bob
Guest
Posts: n/a
 
      02-07-2012
http://www.wendybrown-barry.com/

Site is here. Created in Dreamweaver. Author added an element a while
back, and it somehow threw all of the links to the left and to the
very bottom. If you look in IE, all of the links are at the top and on
the right. He can't figure out how to fix it, and neither can I.

Any help?
 
Reply With Quote
 
 
 
 
Ben Bacarisse
Guest
Posts: n/a
 
      02-07-2012
Bob <(E-Mail Removed)> writes:

> http://www.wendybrown-barry.com/
>
> Site is here. Created in Dreamweaver. Author added an element a while
> back, and it somehow threw all of the links to the left and to the
> very bottom. If you look in IE, all of the links are at the top and on
> the right. He can't figure out how to fix it, and neither can I.


In my firefox it works if I make the window wide enough.

I'm pretty sure that what happened was that an image was added whose
width made the middle table so wide that there was no room for the one
on the right. Even if you fix the image (or whatever), the layout is
going to be very fragile: it's dependent on text sizes, browser window
width and so on.

Table for layout went out of style some years ago, but they did have the
advantage of being able to get round this sort of problem. If the whole
page was one table, the left and right columns would have to fit.

--
Ben.
 
Reply With Quote
 
 
 
 
Beauregard T. Shagnasty
Guest
Posts: n/a
 
      02-07-2012
Ben Bacarisse wrote:

> Bob <(E-Mail Removed)> writes:
>> http://www.wendybrown-barry.com/
>>
>> Site is here. Created in Dreamweaver. Author added an element a while
>> back, and it somehow threw all of the links to the left and to the very
>> bottom. If you look in IE, all of the links are at the top and on the
>> right. He can't figure out how to fix it, and neither can I.

>
> In my firefox it works if I make the window wide enough.
>
> I'm pretty sure that what happened was that an image was added whose
> width made the middle table so wide that there was no room for the one
> on the right. Even if you fix the image (or whatever), the layout is
> going to be very fragile: it's dependent on text sizes, browser window
> width and so on.


And just about every one of those images is being resized by the HTML
height and width attributes. It makes that waaaay-too-long page jump and
jitter as it loads. Each one of the images should be resized to what the
author wants them to be. Example:

http://www.wendybrown-barry.com/imag...LASHNEWWEB.jpg
214.33 KB (219,470 bytes)
600px × 741px (scaled to 187px × 226px)

As a bit of a test, I resized that image to 187x226 and optimized it for
web use, and reduced it from 214KB to 9KB.

--
-bts
-This space for rent, but the price is high
 
Reply With Quote
 
dorayme
Guest
Posts: n/a
 
      02-08-2012
In article
<(E-Mail Removed)>,
Bob <(E-Mail Removed)> wrote:

> http://www.wendybrown-barry.com/
>
> Site is here. Created in Dreamweaver. Author added an element a while
> back, and it somehow threw all of the links to the left and to the
> very bottom. If you look in IE, all of the links are at the top and on
> the right. He can't figure out how to fix it, and neither can I.
>
> Any help?


Good luck. This design is so awful that it might be illegal to help
you! <g>

Interestingly enough, to try to get a bit of aesthetic sanity, even if
you turn off the styles, the gaucheness remains almost wholly intact
which is telltale of one significant thing: the markup is very
purposively built to produce a certain look - never mind what! - all
on its ownsome. In other words, from the word go, the website is badly
flawed.

--
dorayme
 
Reply With Quote
 
Hot-Text
Guest
Posts: n/a
 
      02-09-2012
"Bob" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
> http://www.wendybrown-barry.com/
>
> Site is here. Created in Dreamweaver. Author added an element a while
> back, and it somehow threw all of the links to the left and to the
> very bottom. If you look in IE, all of the links are at the top and on
> the right. He can't figure out how to fix it, and neither can I.
>
> Any help?


<pre>


The Table with IMG Wendy Flash,
Yosemite Valley pic,
and Monarch Butterfly pic,
is where the Error at....

TABLE #A border=0 width="106%"
<< Error WebPage BODY is Default at
800Pixels...
#A width can only be 100%,
to over ride Body Default,

You need to use a Calculator,
to get the right Pixels widths,
to help over ride Body Default....

TD #1 height=250 width=190
TD #2 width=599
TD #3 width=228
190 + 599 + 228 = 1017Pixels
<< Error TABLE #A Body Default of 800Pixels
or width="1017"
All TD need a Height of 250 in them,
in the TABLE..

IMG "Wendy &amp; Flash" width=187 height=226
IMG "Yosemite Valley pic" width=583 height=228
IMG Monarch Butterfly pic" width=215 height=228


IMG Height 226 and 228 is ok for the TD is set to 250,
by Default it will move to TD Height 228,
But it would help to make TD to TD Height 228

IMG widths
width=187
width=583
width=215
= 984

Here is set to Pixels, to over ride Body Default of 800Pixels
and it can be a TABLE width="100%"
<TABLE border=0 width="100%" align=center>
Too will do the same,
if all the TD have same height in them..

<TABLE border=0 width="1017" align=center>
<TBODY>
<TR>
<TD height=250 width=190>
<DIV align=left>
<IMG alt="Wendy &amp; Flash" src="http://www.wendybrown barry.com/images/WENDY-FLASHNEWWEB.jpg" width=187 height=226>
</DIV>
</TD>
<TD height=250 width=599>
<DIV align=center>
<IMG border=0 alt="Yosemite Valley pic" src="http://www.wendybrown-barry.com/images/yosemiteCROPWEB.jpg" width=583 height=228>
</DIV>
</TD>
<TD height=250 width=228>
<IMG border=0 alt="Monarch Butterfly pic" src="http://www.wendybrown-barry.com/images/monarch1EDITWEB.jpg" width=215 height=228>
</TD>
</TR>
</TBODY>
</TABLE>



You need to do all webpage,
TABLE that pass 100 to width="100%",
or use a Calculator to get the right,
Pixels Widths in the TABLE
</pre>


--
User-agent: *
Disallow: /
 
Reply With Quote
 
Hot-Text
Guest
Posts: n/a
 
      02-09-2012
Bob
I see height=228> it here[[[]]]


<table width="100%" border="0" align="center">
<tr>
<td width="190" height="250"><div align="left"><img src="/images/WENDY-FLASHNEWWEB.jpg" alt="Wendy & Flash" width="187"
height="226"></div></td>
<td width="599"> [[[height="250">]]] <div align="center"><img src="/images/yosemiteCROPWEB.jpg" alt="Yosemite Valley pic"
width="583" height="228" border="0"></div></td>
<td width="228" height="250"><img src="/images/monarch1EDITWEB.jpg" alt="Monarch Butterfly pic" width="215" height="228"
border="0"></td>
</tr>
</table>


 
Reply With Quote
 
Hot-Text
Guest
Posts: n/a
 
      02-09-2012
"Beauregard T. Shagnasty" <(E-Mail Removed)> wrote in message news:jgs7jc$aqp$(E-Mail Removed)...
> Ben Bacarisse wrote:
>


Beauregard T. Shagnasty Right like always

> http://www.wendybrown-barry.com/imag...LASHNEWWEB.jpg
> 214.33 KB (219,470 bytes)
> 600px × 741px (scaled to 187px × 226px)
>
> As a bit of a test, I resized that image to 187x226 and optimized it for
> web use, and reduced it from 214KB to 9KB.


here Needs
< http://www.irfanview.com/ >
too do the residing and reduced for him..

< http://hot-text.ath.cx:81/Temp-Folde...LASHNEWWEB.jpg >
183 X 226 40.3 KB (41,269 bytes)
< http://hot-text.ath.cx:81/Temp-Folde...iteCROPWEB.jpg >
550 x 226 Pixels (2.43) 100 KB (102,409 bytes)

he need to Keep the height=226 at 226 Pixels

and he need put them is Thumbnails Folder name tnails...
http://www.wendybrown-barry.com/imag...LASHNEWWEB.jpg
And all use Save-As

If he need help with irfanview..
I know we can help him
for I do not have time to do all the Images for him...




--
User-agent: *
Disallow: /

 
Reply With Quote
 
Bob
Guest
Posts: n/a
 
      02-10-2012
On Feb 8, 6:52*pm, Hot-Text <(E-Mail Removed)> wrote:
> "Bob" <(E-Mail Removed)> wrote in messagenews:(E-Mail Removed)...
> >http://www.wendybrown-barry.com/

>
> > Site is here. Created in Dreamweaver. Author added an element a while
> > back, and it somehow threw all of the links to the left and to the
> > very bottom. If you look in IE, all of the links are at the top and on
> > the right. He can't figure out how to fix it, and neither can I.

>
> > Any help?

>
> <pre>
>
> The Table with IMG Wendy Flash,
> Yosemite Valley pic,
> and Monarch Butterfly pic,
> is where the Error at....
>
> TABLE #A border=0 width="106%"
> << Error WebPage BODY is Default at
> 800Pixels...
> #A width can only be 100%,
> to over ride Body Default,
>
> You need to use a Calculator,
> to get the right Pixels widths,
> to help over ride Body Default....
>
> TD #1 height=250 width=190
> TD #2 width=599
> TD #3 width=228
> 190 + 599 + 228 = 1017Pixels
> << Error TABLE #A Body Default of 800Pixels
> or width="1017"
> All TD need a Height of 250 in them,
> in the TABLE..
>
> IMG "Wendy &amp; Flash" width=187 height=226
> IMG "Yosemite Valley pic" width=583 height=228
> IMG Monarch Butterfly pic" width=215 height=228
>
> IMG Height 226 and 228 is ok for the TD is set to 250,
> by Default it will move to TD Height 228,
> But it would help to make TD to TD Height 228
>
> IMG widths
> width=187
> width=583
> width=215
> = 984
>
> Here is set to Pixels, to over ride Body Default of 800Pixels
> and it can be a TABLE width="100%"
> <TABLE border=0 width="100%" align=center>
> Too will do the same,
> if all the TD have same height in them..
>
> <TABLE border=0 width="1017" align=center>
> <TBODY>
> <TR>
> <TD height=250 width=190>
> <DIV align=left>
> <IMG alt="Wendy &amp; Flash" src="http://www.wendybrownbarry.com/images/WENDY-FLASHNEWWEB.jpg" width=187 height=226>
> </DIV>
> </TD>
> <TD height=250 width=599>
> <DIV align=center>
> <IMG border=0 alt="Yosemite Valley pic" src="http://www.wendybrown-barry.com/images/yosemiteCROPWEB.jpg" width=583 height=228>
> </DIV>
> </TD>
> <TD height=250 width=228>
> <IMG border=0 alt="Monarch Butterfly pic" src="http://www.wendybrown-barry.com/images/monarch1EDITWEB.jpg" width=215 height=228>
> </TD>
> </TR>
> </TBODY>
> </TABLE>
>
> You need to do all webpage,
> TABLE that pass 100 to width="100%",
> or use a Calculator to get the right,
> Pixels Widths in the TABLE
> </pre>
>
> --
> User-agent: *
> Disallow: /


Hi thx for this. We worked on it a lot. We got it to where the links
now are on the right properly in FF 8, but not in the latest version
of FF. In the latest version, all they did is move to the middle at
the bottom. My friend is about ready to give up.
 
Reply With Quote
 
Hot-Text
Guest
Posts: n/a
 
      02-10-2012
"Bob" <(E-Mail Removed)> wrote in message news:(E-Mail Removed)...
> On Feb 8, 6:52 pm, Hot-Text <(E-Mail Removed)> wrote:
>> "Bob" <(E-Mail Removed)> wrote in messagenews:(E-Mail Removed)...
>> >http://www.wendybrown-barry.com/

>>
>> > Site is here. Created in Dreamweaver. Author added an element a while
>> > back, and it somehow threw all of the links to the left and to the
>> > very bottom. If you look in IE, all of the links are at the top and on
>> > the right. He can't figure out how to fix it, and neither can I.

>>
>> > Any help?

>>
>> <pre>
>>
>> The Table with IMG Wendy Flash,
>> Yosemite Valley pic,
>> and Monarch Butterfly pic,
>> is where the Error at....
>>
>> TABLE #A border=0 width="106%"
>> << Error WebPage BODY is Default at
>> 800Pixels...
>> #A width can only be 100%,
>> to over ride Body Default,
>>
>> You need to use a Calculator,
>> to get the right Pixels widths,
>> to help over ride Body Default....
>>
>> TD #1 height=250 width=190
>> TD #2 width=599
>> TD #3 width=228
>> 190 + 599 + 228 = 1017Pixels
>> << Error TABLE #A Body Default of 800Pixels
>> or width="1017"
>> All TD need a Height of 250 in them,
>> in the TABLE..
>>
>> IMG "Wendy &amp; Flash" width=187 height=226
>> IMG "Yosemite Valley pic" width=583 height=228
>> IMG Monarch Butterfly pic" width=215 height=228
>>
>> IMG Height 226 and 228 is ok for the TD is set to 250,
>> by Default it will move to TD Height 228,
>> But it would help to make TD to TD Height 228
>>
>> IMG widths
>> width=187
>> width=583
>> width=215
>> = 984
>>
>> Here is set to Pixels, to over ride Body Default of 800Pixels
>> and it can be a TABLE width="100%"
>> <TABLE border=0 width="100%" align=center>
>> Too will do the same,
>> if all the TD have same height in them..
>>
>> <TABLE border=0 width="1017" align=center>
>> <TBODY>
>> <TR>
>> <TD height=250 width=190>
>> <DIV align=left>
>> <IMG alt="Wendy &amp; Flash" src="http://www.wendybrownbarry.com/images/WENDY-FLASHNEWWEB.jpg" width=187 height=226>
>> </DIV>
>> </TD>
>> <TD height=250 width=599>
>> <DIV align=center>
>> <IMG border=0 alt="Yosemite Valley pic" src="http://www.wendybrown-barry.com/images/yosemiteCROPWEB.jpg" width=583 height=228>
>> </DIV>
>> </TD>
>> <TD height=250 width=228>
>> <IMG border=0 alt="Monarch Butterfly pic" src="http://www.wendybrown-barry.com/images/monarch1EDITWEB.jpg" width=215 height=228>
>> </TD>
>> </TR>
>> </TBODY>
>> </TABLE>
>>
>> You need to do all webpage,
>> TABLE that pass 100 to width="100%",
>> or use a Calculator to get the right,
>> Pixels Widths in the TABLE
>> </pre>
>>
>> --
>> User-agent: *
>> Disallow: /

>
> Hi thx for this. We worked on it a lot. We got it to where the links
> now are on the right properly in FF 8, but not in the latest version
> of FF. In the latest version, all they did is move to the middle at
> the bottom. My friend is about ready to give up.


I look at it with IE8 see you was working on it at the time,
it look good!
Opera 11.61 Show loading but look good..


Firefox 8.0.1.4341 Look good, same as IE8 and Opera 11.61,
But like with Opera Show

A old Netscape Communicator 4.61
Look at it in Communicator Editor
is see 7 main Tables

for Netscape Communicator is just a good old tool,




--
User-agent: *
Disallow: /

 
Reply With Quote
 
Ben Bacarisse
Guest
Posts: n/a
 
      02-10-2012
Bob <(E-Mail Removed)> writes:

> On Feb 8, 6:52*pm, Hot-Text <(E-Mail Removed)> wrote:

<snip>
>> >http://www.wendybrown-barry.com/

>>
>> > Site is here. Created in Dreamweaver. Author added an element a while
>> > back, and it somehow threw all of the links to the left and to the
>> > very bottom. If you look in IE, all of the links are at the top and on
>> > the right. He can't figure out how to fix it, and neither can I.

<snip>
> Hi thx for this. We worked on it a lot. We got it to where the links
> now are on the right properly in FF 8, but not in the latest version
> of FF. In the latest version, all they did is move to the middle at
> the bottom. My friend is about ready to give up.


It seems to me that where the links are will depend on things like the
windows width and font sizes. These may vary from version to version,
but that's not the problem. The problem is that the design can't work
as is for all window widths and font sizes. I can make the links move
to the "right" place just my making the window a little wider or by
making the text a little smaller.

I don't think there is a real solution other than to re-design the page.
You have three tables that can't shrink because of all the fixed sizes
you are using, so there will always be cases where they don't fit across
the browser window. The old solution was to put tables in tables and I
image that would work (i.e. your three main tables become cells in a
giant on-row table) but that's a terrible design.

How hard would it be to start over a use a modern three-column flexible
layout?

--
Ben.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atlas and asp.net Image control not refreshing (firefox fails, IE6 works) PeterKellner ASP .Net 0 06-01-2006 09:19 PM
When I turn on my PC, it works, works, works. Problem! Fogar Computer Information 1 01-17-2006 12:57 AM
Firefox and XSLT (local stylesheet works, server-based stylesheet fails) David Blickstein XML 14 10-15-2005 11:27 PM
slideshow fails, Firefox debugger also fails lkrubner@geocities.com Javascript 2 12-23-2004 06:22 PM
After rebooting my PC works, works, works! Antivirus problem? Adriano Computer Information 1 12-15-2003 05:30 AM



Advertisments