Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > Startup & Shutdown

Reply
Thread Tools

Startup & Shutdown

 
 
Rajesh Huria
Guest
Posts: n/a
 
      05-27-2011
Hi All,

I am trying to execute the below mentioned code:
require 'test/unit'


class MyTest < Test::Unit::TestCase

class << self
def startup
puts "startup"

end

def shutdown

puts "shutdown"

end

end
def setup

puts "Test setup"

end


def teardown

puts "test teardown"

end



def test_test3

puts "test3"

end


def test_test1

puts "test1"

end


def test_test2

puts "test2"

end

end
Actual output:
Loaded suite unit_test_suite
Started
Test setup
test teardown
Test setup
test1
test teardown
Test setup
test2
test teardown
Test setup
test3
test teardown
 
Reply With Quote
 
 
 
 
Rajesh Huria
Guest
Posts: n/a
 
      05-27-2011
gem version: test-unit (2.3.0)

--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
 
Kouhei Sutou
Guest
Posts: n/a
 
      05-27-2011
Hi,

In <(E-Mail Removed)>
"Startup & Shutdown" on Fri, 27 May 2011 22:46:20 +0900,
Rajesh Huria <(E-Mail Removed)> wrote:

> I am trying to execute the below mentioned code:
> require 'test/unit'


You need to add 'gem "test-unit"' before 'require "test/unit"':

require 'rubygems'
gem 'test-unit'
require 'test/unit'

class MyTest < Test::Unit::TestCase
...
end

Thanks,
--
kou

 
Reply With Quote
 
Rajesh Huria
Guest
Posts: n/a
 
      05-27-2011
thanks a lot buddy.. its working now. i would like to know why its not
working when i dont write - gem 'test-unit' - i can see the standard
library also has test/unit @ http://www.ruby-doc.org/stdlib-1.8.7/ but
does not support startup and shutdown. Also, when i am writing require
'test/unit', it should work? usually we include gems with this format???

--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
Kouhei Sutou
Guest
Posts: n/a
 
      05-28-2011
Hi,

In <(E-Mail Removed)>
"Re: Startup & Shutdown" on Sat, 28 May 2011 00:01:56 +0900,
Rajesh Huria <(E-Mail Removed)> wrote:

> thanks a lot buddy.. its working now. i would like to know why its not
> working when i dont write - gem 'test-unit' - i can see the standard
> library also has test/unit @ http://www.ruby-doc.org/stdlib-1.8.7/ but
> does not support startup and shutdown. Also, when i am writing require
> 'test/unit', it should work? usually we include gems with this format???


'require "test/unit"' only case: Ruby bundled test-unit is
loaded because bundled test-unit is already in $LOAD_PATH.

'gem "test-unit"; require "test/unit"' case: 'gem
"test-unit"' prepends paths for gem version test-unit (not
Ruby bundled test-unit) to $LOAD_PATH. 'require "test/unit"'
finds gem version test-unit instead of Ruby bundled
test-unit.

Please try the scripts:

'require "test/unit"' only case:
p $LOAD_PATH
require 'test/unit'
p $LOADED_FEATURES

'gem "test-unit"; require "test/unit"' case:
require 'rubygems'
p $LOAD_PATH
gem 'test-unit'
p $LOAD_PATH
require 'test/unit'
p $LOADED_FEATURES


Thanks,
--
kou

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
what caused these changes in startup/shutdown? mike Computer Support 1 09-17-2004 12:55 AM
Startup and shutdown logos [XP] Jim Scott Computer Support 3 09-14-2004 09:40 AM
help with windows shutdown - startup ken Computer Support 4 06-11-2004 09:54 AM
XP - irritating change on startup and shutdown Caaagh Computer Support 2 11-05-2003 12:22 AM
How do I delete Startup & Shutdown sounds???? Phil Computer Support 4 07-27-2003 10:52 PM



Advertisments