Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > Error "unrecognized option --protected" when running "gem install bluecloth"

Reply
Thread Tools

Error "unrecognized option --protected" when running "gem install bluecloth"

 
 
rlh100
Guest
Posts: n/a
 
      02-28-2011
I am running Fedora core 14 and trying to install bluecloth and am
having problems.
The first problem was with strcasecmp and I solved that my recompiling
ruby to the latest 1.8.7 version, patch 334.

Now when I try to install bluecloth I get the error:
gem install bluecloth
Building native extensions. This could take a while...
..................

Successfully installed bluecloth-2.0.11
1 gem installed
Installing ri documentation for bluecloth-2.0.11...

unrecognized option `--protected'

If I turn on debugging I get:
.. . .
Installing ri documentation for bluecloth-2.0.11...
Exception `GetoptLong::InvalidOption' at /usr/lib/ruby/1.8/
getoptlong.rb:403 - unrecognized option `--protected'

Any suggestions?
RLH
 
Reply With Quote
 
 
 
 
Justin Collins
Guest
Posts: n/a
 
      02-28-2011
On 02/27/2011 10:10 PM, rlh100 wrote:
> I am running Fedora core 14 and trying to install bluecloth and am
> having problems.
> The first problem was with strcasecmp and I solved that my recompiling
> ruby to the latest 1.8.7 version, patch 334.
>
> Now when I try to install bluecloth I get the error:
> gem install bluecloth
> Building native extensions. This could take a while...
> ..................
>
> Successfully installed bluecloth-2.0.11
> 1 gem installed
> Installing ri documentation for bluecloth-2.0.11...
>
> unrecognized option `--protected'
>
> If I turn on debugging I get:
> . . .
> Installing ri documentation for bluecloth-2.0.11...
> Exception `GetoptLong::InvalidOption' at /usr/lib/ruby/1.8/
> getoptlong.rb:403 - unrecognized option `--protected'
>
> Any suggestions?
> RLH
>
>


If you just want to use the gem then you can ignore that error and read
documentation online: http://rubydoc.info/gems/bluecloth/2.0.11/frames

Not sure about the error.

-Justin

 
Reply With Quote
 
 
 
 
Michael Granger
Guest
Posts: n/a
 
      03-03-2011
On Feb 27, 2011, at 10:10 PM, rlh100 wrote:
>=20
> I am running Fedora core 14 and trying to install bluecloth and am
> having problems.
> The first problem was with strcasecmp and I solved that my recompiling
> ruby to the latest 1.8.7 version, patch 334.
>=20
> Now when I try to install bluecloth I get the error:
> gem install bluecloth
> Building native extensions. This could take a while...
> ..................
>=20
> Successfully installed bluecloth-2.0.11
> 1 gem installed
> Installing ri documentation for bluecloth-2.0.11...
>=20
> unrecognized option `--protected'


This happens because the gem has an invalid RDoc option in its =
rdoc_options. I'll have this fixed in the next release.

--
Michael Granger <(E-Mail Removed)>
Rubymage, Architect, Believer
The FaerieMUD Consortium <http://www.FaerieMUD.org/>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regex for <option> ... </option> John Perl Misc 10 01-29-2009 11:04 PM
page.aspx?option - how to detect "option" Kevin Blount ASP .Net 6 11-28-2006 09:21 PM
DHCP relay agent versus Option 3; Routers Option lcorrigan Cisco 2 09-27-2006 05:18 PM
no 'option' in aspx file means 'option'="false"? Cas ASP .Net 5 08-28-2006 10:36 AM
g++ -pg option and -shared option Julien ROUZIERES C++ 1 12-21-2004 02:30 PM



Advertisments