Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > Sinatra Error - `read ': Invalid argument .. (Errno::EINVAL)

Reply
Thread Tools

Sinatra Error - `read ': Invalid argument .. (Errno::EINVAL)

 
 
Bhay Zone
Guest
Posts: n/a
 
      09-07-2010
I'm hoping someone can help me here. I am a complete newbie to Ruby and
Sinatra and cannot find any information related to this problem
anywhere. Any help would be greatly appreciated.

Ruby version=1.9.2
I also have ruby 1.8.5 installed in a different folder. But ruby -v
gives 1.9.2.

While following the Sinatra tutorial on
"http://titusd.co.uk/2010/04/07/a-beginners-sinatra-tutorial" I get the
following error:

C:\Test\Sinatra>ruby minimal.rb

C:/Ruby192/lib/ruby/gems/1.9.1/gems/sinatra-1.0/lib/sinatra/base.rb:753:in
`read
': Invalid argument - <internal:lib/rubygems/custom_require>
(Errno::EINVAL)
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/sinatra-1.0/lib/sinatra/base.rb
:753:in `inline_templates='
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/sinatra-1.0/lib/sinatra/base.rb
:706:in `set'
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/sinatra-1.0/lib/sinatra/base.rb
:715:in `block in enable'
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/sinatra-1.0/lib/sinatra/base.rb
:715:in `each'
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/sinatra-1.0/lib/sinatra/base.rb
:715:in `enable'
from (__DELEGATE__):2:in `enable'
from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/sinatra-1.0/lib/sinatra.rb:7:in
`<top (required)>'
from <internal:lib/rubygems/custom_require>:33:in `require'
from <internal:lib/rubygems/custom_require>:33:in `rescue in
require'
from <internal:lib/rubygems/custom_require>:29:in `require'
from minimal.rb:2:in `<main>'
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
 
Luis Lavena
Guest
Posts: n/a
 
      09-08-2010
On Sep 7, 8:23*pm, Bhay Zone <(E-Mail Removed)> wrote:
> I'm hoping someone can help me here. I am a complete newbie to Ruby and
> Sinatra and cannot find any information related to this problem
> anywhere. Any help would be greatly appreciated.
>
> Ruby version=1.9.2
> I also have ruby 1.8.5 installed in a different folder. But ruby -v
> gives 1.9.2.
>
> While following the Sinatra tutorial on
> "http://titusd.co.uk/2010/04/07/a-beginners-sinatra-tutorial" I get the
> following error:
>
> C:\Test\Sinatra>ruby minimal.rb
>
> C:/Ruby192/lib/ruby/gems/1.9.1/gems/sinatra-1.0/lib/sinatra/base.rb:753:in
> `read
> ': Invalid argument - <internal:lib/rubygems/custom_require>
> (Errno::EINVAL)
> * * * * from


Please see Issue #50 of Sinatra:

http://github.com/sinatra/sinatra/issues/#issue/50

--
Luis Lavena
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sinatra and Rails. Was: [ANN] Sinatra 1.1 released! Ed Howland Ruby 1 10-26-2010 06:58 AM
How do fix: "Wrong number of arguments" / "invalid propert assignment"/ "Invalid argument" Java Guy Javascript 1 10-15-2006 08:41 PM
How do fix: "Wrong number of arguments" / "invalid propert assignment"/ "Invalid argument" Java Guy Java 1 10-15-2006 08:31 PM
ICallbackEventHandler and "Invalid postback or callback argument" error Martin ASP .Net 3 06-15-2006 01:56 PM
Got an error :Invalid postback or callback argument nitin.bajaj@rediffmail.com ASP .Net 0 11-16-2005 06:42 AM



Advertisments