Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > gem update error

Reply
Thread Tools

gem update error

 
 
Junkone
Guest
Posts: n/a
 
      04-03-2010
dunno what to do. i have a ruby installed on my new machine and cannot
add fastercsv.

E:\Documents and Settings\TTS>gem install fastercsv
WARNING: RubyGems 1.2+ index not found for:
http://gems.rubyforge.org/

RubyGems will revert to legacy indexes degrading performance.
Bulk updating Gem source index for: http://gems.rubyforge.org/
ERROR: While executing gem ... (Gem::RemoteSourceException)
Error fetching remote gem cache: bad response Not Found 404
(http://producti
on.s3.rubygems.org/yaml)

E:\Documents and Settings\TTS>ruby -ver
ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]
-e:1:in `<main>': undefined local variable or method `r' for
main:Object (NameEr
ror)
 
Reply With Quote
 
 
 
 
Luis Lavena
Guest
Posts: n/a
 
      04-03-2010
On Apr 3, 3:41*pm, Junkone <(E-Mail Removed)> wrote:
> dunno what to do. i have a ruby installed on my new machine and cannot
> add fastercsv.
>
> E:\Documents and Settings\TTS>gem install fastercsv
> WARNING: *RubyGems 1.2+ index not found for:
> * * * *http://gems.rubyforge.org/
>
> RubyGems will revert to legacy indexes degrading performance.
> Bulk updating Gem source index for:http://gems.rubyforge.org/
> ERROR: *While executing gem ... (Gem::RemoteSourceException)
> * * Error fetching remote gem cache: bad response Not Found 404
> (http://producti
> on.s3.rubygems.org/yaml)
>


Are you behind a firewall or proxy? That is the common source of this
problem

See "gem help install" on how to provide proxy settings for gem
installation.

gem install fastercsv --http-proxy=http://userass@proxyort/

--
Luis Lavena
 
Reply With Quote
 
 
 
 
Junkone
Guest
Posts: n/a
 
      04-03-2010
On Apr 3, 9:57*am, Luis Lavena <(E-Mail Removed)> wrote:
> On Apr 3, 3:41*pm, Junkone <(E-Mail Removed)> wrote:
>
> > dunno what to do. i have a ruby installed on my new machine and cannot
> > add fastercsv.

>
> > E:\Documents and Settings\TTS>gem install fastercsv
> > WARNING: *RubyGems 1.2+ index not found for:
> > * * * *http://gems.rubyforge.org/

>
> > RubyGems will revert to legacy indexes degrading performance.
> > Bulk updating Gem source index for:http://gems.rubyforge.org/
> > ERROR: *While executing gem ... (Gem::RemoteSourceException)
> > * * Error fetching remote gem cache: bad response Not Found 404
> > (http://producti
> > on.s3.rubygems.org/yaml)

>
> Are you behind a firewall or proxy? That is the common source of this
> problem
>
> See "gem help install" on how to provide proxy settings for gem
> installation.
>
> gem install fastercsv --http-proxy=http://userass@proxyort/
>
> --
> Luis Lavena


no. i am in direct connection to internet.

E:\Documents and Settings\TTS>ping rubygems.com

Pinging rubygems.com [174.120.120.196] with 32 bytes of data:

Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
Reply from 174.120.120.196: bytes=32 time=55ms TTL=48

Ping statistics for 174.120.120.196:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 54ms, Maximum = 55ms, Average = 54ms
 
Reply With Quote
 
Junkone
Guest
Posts: n/a
 
      04-03-2010
On Apr 3, 10:27*am, Junkone <(E-Mail Removed)> wrote:
> On Apr 3, 9:57*am, Luis Lavena <(E-Mail Removed)> wrote:
>
>
>
>
>
> > On Apr 3, 3:41*pm, Junkone <(E-Mail Removed)> wrote:

>
> > > dunno what to do. i have a ruby installed on my new machine and cannot
> > > add fastercsv.

>
> > > E:\Documents and Settings\TTS>gem install fastercsv
> > > WARNING: *RubyGems 1.2+ index not found for:
> > > * * * *http://gems.rubyforge.org/

>
> > > RubyGems will revert to legacy indexes degrading performance.
> > > Bulk updating Gem source index for:http://gems.rubyforge.org/
> > > ERROR: *While executing gem ... (Gem::RemoteSourceException)
> > > * * Error fetching remote gem cache: bad response Not Found 404
> > > (http://producti
> > > on.s3.rubygems.org/yaml)

>
> > Are you behind a firewall or proxy? That is the common source of this
> > problem

>
> > See "gem help install" on how to provide proxy settings for gem
> > installation.

>
> > gem install fastercsv --http-proxy=http://userass@proxyort/

>
> > --
> > Luis Lavena

>
> no. i am in direct connection to internet.
>
> E:\Documents and Settings\TTS>ping rubygems.com
>
> Pinging rubygems.com [174.120.120.196] with 32 bytes of data:
>
> Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
> Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
> Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
> Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
>
> Ping statistics for 174.120.120.196:
> * * Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
> Approximate round trip times in milli-seconds:
> * * Minimum = 54ms, Maximum = 55ms, Average = 54ms


well. i tried to ping the rubygems.org and am getting a crazy error. i
dunno where it is going to.
E:\Documents and Settings\TTS>ping rubygems.org

Pinging rubygems.org.csb.obgnet [8.15.7.103] with 32 bytes of data:

Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 8.15.7.103:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
 
Reply With Quote
 
Junkone
Guest
Posts: n/a
 
      04-03-2010
On Apr 3, 10:27*am, Junkone <(E-Mail Removed)> wrote:
> On Apr 3, 9:57*am, Luis Lavena <(E-Mail Removed)> wrote:
>
>
>
>
>
> > On Apr 3, 3:41*pm, Junkone <(E-Mail Removed)> wrote:

>
> > > dunno what to do. i have a ruby installed on my new machine and cannot
> > > add fastercsv.

>
> > > E:\Documents and Settings\TTS>gem install fastercsv
> > > WARNING: *RubyGems 1.2+ index not found for:
> > > * * * *http://gems.rubyforge.org/

>
> > > RubyGems will revert to legacy indexes degrading performance.
> > > Bulk updating Gem source index for:http://gems.rubyforge.org/
> > > ERROR: *While executing gem ... (Gem::RemoteSourceException)
> > > * * Error fetching remote gem cache: bad response Not Found 404
> > > (http://producti
> > > on.s3.rubygems.org/yaml)

>
> > Are you behind a firewall or proxy? That is the common source of this
> > problem

>
> > See "gem help install" on how to provide proxy settings for gem
> > installation.

>
> > gem install fastercsv --http-proxy=http://userass@proxyort/

>
> > --
> > Luis Lavena

>
> no. i am in direct connection to internet.
>
> E:\Documents and Settings\TTS>ping rubygems.com
>
> Pinging rubygems.com [174.120.120.196] with 32 bytes of data:
>
> Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
> Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
> Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
> Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
>
> Ping statistics for 174.120.120.196:
> * * Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
> Approximate round trip times in milli-seconds:
> * * Minimum = 54ms, Maximum = 55ms, Average = 54ms



when i tried to ping from web, it is pingable only from USA
http://www.watchmouse.com/en/checkit...gn=jpcheckperf

 
Reply With Quote
 
Luis Lavena
Guest
Posts: n/a
 
      04-03-2010
On Apr 3, 4:30*pm, Junkone <(E-Mail Removed)> wrote:
> On Apr 3, 10:27*am, Junkone <(E-Mail Removed)> wrote:
>
>
>
>
>
> > On Apr 3, 9:57*am, Luis Lavena <(E-Mail Removed)> wrote:

>
> > > On Apr 3, 3:41*pm, Junkone <(E-Mail Removed)> wrote:

>
> > > > dunno what to do. i have a ruby installed on my new machine and cannot
> > > > add fastercsv.

>
> > > > E:\Documents and Settings\TTS>gem install fastercsv
> > > > WARNING: *RubyGems 1.2+ index not found for:
> > > > * * * *http://gems.rubyforge.org/

>
> > > > RubyGems will revert to legacy indexes degrading performance.
> > > > Bulk updating Gem source index for:http://gems.rubyforge.org/
> > > > ERROR: *While executing gem ... (Gem::RemoteSourceException)
> > > > * * Error fetching remote gem cache: bad response Not Found 404
> > > > (http://producti
> > > > on.s3.rubygems.org/yaml)

>
> > > Are you behind a firewall or proxy? That is the common source of this
> > > problem

>
> > > See "gem help install" on how to provide proxy settings for gem
> > > installation.

>
> > > gem install fastercsv --http-proxy=http://userass@proxyort/

>
> > > --
> > > Luis Lavena

>
> > no. i am in direct connection to internet.

>
> > E:\Documents and Settings\TTS>ping rubygems.com

>
> > Pinging rubygems.com [174.120.120.196] with 32 bytes of data:

>
> > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
> > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
> > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
> > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48

>
> > Ping statistics for 174.120.120.196:
> > * * Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
> > Approximate round trip times in milli-seconds:
> > * * Minimum = 54ms, Maximum = 55ms, Average = 54ms

>
> well. i tried to ping the rubygems.org and am getting a crazy error. i
> dunno where it is going to.
> E:\Documents and Settings\TTS>ping rubygems.org
>
> Pinging rubygems.org.csb.obgnet [8.15.7.103] with 32 bytes of data:
>
> Request timed out.
> Request timed out.
> Request timed out.
> Request timed out.
>
> Ping statistics for 8.15.7.103:
> * * Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


I can ping rubygems.org without issues:

C:\Users\Luis>ping rubygems.org

Pinging rubygems.org [72.4.120.124] with 32 bytes of data:
Reply from 72.4.120.124: bytes=32 time=112ms TTL=50
Reply from 72.4.120.124: bytes=32 time=103ms TTL=50
Reply from 72.4.120.124: bytes=32 time=103ms TTL=50

Ping statistics for 72.4.120.124:
Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 103ms, Maximum = 112ms, Average = 106ms

So this raises again my previous question: are you behind a proxy or
firewall?

The IP address of rubygems.org is reporting in your case do not match
the real one.

You're in USA on Elliot Cable network?

http://www.ipaddresser.com/reverse.php/8.15-0

For some reason, if that is your IP address of your current internet
connection:

http://www.showmyip.com/

Means you have a miss configuration in windows hosts file.

--
Luis Lavena
 
Reply With Quote
 
Junkone
Guest
Posts: n/a
 
      04-03-2010
On Apr 3, 11:07*am, Luis Lavena <(E-Mail Removed)> wrote:
> On Apr 3, 4:30*pm, Junkone <(E-Mail Removed)> wrote:
>
>
>
>
>
> > On Apr 3, 10:27*am, Junkone <(E-Mail Removed)> wrote:

>
> > > On Apr 3, 9:57*am, Luis Lavena <(E-Mail Removed)> wrote:

>
> > > > On Apr 3, 3:41*pm, Junkone <(E-Mail Removed)> wrote:

>
> > > > > dunno what to do. i have a ruby installed on my new machine and cannot
> > > > > add fastercsv.

>
> > > > > E:\Documents and Settings\TTS>gem install fastercsv
> > > > > WARNING: *RubyGems 1.2+ index not found for:
> > > > > * * * *http://gems.rubyforge.org/

>
> > > > > RubyGems will revert to legacy indexes degrading performance.
> > > > > Bulk updating Gem source index for:http://gems.rubyforge.org/
> > > > > ERROR: *While executing gem ... (Gem::RemoteSourceException)
> > > > > * * Error fetching remote gem cache: bad response Not Found 404
> > > > > (http://producti
> > > > > on.s3.rubygems.org/yaml)

>
> > > > Are you behind a firewall or proxy? That is the common source of this
> > > > problem

>
> > > > See "gem help install" on how to provide proxy settings for gem
> > > > installation.

>
> > > > gem install fastercsv --http-proxy=http://userass@proxyort/

>
> > > > --
> > > > Luis Lavena

>
> > > no. i am in direct connection to internet.

>
> > > E:\Documents and Settings\TTS>ping rubygems.com

>
> > > Pinging rubygems.com [174.120.120.196] with 32 bytes of data:

>
> > > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48
> > > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
> > > Reply from 174.120.120.196: bytes=32 time=54ms TTL=48
> > > Reply from 174.120.120.196: bytes=32 time=55ms TTL=48

>
> > > Ping statistics for 174.120.120.196:
> > > * * Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
> > > Approximate round trip times in milli-seconds:
> > > * * Minimum = 54ms, Maximum = 55ms, Average = 54ms

>
> > well. i tried to ping the rubygems.org and am getting a crazy error. i
> > dunno where it is going to.
> > E:\Documents and Settings\TTS>ping rubygems.org

>
> > Pinging rubygems.org.csb.obgnet [8.15.7.103] with 32 bytes of data:

>
> > Request timed out.
> > Request timed out.
> > Request timed out.
> > Request timed out.

>
> > Ping statistics for 8.15.7.103:
> > * * Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

>
> I can ping rubygems.org without issues:
>
> C:\Users\Luis>ping rubygems.org
>
> Pinging rubygems.org [72.4.120.124] with 32 bytes of data:
> Reply from 72.4.120.124: bytes=32 time=112ms TTL=50
> Reply from 72.4.120.124: bytes=32 time=103ms TTL=50
> Reply from 72.4.120.124: bytes=32 time=103ms TTL=50
>
> Ping statistics for 72.4.120.124:
> * * Packets: Sent = 3, Received = 3, Lost = 0 (0% loss),
> Approximate round trip times in milli-seconds:
> * * Minimum = 103ms, Maximum = 112ms, Average = 106ms
>
> So this raises again my previous question: are you behind a proxy or
> firewall?
>
> The IP address of rubygems.org is reporting in your case do not match
> the real one.
>
> You're in USA on Elliot Cable network?
>
> http://www.ipaddresser.com/reverse.php/8.15-0
>
> For some reason, if that is your IP address of your current internet
> connection:
>
> http://www.showmyip.com/
>
> Means you have a miss configuration in windows hosts file.
>
> --
> Luis Lavena


i trouble shooted this one. when i use the googledns, it works. when i
use the dns from my default service provider, it stinks.

dunno why.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gem versions and Gem lists different after update Älphä Blüë Ruby 1 07-22-2009 07:43 PM
RubyGems 0.9.1 calling a gem with gem '<gem>' Austin 7873 Ruby 5 01-27-2007 10:05 PM
gem update for additional gem servers? Stephan Mueller Ruby 3 11-20-2006 06:15 PM
gem.cmd install RMagick-win32-1.9.2-mswin32.gem: Buffer error Clifford Heath Ruby 7 06-09-2006 07:02 PM
ERROR: While executing gem ... (Gem::GemNotFoundException) Could not find rubygems-upodate (> 0) in the repository han Ruby 1 10-24-2005 10:28 PM



Advertisments