Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > Errors running flay

Reply
Thread Tools

Errors running flay

 
 
Justin Rohrman
Guest
Posts: n/a
 
      06-25-2009
Hello All, I am trying to run Flay against my code base but am getting
an error. I suspect it is related to the version compatibility but am
not entirely sure. Any helpful ideas would be appreciated.

C:\prosrm_2\atf\web\atf\ruby>ruby -v
ruby 1.8.5 (2006-12-25 patchlevel 12) [i386-mswin32]

Here is the error.

C:\prosrm_2\atf\web\atf\ruby>flay utils\
c:/ruby/lib/ruby/gems/1.8/gems/flay-1.3.0/lib/flay.rb:59:in `+': can't
convert nil into Array (TypeError)
from c:/ruby/lib/ruby/gems/1.8/gems/flay-1.3.0/lib/flay.rb:
59:in `parse_options'
from c:/ruby/lib/ruby/1.8/optparse.rb:755:in `initialize'
from c:/ruby/lib/ruby/gems/1.8/gems/flay-1.3.0/lib/flay.rb:
26:in `new'
from c:/ruby/lib/ruby/gems/1.8/gems/flay-1.3.0/lib/flay.rb:
26:in `parse_options'
from c:/ruby/lib/ruby/gems/1.8/gems/flay-1.3.0/bin/flay:5
from c:/ruby/bin/flay:16:in `load'
from c:/ruby/bin/flay:16


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ANN] flay 1.2.1 Released Ryan Davis Ruby 0 03-17-2009 02:14 AM
[ANN] flay 1.2.0 Released Ryan Davis Ruby 1 03-13-2009 12:14 PM
[ANN] flay 1.1.0 Released Ryan Davis Ruby 0 01-21-2009 12:15 AM
[ANN] flay 1.0.0 Released Ryan Davis Ruby 0 11-06-2008 08:39 PM
Errors, errors, errors Mark Goldin ASP .Net 2 01-17-2004 08:05 PM



Advertisments