Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > .NET C# service error 1053, service could not start in timely fash

Reply
Thread Tools

.NET C# service error 1053, service could not start in timely fash

 
 
=?Utf-8?B?M2Ry?=
Guest
Posts: n/a
 
      08-31-2004
I am developing a service which I install and run on a number of servers. It
works on most machines I have installed it on, but I always get a 1053,
service will not start in a timely fashion message on one server.

I have reduced the code to almost nothing so as to remove almost all the
proper code.

My main function looks like this

static void Main()
{
System.ServiceProcess.ServiceBase[] ServicesToRun;
ServicesToRun = new System.ServiceProcess.ServiceBase[] { new
TigerPrintService() };
System.ServiceProcess.ServiceBase.Run(ServicesToRu n);
}

My OnStart() is blank at the moment.

My TigerPrintService() constructor is currently empty also.

I can install the service but when I go to the service manager to start it I
get the 1053 error.

And since my OnStart() method is now empty I am at a loss as to what might
be causing this problem. As it seems to me it cannot be to do with
permisions.

By the way when I install the service I am currently doing so using the
local system login.

Many thanks for any thoughts or suggestions as to what might be causing this
problem.

--
Many thanks
Derek

http://www.velocityreviews.com/forums/(E-Mail Removed)
 
Reply With Quote
 
 
 
 
Raghavendra T V
Guest
Posts: n/a
 
      08-31-2004
Hi,

check this thread.

http://groups.google.co.in/groups?hl...ublic.dotnet.*

Thanks
Raghavendra

"3dr" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> I am developing a service which I install and run on a number of servers.

It
> works on most machines I have installed it on, but I always get a 1053,
> service will not start in a timely fashion message on one server.
>
> I have reduced the code to almost nothing so as to remove almost all the
> proper code.
>
> My main function looks like this
>
> static void Main()
> {
> System.ServiceProcess.ServiceBase[] ServicesToRun;
> ServicesToRun = new System.ServiceProcess.ServiceBase[] { new
> TigerPrintService() };
> System.ServiceProcess.ServiceBase.Run(ServicesToRu n);
> }
>
> My OnStart() is blank at the moment.
>
> My TigerPrintService() constructor is currently empty also.
>
> I can install the service but when I go to the service manager to start it

I
> get the 1053 error.
>
> And since my OnStart() method is now empty I am at a loss as to what might
> be causing this problem. As it seems to me it cannot be to do with
> permisions.
>
> By the way when I install the service I am currently doing so using the
> local system login.
>
> Many thanks for any thoughts or suggestions as to what might be causing

this
> problem.
>
> --
> Many thanks
> Derek
>
> (E-Mail Removed)



 
Reply With Quote
 
 
 
 
Steven Cheng[MSFT]
Guest
Posts: n/a
 
      09-07-2004
Hi Raghavendra,

Any progress on this issue or have you resolved it? If you have any other
problems, please feel free to post here or in the C# or other service
related newsgroups. Thanks.

Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
could anyone help me this one?, could not login due to error.. sparc58 MCDST 10 05-15-2007 06:10 PM
The POP3 Service could not start bacause: Joe Leavy MCSE 5 10-29-2005 02:04 AM
IIS: The service did not respond to the start or control request in a timely fashion Water Cooler v2 ASP General 0 08-10-2005 11:15 AM
Which Fash? rda Digital Photography 8 10-22-2004 07:01 PM
Error Message: Outlook Express Could Not Be Started Because Msoe.dll Could Not Be Loaded Dutch Treat Computer Support 4 06-21-2004 02:01 PM



Advertisments