Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > How to set my default ruby back to 1.8 version after install ruby1.9?

Reply
Thread Tools

How to set my default ruby back to 1.8 version after install ruby1.9?

 
 
Harry
Guest
Posts: n/a
 
      03-24-2009
Hi ,this might be a newbie question and I don't know if it's the right
place to ask here:
I use opensuse11.1 and it has it's ruby1.8.7 rpm installed , later I
tried to compiled a ruby 1.9 on the machine.now when I type :
ruby -v
It shows
ruby 1.9.1p0 (2009-01-30 revision 21907) [x86_64-linux]

then all of my gem installed under ruby 1.8.7 lost. since I just want
to try 1.9 and some gem will have problem under 1.9 .so I want to set
the default ruby still be the ruby1.8.7 . how could I do that ?

my ruby1.8.7 has the path :/usr/bin/ruby
ruby 1.9 has the path : /usr/local/bin/ruby

thank you guys!
 
Reply With Quote
 
 
 
 
Rafael Crivellari Saliba Schouery
Guest
Posts: n/a
 
      03-24-2009
If you change your PATH variable to start with /usr/bin and after
that you put /usr/local/bin, then I think you will be able to use Ruby
1.8.
Bye!

---
Rafael Crivellari Saliba Schouery
http://www.velocityreviews.com/forums/(E-Mail Removed)

Autor do VidaGeek.net: http://vidageek.net
RSS: http://feeds.feedburner.com/VidaGeek
Twitter: http://twitter.com/blogvidageek

On 24/03/2009, at 06:52, Harry wrote:

> Hi ,this might be a newbie question and I don't know if it's the right
> place to ask here:
> I use opensuse11.1 and it has it's ruby1.8.7 rpm installed , later I
> tried to compiled a ruby 1.9 on the machine.now when I type :
> ruby -v
> It shows
> ruby 1.9.1p0 (2009-01-30 revision 21907) [x86_64-linux]
>
> then all of my gem installed under ruby 1.8.7 lost. since I just want
> to try 1.9 and some gem will have problem under 1.9 .so I want to set
> the default ruby still be the ruby1.8.7 . how could I do that ?
>
> my ruby1.8.7 has the path :/usr/bin/ruby
> ruby 1.9 has the path : /usr/local/bin/ruby
>
> thank you guys!
>



 
Reply With Quote
 
 
 
 
Harry
Guest
Posts: n/a
 
      03-24-2009
On Mar 24, 9:07*pm, Rafael Crivellari Saliba Schouery
<(E-Mail Removed)> wrote:
> If you change your PATH variable to start with /usr/bin and after
> that you put /usr/local/bin, then I think you will be able to use Ruby *
> 1.8.
> Bye!
>
> ---
> Rafael Crivellari Saliba Schouery
> (E-Mail Removed)
>
> Autor do VidaGeek.net:http://vidageek.net
> RSS: * * *http://feeds.feedburner.com/VidaGeek
> Twitter: *http://twitter.com/blogvidageek
>
> On 24/03/2009, at 06:52, Harry wrote:
>
> > Hi ,this might be a newbie question and I don't know if it's the right
> > place to ask here:
> > I use opensuse11.1 and it has it's ruby1.8.7 rpm installed , later I
> > tried to compiled a ruby 1.9 on the machine.now when I type :
> > ruby -v
> > It shows
> > ruby 1.9.1p0 (2009-01-30 revision 21907) [x86_64-linux]

>
> > then all of my gem installed under ruby 1.8.7 lost. since I just want
> > to try 1.9 and some gem will have problem under 1.9 .so I want to set
> > the default ruby still be the ruby1.8.7 . how could I do that ?

>
> > my ruby1.8.7 has the path :/usr/bin/ruby
> > ruby 1.9 has the path : /usr/local/bin/ruby

>
> > thank you guys!

>
>


thanks for the clue !
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: How include a large array? Edward A. Falk C Programming 1 04-04-2013 08:07 PM
Re: Where to get stand alone Dot Net Framework version 1.1, version2.0, version 3.0, version 3.5, version 2.0 SP1, version 3.0 SP1 ? MowGreen [MVP] ASP .Net 5 02-09-2008 01:55 AM
Re: Where to get stand alone Dot Net Framework version 1.1, version 2.0, version 3.0, version 3.5, version 2.0 SP1, version 3.0 SP1 ? PA Bear [MS MVP] ASP .Net 0 02-05-2008 03:28 AM
Re: Where to get stand alone Dot Net Framework version 1.1, version 2.0, version 3.0, version 3.5, version 2.0 SP1, version 3.0 SP1 ? V Green ASP .Net 0 02-05-2008 02:45 AM
How to get the 32 bit version of explorer to be the default instead of the 64bit version of Explorer? Thanks! Manquala@gmail.com Windows 64bit 1 02-23-2006 12:36 AM



Advertisments