Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > I have to be missing something simple here.

Reply
Thread Tools

I have to be missing something simple here.

 
 
thermowax@gmail.com
Guest
Posts: n/a
 
      02-18-2009
I have some code that was written in the Ruby-1.8ish era. However,
the newer versions append the version number to all library/etc
filenames, which is causing problems- for example, "/usr/local/bin/
ruby" no longer exists, it's "/usr/local/bin/ruby19". I'd stay with
1.8 but when I try to run the software on the new system I'm trying to
set up (FreeBSD) it complains that gzip library isn't present.

I know from Googling that zlib was included with Ruby starting with
1.8, so I'm not quite sure what's going on there. Rather than fiddle
with that, I thought I'd just get a newer version (1.9.1 is the
current for FreeBSD 7.1, IIRC), but then I run into the above
mentioned filename problems.

Am I missing something? Surely it should be more backward compatible
than that... I thought the problem might be that the FreeBSD packages
were broken, but compiling from source results in the same problem.
Should I just set up links or rename everything to the old filenames?
Was there some drastic change in Ruby that necessitated the versions
not commingle? Argh.

Thanks for any input,
Jim
 
Reply With Quote
 
 
 
 
Tom Cloyd
Guest
Posts: n/a
 
      02-19-2009
http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> I have some code that was written in the Ruby-1.8ish era. However,
> the newer versions append the version number to all library/etc
> filenames, which is causing problems- for example, "/usr/local/bin/
> ruby" no longer exists, it's "/usr/local/bin/ruby19". I'd stay with
> 1.8 but when I try to run the software on the new system I'm trying to
> set up (FreeBSD) it complains that gzip library isn't present.
>
> I know from Googling that zlib was included with Ruby starting with
> 1.8, so I'm not quite sure what's going on there. Rather than fiddle
> with that, I thought I'd just get a newer version (1.9.1 is the
> current for FreeBSD 7.1, IIRC), but then I run into the above
> mentioned filename problems.
>
> Am I missing something? Surely it should be more backward compatible
> than that... I thought the problem might be that the FreeBSD packages
> were broken, but compiling from source results in the same problem.
> Should I just set up links or rename everything to the old filenames?
> Was there some drastic change in Ruby that necessitated the versions
> not commingle? Argh.
>
> Thanks for any input,
> Jim
>
>
>

Jim, I'm competent only to comment on part of your problem. I know this:
If you have Ruby 1.8.x installed, and then also install 1.9.x, the
installation process will keep them separate by appending ...1.9 to all
(I HOPE all!) the 1.9 components. That's what happened on my Kubuntu
Linux OS. What implications this might have for the internals of various
Ruby scripts of which any particular piece of software s composed I can
only conjecture.

I think you may have two Ruby's installed on your OS. For the present, I
don't think there's a realistic alternative to this setup. I'm NOT sure
how best to manage it, however. Still learning.

t.

--

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~
Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist
Bellingham, Washington, U.S.A: (360) 920-1226
<< (E-Mail Removed) >> (email)
<< TomCloyd.com >> (website)
<< sleightmind.wordpress.com >> (mental health weblog)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~


 
Reply With Quote
 
 
 
 
thermowax@gmail.com
Guest
Posts: n/a
 
      02-19-2009
On Feb 18, 7:58*pm, Tom Cloyd <(E-Mail Removed)> wrote:
> (E-Mail Removed) wrote:
> > I have some code that was written in the Ruby-1.8ish era. *However,
> > the newer versions append the version number to all library/etc
> > filenames, which is causing problems- for example, "/usr/local/bin/
> > ruby" no longer exists, it's "/usr/local/bin/ruby19". *I'd stay with
> > 1.8 but when I try to run the software on the new system I'm trying to
> > set up (FreeBSD) it complains that gzip library isn't present.

>
> > I know from Googling that zlib was included with Ruby starting with
> > 1.8, so I'm not quite sure what's going on there. *Rather than fiddle
> > with that, I thought I'd just get a newer version (1.9.1 is the
> > current for FreeBSD 7.1, IIRC), but then I run into the above
> > mentioned filename problems.

>
> > Am I missing something? *Surely it should be more backward compatible
> > than that... I thought the problem might be that the FreeBSD packages
> > were broken, but compiling from source results in the same problem.
> > Should I just set up links or rename everything to the old filenames?
> > Was there some drastic change in Ruby that necessitated the versions
> > not commingle? *Argh.

>
> > Thanks for any input,
> > Jim

>
> Jim, I'm competent only to comment on part of your problem. I know this:
> If you have Ruby 1.8.x installed, and then also install 1.9.x, the
> installation process will keep them separate by appending ...1.9 to all
> (I HOPE all!) the 1.9 components. That's what happened on my Kubuntu
> Linux OS. What implications this might have for the internals of various
> Ruby scripts of which any particular piece of software s composed I can
> only conjecture.
>
> I think you may have two Ruby's installed on your OS. For the present, I
> don't think there's a realistic alternative to this setup. I'm NOT sure
> how best to manage it, however. Still learning.
>
> t.



Tom-

Thanks for the input. Nope, only one Ruby- I've tried it several
different ways. I did notice in the changelog for 1.9.0 that there
are several "severe" incompatible changes, so perhaps that's why
they're segregating the versions like that. (I'd love to hear it if
anyone knows!)

For the moment I'm going to fall back to 1.8.0.111 and try to get zlib
working. My other concern is that I don't know if all the current
extension binding packages (pango, glib2, gtk2, etc etc) are going to
play nicely with it. Sigh. I wouldn't mind _that_ much except
finding older versions of this stuff can be an immense pain in the
butt, and it's a crap shoot which versions work together. Hmm, a
compatibility table would be nice...

Thanks again-
Jim
 
Reply With Quote
 
Tom Cloyd
Guest
Posts: n/a
 
      02-19-2009
(E-Mail Removed) wrote:
> On Feb 18, 7:58 pm, Tom Cloyd <(E-Mail Removed)> wrote:
>
>> (E-Mail Removed) wrote:
>>
>>> I have some code that was written in the Ruby-1.8ish era. However,
>>> the newer versions append the version number to all library/etc
>>> filenames, which is causing problems- for example, "/usr/local/bin/
>>> ruby" no longer exists, it's "/usr/local/bin/ruby19". I'd stay with
>>> 1.8 but when I try to run the software on the new system I'm trying to
>>> set up (FreeBSD) it complains that gzip library isn't present.
>>>
>>> I know from Googling that zlib was included with Ruby starting with
>>> 1.8, so I'm not quite sure what's going on there. Rather than fiddle
>>> with that, I thought I'd just get a newer version (1.9.1 is the
>>> current for FreeBSD 7.1, IIRC), but then I run into the above
>>> mentioned filename problems.
>>>
>>> Am I missing something? Surely it should be more backward compatible
>>> than that... I thought the problem might be that the FreeBSD packages
>>> were broken, but compiling from source results in the same problem.
>>> Should I just set up links or rename everything to the old filenames?
>>> Was there some drastic change in Ruby that necessitated the versions
>>> not commingle? Argh.
>>>
>>> Thanks for any input,
>>> Jim
>>>

>> Jim, I'm competent only to comment on part of your problem. I know this:
>> If you have Ruby 1.8.x installed, and then also install 1.9.x, the
>> installation process will keep them separate by appending ...1.9 to all
>> (I HOPE all!) the 1.9 components. That's what happened on my Kubuntu
>> Linux OS. What implications this might have for the internals of various
>> Ruby scripts of which any particular piece of software s composed I can
>> only conjecture.
>>
>> I think you may have two Ruby's installed on your OS. For the present, I
>> don't think there's a realistic alternative to this setup. I'm NOT sure
>> how best to manage it, however. Still learning.
>>
>> t.
>>

>
>
> Tom-
>
> Thanks for the input. Nope, only one Ruby- I've tried it several
> different ways. I did notice in the changelog for 1.9.0 that there
> are several "severe" incompatible changes, so perhaps that's why
> they're segregating the versions like that. (I'd love to hear it if
> anyone knows!)
>
> For the moment I'm going to fall back to 1.8.0.111 and try to get zlib
> working. My other concern is that I don't know if all the current
> extension binding packages (pango, glib2, gtk2, etc etc) are going to
> play nicely with it. Sigh. I wouldn't mind _that_ much except
> finding older versions of this stuff can be an immense pain in the
> butt, and it's a crap shoot which versions work together. Hmm, a
> compatibility table would be nice...
>
> Thanks again-
> Jim
>
>
>

Don't know if this helps or not, but...

I use 1.8.7 for most of my work and everything *I* needs seems to be
available and working for it. Not so with 9.1.

When I recently reinstalled my kubuntu linux, I found that somehow 9.1
had been installed by something, somehow, without my knowledge. It was
causing me some problems, relative to my 1.8.7 installation. I removed
them both, installed 1.8.7 (from source), got it working, then installed
9.1 from Synaptic package manager. Everything's working great, other
than that I cannot find everything I need for 9.1, yet. I expect
Libraries will come available over time.

So...you might want to try 1.8.7, after doing some housecleaning.

t.

--

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~
Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist
Bellingham, Washington, U.S.A: (360) 920-1226
<< (E-Mail Removed) >> (email)
<< TomCloyd.com >> (website)
<< sleightmind.wordpress.com >> (mental health weblog)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~


 
Reply With Quote
 
Brian Candler
Guest
Posts: n/a
 
      02-19-2009
unknown wrote:
> I have some code that was written in the Ruby-1.8ish era. However,
> the newer versions append the version number to all library/etc
> filenames, which is causing problems- for example, "/usr/local/bin/
> ruby" no longer exists, it's "/usr/local/bin/ruby19".


This is a compile-time option: ./configure --program-suffix=19

> I'd stay with
> 1.8 but when I try to run the software on the new system I'm trying to
> set up (FreeBSD) it complains that gzip library isn't present.


If you're trying to run code written under 1.8, then you definitely need
1.8. There are many differences between 1.8 and 1.9, some minor but many
substantial.

Hence many people need to have both 1.8 and 1.9 installed
simultaneously, and the suffix is one way to achieve this.

I'd argue that 1.8.7 is a third incompatible variant, but let's not get
into that now Suffice to say, if your code was written under 1.8,
then you should install a recent 1.8.6.

> I know from Googling that zlib was included with Ruby starting with
> 1.8, so I'm not quite sure what's going on there.


It is. How are you installing ruby - from ports? Compiling from source?

If compiling from source it should be easy to debug. If the zlib
extension isn't being build, you'll find the answer in
ext/zlib/mkmf.log.

I believe zlib is part of FreeBSD base system, so you'll need to check
what's happening.

> Was there some drastic change in Ruby that necessitated the versions
> not commingle? Argh.


Yes
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing Something Simple John Abel Python 2 07-12-2005 04:30 PM
Re: I'm missing something simple Kevin Spencer ASP .Net 1 05-20-2004 04:56 PM
I have no idea why this isn't working - must be missing something simple SB C++ 6 04-23-2004 11:17 AM
please help, am i missing something simple? JROCKS11 Java 4 01-29-2004 01:31 AM
must be missing something simple... luca passani Java 1 09-05-2003 02:43 PM



Advertisments