Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > Recommendation for Ruby 1.9.1 gem compatibility

Reply
Thread Tools

Recommendation for Ruby 1.9.1 gem compatibility

 
 
Nate Wiger
Guest
Posts: n/a
 
      02-04-2009
I just wanted to share this commit I saw from Passenger for Ruby 1.9.1
compatibility, in case anyone out there owns a gem/library that needs
to work on both Ruby 1.8.6 and Ruby 1.9.1. It's a couple simple macro
changes and your library is backwards compatible:

http://github.com/FooBarWidget/passe...925b2ede6bc831

Sorry if this is repeat information, but seemed like a nice solution.

-Nate

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gemspec: How to install a Ruby extension into GEM/lib/SOME_DIR/rather than GEM/lib/ IƱaki Baz Castillo Ruby 1 02-28-2011 03:26 PM
Gem naming recommendation Eric Hodel Ruby 0 05-22-2009 06:55 PM
RubyGems 0.9.1 calling a gem with gem '<gem>' Austin 7873 Ruby 5 01-27-2007 10:05 PM
[ANN] Getopt-Declare 1.12 (gem/zip) and GGEnv (gem/zip) gga Ruby 0 07-18-2005 03:21 PM
[Ruby Forum] Ruby extconf.rb / autoconf (in?)compatibility Alexey Verkhovsky Ruby 5 09-28-2004 08:37 AM



Advertisments