Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > Turn off warnings in ruby

Reply
Thread Tools

Turn off warnings in ruby

 
 
Jim Burgess
Guest
Posts: n/a
 
      01-08-2009
Hi,

I am writing a ruby application with FXRuby, which also uses the ruby
gem 'spreadsheet' to create an Excel file. Everything was working fine
until this morning when, for some reason, when I ran my application, it
started spewing out warnings at me (literally hundreds), caused by the
'spreadsheet' gem.
e.g.
"c:/ruby/lib/ruby/gems/1.8/gems/spreadsheet-0.6.1.9/lib/spreadsheet/datatypes.rb:27:
warning: instance variable @text_wrap not initialized"

Can anyone tell me how to turn off warnings in ruby while I try to
figure this out?

Thanks a lot.
I'm currently working with ruby 1.8.6 and using xp
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
 
Daniel Berger
Guest
Posts: n/a
 
      01-09-2009
Jim Burgess wrote:
> Hi,
>
> I am writing a ruby application with FXRuby, which also uses the ruby
> gem 'spreadsheet' to create an Excel file. Everything was working fine
> until this morning when, for some reason, when I ran my application, it
> started spewing out warnings at me (literally hundreds), caused by the
> 'spreadsheet' gem.
> e.g.
> "c:/ruby/lib/ruby/gems/1.8/gems/spreadsheet-0.6.1.9/lib/spreadsheet/datatypes.rb:27:
> warning: instance variable @text_wrap not initialized"
>
> Can anyone tell me how to turn off warnings in ruby while I try to
> figure this out?


It's probably harmless, so don't panic. You can report that to Hannes on
the project page as a bug:

http://www.rubyforge.org/projects/spreadsheet

> Thanks a lot.
> I'm currently working with ruby 1.8.6 and using xp


I'm curious what turned warnings on, since they're not on by default.
What happens if you run ruby with -W0?

Regards,

Dan



 
Reply With Quote
 
 
 
 
Jim Burgess
Guest
Posts: n/a
 
      01-09-2009
Hi,

Thanks for the advice.
Running the script from the command line thus, "ruby -W0 invoices.rb"
still produces hundreds of warnings.
Is that then the correct way to turn warnings off? If so, it doesn't
seem to work
Do you think I should report this problem?
I already tried installing (and uninstalling) various versions of the
spreadsheet gem. I also tried downgrading to earlier versions of ruby,
but the result was always the same.
What I will do also is set this up in Linux and try and reproduce the
error ther. Maybe it's windows specific?
Would be grateful for any advice


--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
Marc Heiler
Guest
Posts: n/a
 
      01-09-2009
> Is that then the correct way to turn warnings off?

I dont know how others do it but I fix all the warnings ruby spits out
in my scripts, which sometimes is only annoying if I include stuff from
other authors who do not fix those kind of warnings.

I think there should exist a standard that at least mandates that all
the more popular gems etc... stuff that is used in ruby, should produce
no warnings.

This is just a nuisance IMHO and people should freely use -w flags all
the time.
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
Jim Burgess
Guest
Posts: n/a
 
      01-09-2009
I solved the problem
I was using the latest version of FXRuby (1.6.16)
I uninstalled this and dropped back to the previous version.
Now when I run the programs everything works as it should.
I guess I should have thought of this sooner.
Thanks for the help.

--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
Rodrigo Bermejo
Guest
Posts: n/a
 
      01-09-2009
Jim Burgess wrote:
> I solved the problem
> I was using the latest version of FXRuby (1.6.16)
> I uninstalled this and dropped back to the previous version.
> Now when I run the programs everything works as it should.
> I guess I should have thought of this sooner.
> Thanks for the help.


You could get rid of those warning messages this way:
$VERBOSE = nil

-r.
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
Jim Burgess
Guest
Posts: n/a
 
      01-10-2009
Hi,

> You could get rid of those warning messages this way:
> $VERBOSE = nil


I tried that and couldn't get it to work.
Where exactly in my code should I insert that?
Will this then kill all warnings for my program, including those
generated by a third party library?




--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Viewstate wont turn off even after setting it to off ! robert112 ASP .Net 1 04-26-2007 01:51 AM
ruby 1.8.4 gives warnings where ruby 1.8.2 doesn't - how to disable? Asfand Yar Qazi Ruby 1 03-19-2006 11:09 AM
YAML for Ruby: How to turn off the boolean interpretations? mikshir Ruby 6 12-16-2005 11:06 PM
How To Turn Off Net::HTTP w/SSL Certificate Warnings? Keith Fahlgren Ruby 3 12-12-2005 04:35 PM
use warnings; and use Warnings; give different results Ted Sung Perl Misc 1 08-30-2004 10:22 PM



Advertisments