Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > problem in rubygems installation

Reply
Thread Tools

problem in rubygems installation

 
 
dare ruby
Guest
Posts: n/a
 
      07-10-2008
Dear all,

while installing rubygems(1.2.0) in windows I am getting the below
error.
command used: ruby setup.rb

/lib/rubygems/spec_fetcher.rb:1:in `require': no such file to load --
zlib (Loa
dError)
from ./lib/rubygems/spec_fetcher.rb:1
from ./lib/rubygems/source_index.rb:10:in `require'
from ./lib/rubygems/source_index.rb:10
from ./lib/rubygems.rb:767:in `require'
from ./lib/rubygems.rb:767
from setup.rb:22:in `require'
from setup.rb:22

can anyone help me to solve this error.

I didn't use 'one click installer' for ruby installation. bez I need to
build 'Ruby extensions'. so,
I have installed ruby by 'configure' and 'nmake' commands.
(within: c:/ruby/win32)
now I am able to run the ruby extension program.

NOTE:
I am using ruby version 1.8.6. with MSVC6

Thanks in advance.
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
 
dare ruby
Guest
Posts: n/a
 
      07-11-2008
Dear all,

This error is due to the version of the rubygems.
now I have changed the version rubygems version into the older one. now
its installed properly.

Regards.
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
 
Eric Hodel
Guest
Posts: n/a
 
      07-15-2008
On Jul 10, 2008, at 23:39 PM, dare ruby wrote:
> This error is due to the version of the rubygems.
> now I have changed the version rubygems version into the older one.
> now
> its installed properly.


It won't work without zlib.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rubygems 1.3.5 can't load 'rubygems/defaults/operating_sy..' Eric Roscher Ruby 3 11-24-2009 02:15 AM
problem with installation of rubygems-0.8.11 pirveli Ruby 3 10-12-2005 04:48 PM
[BUG] RubyGems: "No such file to load -- rubygems/builder" Erik Veenstra Ruby 4 02-04-2005 10:28 PM
Problems with fresh install of RubyGems on Ubuntu Linux: No suchfile to load -- rubygems/builder (LoadError) Trevor Ruby 5 01-29-2005 12:52 AM
[Ruby Forum] Problem with rubygems installation in Cygwin Alexey Verkhovsky Ruby 1 10-05-2004 03:09 AM



Advertisments