Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > interrupt during require_gem

Reply
Thread Tools

interrupt during require_gem

 
 
Joel VanderWerf
Guest
Posts: n/a
 
      06-02-2008

Bad timing I guess: I happened to interrupt a program presumably during
require_gem or whatever method happens when you have RUBYOPT=rubygems.
This caused a huge dump of warnings about invalid gem specs (not even
gems I was using in my code). Could this be handled in a way that
doesn't dump all these messages (shown below)? I'm not including the
backtrace, because it didn't show where these warnings were generated.

WARNING: Interrupt
Gem::Specification.new do |s|
s.name = %q{columnize}
s.version = "0.1"

s.specification_version = 1 if s.respond_to? :specification_version=

s.required_rubygems_version = nil if s.respond_to?
:required_rubygems_version=
s.authors = ["R. Bernstein"]
s.cert_chain = nil
s.date = %q{2007-12-08}
s.description = %q{Columnize is a module for reading and caching
lines. This may be useful for example in a debugger where the same lines
are shown many times.}
s.email = %q{(E-Mail Removed)}
s.extra_rdoc_files = ["README", "lib/columnize.rb"]
s.files = ["AUTHORS", "COPYING", "ChangeLog", "NEWS", "README",
"Rakefile", "VERSION", "lib/columnize.rb", "test/test-columnize.rb"]
s.has_rdoc = true
s.homepage = %q{http://rubyforge.org/projects/rocky-hacks/columnize}
s.require_paths = ["lib"]
s.required_ruby_version = Gem::Requirement.new(">= 1.8.2")
s.rubyforge_project = %q{rocky-hacks}
s.rubygems_version = %q{1.1.0}
s.summary = %q{Read file with caching}
end
WARNING: Invalid .gemspec format in
'/usr/local/lib/ruby/gems/1.8/specifications/columnize-0.1.gemspec'
WARNING: Interrupt
Gem::Specification.new do |s|
s.name = %q{mongrel}
s.version = "1.1.4"

s.specification_version = 2 if s.respond_to? :specification_version=

...
...

(and much more like this)

--
vjoel : Joel VanderWerf : path berkeley edu : 510 665 3407

 
Reply With Quote
 
 
 
 
Roger Pack
Guest
Posts: n/a
 
      06-03-2008
> WARNING: Interrupt
> Gem::Specification.new do |s|


I get those all the time, too, if I interrupt a rails app right after
startup. Usually they're considered benign, but, as you mentioned,
confusing
-R
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
 
Eric Hodel
Guest
Posts: n/a
 
      06-05-2008
On Jun 2, 2008, at 13:42 PM, Joel VanderWerf wrote:
> Bad timing I guess: I happened to interrupt a program presumably
> during require_gem or whatever method happens when you have
> RUBYOPT=rubygems. This caused a huge dump of warnings about invalid
> gem specs (not even gems I was using in my code). Could this be
> handled in a way that doesn't dump all these messages (shown below)?
> I'm not including the backtrace, because it didn't show where these
> warnings were generated.
>
> WARNING: Interrupt
> Gem::Specification.new do |s|
> s.name = %q{columnize}
> s.version = "0.1"
>
> s.specification_version = 1 if s.respond_to? :specification_version=
>
> s.required_rubygems_version = nil if
> s.respond_to? :required_rubygems_version=
> s.authors = ["R. Bernstein"]
> s.cert_chain = nil
> s.date = %q{2007-12-08}
> s.description = %q{Columnize is a module for reading and caching
> lines. This may be useful for example in a debugger where the same
> lines are shown many times.}
> s.email = %q{(E-Mail Removed)}
> s.extra_rdoc_files = ["README", "lib/columnize.rb"]
> s.files = ["AUTHORS", "COPYING", "ChangeLog", "NEWS", "README",
> "Rakefile", "VERSION", "lib/columnize.rb", "test/test-columnize.rb"]
> s.has_rdoc = true
> s.homepage = %q{http://rubyforge.org/projects/rocky-hacks/columnize}
> s.require_paths = ["lib"]
> s.required_ruby_version = Gem::Requirement.new(">= 1.8.2")
> s.rubyforge_project = %q{rocky-hacks}
> s.rubygems_version = %q{1.1.0}
> s.summary = %q{Read file with caching}
> end
> WARNING: Invalid .gemspec format in '/usr/local/lib/ruby/gems/1.8/
> specifications/columnize-0.1.gemspec'
> WARNING: Interrupt
> Gem::Specification.new do |s|
> s.name = %q{mongrel}
> s.version = "1.1.4"
>
> s.specification_version = 2 if s.respond_to? :specification_version=
>
> ...
> ...
>
> (and much more like this)


Can you file a bug? I know where to fix this, but am on a larger
change at the moment and don't want to confuse myself.

 
Reply With Quote
 
Joel VanderWerf
Guest
Posts: n/a
 
      06-05-2008

Eric Hodel wrote:
> Can you file a bug? I know where to fix this, but am on a larger change
> at the moment and don't want to confuse myself.


Hi, Eric,
Bug filed. Thanks!

--
vjoel : Joel VanderWerf : path berkeley edu : 510 665 3407

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
require_gem question Andrew Gibson Ruby 1 07-29-2006 02:02 AM
What is the point of require_gem in Ruby 1.8.2? Wes Gamble Ruby 3 03-23-2006 11:23 PM
Is there any relevant difference between require and require_gem? Lars Olsson Ruby 2 12-02-2005 02:29 PM
dev-utils gem... How do I require_gem 'dev-utils/debug' ? Eirikur Hallgrimsson Ruby 3 10-10-2004 07:47 AM
require vs require_gem Gavin Sinclair Ruby 2 06-18-2004 11:31 AM



Advertisments