Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > error installing libxml

Reply
Thread Tools

error installing libxml

 
 
Bu Mihai
Guest
Posts: n/a
 
      03-28-2008
i have this error:


gem install libxml-ruby
Building native extensions. This could take a while...
ERROR: Error installing libxml-ruby:
ERROR: Failed to build gem native extension.

c:/ruby/bin/ruby.exe extconf.rb install libxml-ruby
extconf.rb:6:in `[]': stack level too deep (SystemStackError)
from extconf.rb:6:in `method_missing'
from extconf.rb:6:in `method_missing'
from extconf.rb:34


Gem files will remain installed in
c:/ruby/lib/ruby/gems/1.8/gems/libxml-ruby-0.
5.4 for inspection.
Results logged to
c:/ruby/lib/ruby/gems/1.8/gems/libxml-ruby-0.5.4/ext/libxml/ge
m_make.out


What can i do?
Tnx
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
 
Trans
Guest
Posts: n/a
 
      03-28-2008


On Mar 28, 7:46 am, Bu Mihai <(E-Mail Removed)> wrote:
> i have this error:
>
> gem install libxml-ruby
> Building native extensions. This could take a while...
> ERROR: Error installing libxml-ruby:
> ERROR: Failed to build gem native extension.
>
> c:/ruby/bin/ruby.exe extconf.rb install libxml-ruby
> extconf.rb:6:in `[]': stack level too deep (SystemStackError)
> from extconf.rb:6:in `method_missing'
> from extconf.rb:6:in `method_missing'
> from extconf.rb:34
>
> Gem files will remain installed in
> c:/ruby/lib/ruby/gems/1.8/gems/libxml-ruby-0.
> 5.4 for inspection.
> Results logged to
> c:/ruby/lib/ruby/gems/1.8/gems/libxml-ruby-0.5.4/ext/libxml/ge
> m_make.out
>
> What can i do?


Change line 34 to:

objs = srcs.collect do |srcfile|

(ie. change src -> srcs)

T.

 
Reply With Quote
 
 
 
 
Bu Mihai
Guest
Posts: n/a
 
      03-28-2008
Trans wrote:
> On Mar 28, 7:46 am, Bu Mihai <(E-Mail Removed)> wrote:
>> from extconf.rb:6:in `method_missing'
>> from extconf.rb:34
>>
>> Gem files will remain installed in
>> c:/ruby/lib/ruby/gems/1.8/gems/libxml-ruby-0.
>> 5.4 for inspection.
>> Results logged to
>> c:/ruby/lib/ruby/gems/1.8/gems/libxml-ruby-0.5.4/ext/libxml/ge
>> m_make.out
>>
>> What can i do?

>
> Change line 34 to:
>
> objs = srcs.collect do |srcfile|
>
> (ie. change src -> srcs)
>
> T.


Tnx, but now i have this error:
C:\libxml\libxml-ruby-0.5.4\ext\libxml>ruby extconf.rb
extconf.rb:51: (eval):11: compile error (SyntaxError)
(eval):2: unknown regexp option - h
(eval):9: syntax error, unexpected '.'
(eval):11: syntax error, unexpected $undefined
hdrdir = $(topdir)

There is a gem to intall it without any error, or could u help me to
install without gem install command?
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
Trans
Guest
Posts: n/a
 
      03-28-2008


On Mar 28, 5:25 pm, Bu Mihai <(E-Mail Removed)> wrote:
> Trans wrote:
> > On Mar 28, 7:46 am, Bu Mihai <(E-Mail Removed)> wrote:
> >> from extconf.rb:6:in `method_missing'
> >> from extconf.rb:34

>
> >> Gem files will remain installed in
> >> c:/ruby/lib/ruby/gems/1.8/gems/libxml-ruby-0.
> >> 5.4 for inspection.
> >> Results logged to
> >> c:/ruby/lib/ruby/gems/1.8/gems/libxml-ruby-0.5.4/ext/libxml/ge
> >> m_make.out

>
> >> What can i do?

>
> > Change line 34 to:

>
> > objs = srcs.collect do |srcfile|

>
> > (ie. change src -> srcs)

>
> > T.

>
> Tnx, but now i have this error:
> C:\libxml\libxml-ruby-0.5.4\ext\libxml>ruby extconf.rb
> extconf.rb:51: (eval):11: compile error (SyntaxError)
> (eval):2: unknown regexp option - h
> (eval):9: syntax error, unexpected '.'
> (eval):11: syntax error, unexpected $undefined
> hdrdir = $(topdir)
>
> There is a gem to intall it without any error, or could u help me to
> install without gem install command?


Ah, you are installing on Windows. I'm afriad the extconf.rb code is
"under development" with regard to Windows. Let me get back to you.

T.

 
Reply With Quote
 
Bu Mihai
Guest
Posts: n/a
 
      03-28-2008
Trans wrote:
> On Mar 28, 5:25 pm, Bu Mihai <(E-Mail Removed)> wrote:
>> >> m_make.out

>>
>> Tnx, but now i have this error:
>> C:\libxml\libxml-ruby-0.5.4\ext\libxml>ruby extconf.rb
>> extconf.rb:51: (eval):11: compile error (SyntaxError)
>> (eval):2: unknown regexp option - h
>> (eval):9: syntax error, unexpected '.'
>> (eval):11: syntax error, unexpected $undefined
>> hdrdir = $(topdir)
>>
>> There is a gem to intall it without any error, or could u help me to
>> install without gem install command?

>
> Ah, you are installing on Windows. I'm afriad the extconf.rb code is
> "under development" with regard to Windows. Let me get back to you.
>
> T.


Yes im using windows. sorry for not telling that; i really need libxml
because i was using rexml am my xml file is a little big (~1000 lines
for the moment) and methods like find_first_recursive are slow(~10
seconds) so i need something faster.

Tnx for the help.
--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing libxml on osx as Gem nicholas.henry Ruby 2 10-12-2006 02:16 AM
Installing libxml-ruby on Windows: zlib Robert Breininger Ruby 3 06-13-2006 10:10 AM
C++ libraries: Xerces, libxml/libxml++ or perhaps Arabica? Olav XML 3 01-20-2005 02:51 PM
Problem installing ruby-libxml Francis Hwang Ruby 1 12-04-2003 03:02 AM
Problems with libxml, XML::LibXML and Perl Ian Gregory XML 1 07-25-2003 04:20 PM



Advertisments