Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > can't get good rubygems installation

Reply
Thread Tools

can't get good rubygems installation

 
 
Tom Cloyd
Guest
Posts: n/a
 
      03-10-2008
I don't know how to fix this. While installing the radiant gem last
night, something happened to my ruby gems installation. I've removed and
reinstalled it a couple of times, to no particular effect. I'm working
on Kubuntu (7.10) Linux. (I used apt-get for one install, and when that
didn't work I tried the adept package manager - results were the same.)

"gem list --local" produces or "gem help" both produce -
/usr/bin/gem:23: uninitialized constant Gem::GemRunner (NameError)

Any ideas how I can get things back to normal?

Thanks,

Tom

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rubygems 1.3.5 can't load 'rubygems/defaults/operating_sy..' Eric Roscher Ruby 3 11-24-2009 02:15 AM
[BUG] RubyGems: "No such file to load -- rubygems/builder" Erik Veenstra Ruby 4 02-04-2005 10:28 PM
Problems with fresh install of RubyGems on Ubuntu Linux: No suchfile to load -- rubygems/builder (LoadError) Trevor Ruby 5 01-29-2005 12:52 AM
[Ruby Forum] Problem with rubygems installation in Cygwin Alexey Verkhovsky Ruby 1 10-05-2004 03:09 AM
RubyGems 0.8.1: installation of log4r 1.0.5 failed benny Ruby 7 09-26-2004 11:26 PM



Advertisments