Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > Build failure trying to use rb_define_alias on rb_mKernel

Reply
Thread Tools

Build failure trying to use rb_define_alias on rb_mKernel

 
 
Daniel Berger
Guest
Posts: n/a
 
      11-18-2007
Hi,

In object.c, I tried to change this line:
rb_define_method(rb_mKernel, "is_a?", rb_obj_is_kind_of, 1);

To this:
rb_define_alias(rb_mKernel, "is_a?", "kind_of?");

But it dies during the build. What's the issue?

I tried this on Linux and Windows, after a make distclean, btw. Same
result

Thanks,

Dan

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Macro to cause build failure if parameter not defined? skillzero@gmail.com C Programming 7 06-27-2008 06:29 AM
Success Or Failure: There Is No Such Thing As Failure bs866806@163.com C Programming 0 01-06-2008 11:41 AM
Failure trying to build Ruby 1.8.6 on HP-UX 11 Daniel Berger Ruby 4 08-21-2007 11:56 PM
[JAVA] [EVALUATION] - The Java Failure (Sorry: The Java(tm) Failure) Ilias Lazaridis Java 0 02-01-2005 10:32 AM
SWsoft Acronis Disk Director Suite 9.0 Build 508, Acronis OS Selector 8.0 Build 917, Acronis Partition Expert 2003 Build 292, Acronis Power Utilities 2004 Build 502, F-SECURE.ANTI vIRUS.PROXY v1.10.17.WINALL, F-SECURE.ANTI vIRUS v5.50.10260 for CITRI vvcd Computer Support 0 09-25-2004 01:38 AM



Advertisments