Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > windows-api-0.2.0/lib/windows/api.rb:211: [BUG] Segmentation fault

Reply
Thread Tools

windows-api-0.2.0/lib/windows/api.rb:211: [BUG] Segmentation fault

 
 
aidy.lewis@googlemail.com
Guest
Posts: n/a
 
      10-24-2007
Hi,

I am attempting to use ruby 186rc1 one click installer on Windows
Vista and I am getting this error:

c:/ruby/lib/ruby/gems/1.8/gems/windows-api-0.2.0/lib/windows/api.rb:
211: [BUG] Segmentation fault
ruby 1.8.6 (2007-09-24) [i386-mswin32]

Has anyone ever experienced this error or can suggest a fix?

Aidy

 
Reply With Quote
 
 
 
 
Daniel Berger
Guest
Posts: n/a
 
      10-24-2007
http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> Hi,
>
> I am attempting to use ruby 186rc1 one click installer on Windows
> Vista and I am getting this error:
>
> c:/ruby/lib/ruby/gems/1.8/gems/windows-api-0.2.0/lib/windows/api.rb:
> 211: [BUG] Segmentation fault
> ruby 1.8.6 (2007-09-24) [i386-mswin32]
>
> Has anyone ever experienced this error or can suggest a fix?


That's coming from win32-api. The line is simply API.new(...). By any
chance did you build win32-api from source? Or did you install the
prebuilt gem? If you built from source, what compiler did you use?

Thanks,

Dan

 
Reply With Quote
 
 
 
 
bbiker
Guest
Posts: n/a
 
      10-25-2007
On Oct 24, 7:00 pm, Daniel Berger <(E-Mail Removed)> wrote:
> (E-Mail Removed) wrote:
> > Hi,

>
> > I am attempting to use ruby 186rc1 one click installer on Windows
> > Vista and I am getting this error:

>
> > c:/ruby/lib/ruby/gems/1.8/gems/windows-api-0.2.0/lib/windows/api.rb:
> > 211: [BUG] Segmentation fault
> > ruby 1.8.6 (2007-09-24) [i386-mswin32]

>
> > Has anyone ever experienced this error or can suggest a fix?

>
> That's coming from win32-api. The line is simply API.new(...). By any
> chance did you build win32-api from source? Or did you install the
> prebuilt gem? If you built from source, what compiler did you use?
>
> Thanks,
>
> Dan


This may not help the OP, info provide just in case.
The problem may be related to Vista or as you mentioned the gem was
built by the OP rather than installed.

Both win32-api and windows-api work fine on Windows XP.

C:\Documents and Settings\Owner>gem query -n api
*** LOCAL GEMS ***
win32-api (1.0.3)
A superior replacement for Win32API
windows-api (0.2.0)
An easier way to create methods using Win32API

C:\Documents and Settings\Owner>ruby -v
ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]

C:\Documents and Settings\Owner>irb
irb(main):001:0> require 'win32/api'
=> true
irb(main):002:0> require 'windows/api'
=> true

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Segmentation fault using Firefox 15.0.2 Keith Lee Firefox 3 04-29-2006 05:45 PM
Xerces on Solaris - Segmentation fault ldvmbs@gmail.com XML 0 05-16-2005 07:21 AM
Xerces XML Parser Segmentation fault with Java Pud XML 0 11-06-2003 05:07 PM
Intel Xeon + Linux + IBM sdk 1.3.1 - getting Segmentation fault Alex Hunsley Java 17 11-06-2003 12:12 AM
Re: segmentation fault exception handling Ivan Vecerina C++ 0 06-29-2003 10:56 PM



Advertisments