Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > fastthread installation fails - debian - w or w/o gem

Reply
Thread Tools

fastthread installation fails - debian - w or w/o gem

 
 
paukul@googlemail.com
Guest
Posts: n/a
 
      02-26-2007
Hi,

iam trying to install fastthread, but it fails with the message:
---------
Building native extensions. This could take a while...
extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
from extconf.rb:1

ERROR: While executing gem ... (RuntimeError)
ERROR: Failed to build gem native extension.
Gem files will remain installed in /var/lib/gems/1.8/gems/
fastthread-0.6.4.1 for inspection.


Results logged to /var/lib/gems/1.8/gems/fastthread-0.6.4.1/ext/
fastthread/gem_make.out
--------

i tried it both with gem install fastthread and by downloading it from
the project
website und install it with ruby setup.rb => Same result

Iam realy new with ruby so i don't know what to do. google didnt help
me anyway... I'd be happy if someone could give me a hint..

Pascal Friederich

 
Reply With Quote
 
 
 
 
Brian Candler
Guest
Posts: n/a
 
      02-26-2007
On Mon, Feb 26, 2007 at 06:40:05PM +0900, http://www.velocityreviews.com/forums/(E-Mail Removed) wrote:
> Hi,
>
> iam trying to install fastthread, but it fails with the message:
> ---------
> Building native extensions. This could take a while...
> extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
> from extconf.rb:1


For Debian/Ubuntu, you need to install the ruby1.8-dev package to get mkmf
(which is a standard part of Ruby, it's just that Debian broke up the core
Ruby into shrapnel packages)

HTH,

Brian.

 
Reply With Quote
 
 
 
 
paukul@googlemail.com
Guest
Posts: n/a
 
      02-26-2007
On 26 Feb., 10:44, Brian Candler <(E-Mail Removed)> wrote:

> For Debian/Ubuntu, you need to install the ruby1.8-dev package to get mkmf
> (which is a standard part of Ruby, it's just that Debian broke up the core
> Ruby into shrapnel packages)


works. thanks so much!

 
Reply With Quote
 
MenTaLguY
Guest
Posts: n/a
 
      02-26-2007
On Mon, 26 Feb 2007 18:40:05 +0900, "(E-Mail Removed)" <(E-Mail Removed)> wrote:
> Hi,
>
> iam trying to install fastthread, but it fails with the message:
> ---------
> Building native extensions. This could take a while...
> extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
> from extconf.rb:1


You will need to install the ruby1.8-dev Debian package in order to be able to install gems with C extensions (like fastthread).

-mental


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ANN] Builds of PyWebkitGtk and Webkit-Glib-Gtk(r39359+#16401.master) for Debian i386,Debian AMD64 and Macports MacOSX 10.4 Luke Kenneth Casson Leighton Python 0 12-31-2008 08:23 PM
Rubygems 0.9.5 and fastthread mswin32 gem Vassilis Rizopoulos Ruby 5 12-11-2007 03:06 PM
RubyGems 0.9.1 calling a gem with gem '<gem>' Austin 7873 Ruby 5 01-27-2007 10:05 PM
gem query finds gem, yet require fails Michael Glaesemann Ruby 5 11-26-2006 02:23 AM
[Debian] Upgrading to kernel 2.6 in Debian DUser NZ Computing 0 01-11-2004 12:38 AM



Advertisments