Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Repeater_ItemCommand not firing

Reply
Thread Tools

Repeater_ItemCommand not firing

 
 
=?Utf-8?B?RGFsZQ==?=
Guest
Posts: n/a
 
      07-29-2004
I have created a custom repeater that I am using in about 8 webforms in my current project. It has been working for several weeks with no issues. Today, as Visual Studio is prone to do, it dropped the event handler registration from the InitializeComponents method on just one page. After I realized what had happened, I aded the event handling registration back by selecting the event handler method in the properties window as I always do.

Now, the ItemCommand event will not fire for the repeater in that one page. I have deleted the repeater and re-added it from the toolbox, deleted it and re-added it by copying from another page, etc., etc. The repeater works in all other pages except this one. The repeater even has some custom events that are still working in all pages, including the problem page.

Has anyone seen anything like this? Any ideas how just one event on the page can not fire properly when it is properly registered? The code that registers it is the same across all pages:

this.ServerRepeater1.ItemCommand += new System.Web.UI.WebControls.RepeaterCommandEventHand ler(this.ServerRepeater1_ItemCommand);

--
Dale Preston
MCAD C#
MCSE, MCDBA
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
master page does not change due to preinit event not firing franchise63 General Computer Support 0 02-13-2008 09:18 AM
DataGrid ItemCommand event not firing if not first page =?Utf-8?B?ZGFuYw==?= ASP .Net 3 10-26-2005 05:24 PM
DataGris Paging not working (event not firing) Ryan Rueckl ASP .Net Datagrid Control 8 06-24-2005 07:13 PM
Control not maintaing viewState and PostBack not firing event. Don ASP .Net Building Controls 1 05-16-2005 01:45 PM
Re: onkeypress not being recognized, or not firing S. Justin Gengo ASP .Net 0 08-26-2003 04:15 PM



Advertisments