Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > install ruby offline with openssl

Reply
Thread Tools

install ruby offline with openssl

 
 
Ye Huang
Guest
Posts: n/a
 
      01-14-2007
Hi, all:
I know this is an old problem, but I still feel puzzled about it.
After I installed ruby in my computer, I found openssl is not available,
here's the details:
I have two linux machines, one with Ubuntu6.06 and anther with SuSE10.0,
further more, I have a windows machine with windows XP.

I tried several times. Once I installed ruby in windows and gem install
rails, I could always find openssl.rb and openssl folder in my path,
which enable me use net/http very easily.

But I don't get why once I installed ruby1.8.4 into my SuSE with a
download package, I can find openssl.rb and openssl directory in
/usr/local/lib/ruby/1.8; further more, once I tried to install ruby1.8.5
into my ubuntu, I encounter the same problem?!

I have read some solution with ubuntu, using "apt-get install
libssl-dev" or something else, I don't know whether that's because the
earthquake in Taiwan channel , I can't connect to ubuntu update server
very well, meanwhile this online solution won't solve the same problem
in SuSE.

So I wonder if I have to download some standalone ruby language packages
and install ruby offline, how could I make it support openssl as
well.(or did i missed some parameters while configure or make??)

Thanks very much!!

ye

--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
 
Ye Huang
Guest
Posts: n/a
 
      01-14-2007
I think this could be described in one word, how could i install ruby
additional libraries with a download package.

--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ruby-191-p243 or ruby-192-preview Compile error with openssl Philippe Philos Ruby 3 11-11-2010 06:32 AM
Problem with new ruby install and openssl.rb (on Ubuntu) Phor Gruber Ruby 8 02-28-2009 12:28 AM
Ruby and OpenSSL: no such file to load -- openssl (RuntimeError) Redd Vinylene Ruby 6 11-18-2008 08:51 AM
Install/Enable openssl for ruby 1.8.6? Jason Bornhoft Ruby 11 07-03-2008 06:16 PM
[Ruby Forum] Problems building OpenSSL for Ruby on a Win32 platform Alexey Verkhovsky Ruby 0 01-20-2005 10:55 PM



Advertisments