Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > Gem question; error on list -r

Reply
Thread Tools

Gem question; error on list -r

 
 
Patrick Gundlach
Guest
Posts: n/a
 
      09-06-2006
Hi,

I've put my gem command into an unusable state:

~$ gem list --r

*** REMOTE GEMS ***
Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR: While executing gem ... (NoMethodError)
private method `scan' called for #<YAML:rivateType:0x3849600>

I've previously removed source_cache, with source_cache in place, I get
the following

*** REMOTE GEMS ***
Need to update 2 gems from http://gems.rubyforge.org
ERROR: While executing gem ... (URI::InvalidURIError)
bad URI(is not URI?):
http://gems.rubyforge.org/quick/activerecord-jdbc-#<gem::version:0xa53ac84>.gemspec.rz

Could anybody point me to a solution?

TIA,
Patrick

--
Posted via http://www.ruby-forum.com/.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gem list --remote --details gives "ERROR: While executing gem ...(NoMethodError)" Markus Fischer Ruby 4 03-27-2011 12:59 PM
"gem list" and "sudo gem list" yield different results Mike Nicholaides Ruby 3 03-28-2008 02:29 PM
RubyGems 0.9.1 calling a gem with gem '<gem>' Austin 7873 Ruby 5 01-27-2007 10:05 PM
gem.cmd install RMagick-win32-1.9.2-mswin32.gem: Buffer error Clifford Heath Ruby 7 06-09-2006 07:02 PM
ERROR: While executing gem ... (Gem::GemNotFoundException) Could not find rubygems-upodate (> 0) in the repository han Ruby 1 10-24-2005 10:28 PM



Advertisments