Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > Help needed to figure out Ruby 1.8.4 installation failure

Reply
Thread Tools

Help needed to figure out Ruby 1.8.4 installation failure

 
 
Paul Van Delst
Guest
Posts: n/a
 
      06-02-2006
Hello,

I was doing a re-install (don't ask) of Ruby 1.8.4 on my RHE4 machine and I am getting the
following failure:

..... other stuff successfully completed.....
make[1]: Entering directory `/usr1/wd20pd/local/ruby-1.8.4/ext/openssl'
gcc -fPIC -g -O2 -I. -I../.. -I../../. -I../.././ext/openssl -DHAVE_UNISTD_H
-DHAVE_SYS_TIME_H -DHAVE_ASSERT_H -DHAVE_OPENSSL_SSL_H -DHAVE_OPENSSL_CONF_API_H
-DHAVE_ERR_PEEK_LAST_ERROR -DHAVE_BN_MOD_ADD -DHAVE_BN_MOD_SQR -DHAVE_BN_MOD_SUB
-DHAVE_BN_PSEUDO_RAND_RANGE -DHAVE_BN_RAND_RANGE -DHAVE_CONF_GET1_DEFAULT_CONFIG_FILE
-DHAVE_EVP_CIPHER_CTX_SET_PADDING -DHAVE_EVP_CIPHERFINAL_EX -DHAVE_EVP_CIPHERINIT_EX
-DHAVE_EVP_DIGESTFINAL_EX -DHAVE_EVP_DIGESTINIT_EX -DHAVE_EVP_MD_CTX_CLEANUP
-DHAVE_EVP_MD_CTX_CREATE -DHAVE_EVP_MD_CTX_DESTROY -DHAVE_EVP_MD_CTX_INIT
-DHAVE_HMAC_CTX_CLEANUP -DHAVE_HMAC_CTX_INIT -DHAVE_PEM_DEF_CALLBACK
-DHAVE_X509V3_SET_NCONF -DHAVE_X509V3_EXT_NCONF_NID -DHAVE_X509_CRL_ADD0_REVOKED
-DHAVE_X509_CRL_SET_ISSUER_NAME -DHAVE_X509_CRL_SET_VERSION -DHAVE_X509_CRL_SORT
-DHAVE_OPENSSL_CLEANSE -DHAVE_VA_ARGS_MACRO -DHAVE_OPENSSL_ENGINE_H -DHAVE_ENGINE_ADD
-DHAVE_ENGINE_LOAD_BUILTIN_ENGINES -DHAVE_ENGINE_GET_DIGEST -DHAVE_ENGINE_GET_CIPHER
-DHAVE_ENGINE_CLEANUP -DHAVE_OPENSSL_OCSP_H -c ossl_x509name.c
In file included from /usr/include/openssl/asn1.h:67,
from /usr/include/openssl/asn1_mac.h:62,
from ossl.h:37,
from ossl_x509name.c:11:
/usr1/wd20pd/local/gfortran/irun/bin/../lib/gcc/i386-linux/4.2.0/include/openssl/bn.h:301:
error: expected specifier-qualifier-list before 'BIGNUM'
/usr1/wd20pd/local/gfortran/irun/bin/../lib/gcc/i386-linux/4.2.0/include/openssl/bn.h:314:
error: expected specifier-qualifier-list before 'BIGNUM'
/usr1/wd20pd/local/gfortran/irun/bin/../lib/gcc/i386-linux/4.2.0/include/openssl/bn.h:331:
error: expected declaration specifiers or '...' before 'BN_GENCB'

etc..... for about a couple 100 more lines. I just installed the latest version of
gfortran the other day and, somehow, the ruby install is looking in the gfortran
irun/lib/gcc/i386-linux/4.2.0/include/openssl for the bn.h header file.

Does anybody have *any* idea how get around this problem? It's got me stumped. I have no
idea why the ruby install is looking in my local installation of gfortran for the openssl
stuff.

Thanks for any info.

cheers,

paulv

--
Paul van Delst Ride lots.
CIMSS @ NOAA/NCEP/EMC Eddy Merckx
Ph: (301)763-8000 x7748
Fax301)763-8545
 
Reply With Quote
 
 
 
 
Paul Van Delst
Guest
Posts: n/a
 
      06-02-2006
Paul Van Delst wrote:
> Hello,
>
> I was doing a re-install (don't ask) of Ruby 1.8.4 on my RHE4 machine
> and I am getting the following failure:


No need - I figured it out. The path order of the new gcc install (v4.2) was defined
before the older (ruby-compatible) one (v3.4.5)

Apologies for the wasted bandwidth.

cheers,

paulv

--
Paul van Delst Ride lots.
CIMSS @ NOAA/NCEP/EMC Eddy Merckx
Ph: (301)763-8000 x7748
Fax301)763-8545
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me figure out a problem... PlainDave HTML 1 02-05-2006 07:24 AM
Help me figure out a problem... PlainDave HTML 0 02-05-2006 06:42 AM
I can not figure this vhdl logic out, help. logia VHDL 6 01-16-2006 03:03 PM
Please Help! Can't figure this out... Chad A. Beckner ASP .Net 2 06-21-2004 08:58 AM
Windows error.please help me figure it out jamie kate fraser Computer Support 3 09-03-2003 03:51 AM



Advertisments