Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > Installing ruby-libs-1.8.4-0.4.preview2.i386.rpm on FC4?

Reply
Thread Tools

Installing ruby-libs-1.8.4-0.4.preview2.i386.rpm on FC4?

 
 
Philip Rhoades
Guest
Posts: n/a
 
      01-02-2006
People,

Has anyone been able to install these preview RPMs?

I get:

rpm -ivh ruby-libs-1.8.4-0.4.preview2.i386.rpm

error: Failed dependencies:
libc.so.6(GLIBC_2.4) is needed by
ruby-libs-1.8.4-0.4.preview2.i386
libcrypto.so.6 is needed by ruby-libs-1.8.4-0.4.preview2.i386
libssl.so.6 is needed by ruby-libs-1.8.4-0.4.preview2.i386

I don't know if upgrading glibc-2.3.5 to glibc-2.3.90 would help but I
am worried that it would break lots of things . .

I have been able to build 1.8.4 from source but I need to install:

ruby-devel-1.8.4-0.4.preview2.i386.rpm

to get Rails working with PostgreSQL?

Thanks,

Phil.
--
Philip Rhoades

Pricom Pty Limited (ACN 003 252 275 ABN 91 003 252 275)
GPO Box 3411
Sydney NSW 2001
Australia
Mobile: +610)411-185-652
Fax: +610)2-8221-9599
E-mail: http://www.velocityreviews.com/forums/(E-Mail Removed)




 
Reply With Quote
 
 
 
 
Oliver Andrich
Guest
Posts: n/a
 
      01-02-2006
Hi,

if you actually want to use these RPMs, I would fetch the SRPM
(source RPM) and compile it on my own. The path you want to stride, is
the path to FC5 test 1 (or whatever is current). ANd this path you don't
want to walk at the moment.

I am not sure, why you need 1.8.4 for a Rails with PostgreSQL, cause I
don't use PostgreSQL. But my Rails setup works fine so far with the
1.8.3 RPM from FC4.

But let me repeat it. If you want to use the preview RPM, then go and
fetch the SRPM. Compile it on your system and use the result.

Best regards,
Oliver


 
Reply With Quote
 
 
 
 
vnpenguin@gmail.com
Guest
Posts: n/a
 
      01-02-2006
I make a rpm of 1.8.4 for ... myself on FC4
So if you want try it :
http://people.vnoss.org/~vnpenguin/pub/rpm/ruby/

 
Reply With Quote
 
Oliver Andrich
Guest
Posts: n/a
 
      01-06-2006
Just for the record, today 1.8.4 has been pushed back from FC5 to FC4. I
got this information as an answer to a Bugreport I opened. It is also
already available as an update.

Best regards,
Oliver

--
Oliver Andrich --- (E-Mail Removed) --- http://roughbook.de/


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble installing the peer-to-peer component =?Utf-8?B?TWFya28=?= Wireless Networking 1 12-28-2004 03:41 AM
Wireless Problems After Installing SP2 Brian \(BK's Computing\) Wireless Networking 15 12-11-2004 06:03 AM
Installing Symantec VPN and received IP Address error =?Utf-8?B?RnJhbms=?= Wireless Networking 0 12-06-2004 11:05 PM
No internet connection after installing SP2 using Microsoft Broadb =?Utf-8?B?ZnJ1c3RyYXRlZCBub3ZpY2U=?= Wireless Networking 3 10-16-2004 11:01 PM
cannot create wireless network at all after installing SP2 Headtheball Wireless Networking 2 09-06-2004 03:53 PM



Advertisments