Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > gem oddities?

Reply
Thread Tools

gem oddities?

 
 
Stu
Guest
Posts: n/a
 
      12-28-2004
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


have been migrating a lot of my stuff over to my unix box..

on windows, I have latest rubygems, and have the ncurses 0.9.1,
my code has

require "ncurses"

and all works fine...

on my unix box, i have rubygems same version and ncurses 0.9.1
gem installed...

but now I get

rfm.rb:10:in `require': No such file to load -- NCurses (LoadError)
from rfm.rb:10

I dont know whats wrong. All the NCurses examples give same error...
works on windows, does not work on my test linux box...

windows is using pdcurses 2.4,
linux is using ncurses 5.4...

what do I need to do to make the requre "ncurses" work??

- --
- -- Stu

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFB0WM4Hke2U6OXzu0RAjFrAJ90a2lMvnUQpQHH86xbcZ F9LfGhDwCffHxH
MjjB2s82NZ41OGI/FFmLF7U=
=PZ9w
-----END PGP SIGNATURE-----
 
Reply With Quote
 
 
 
 
Kaspar Schiess
Guest
Posts: n/a
 
      12-29-2004
(In response to news:IqdAd.73$(E-Mail Removed) by Stu)

> what do I need to do to make the requre "ncurses" work??


Have you set RUBYOPT=rubygems to autorequire rubygems ? Excuse me if this
is a silly question to ask..

kaspar

hand manufactured code - www.tua.ch/ruby



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RubyGems 0.9.1 calling a gem with gem '<gem>' Austin 7873 Ruby 5 01-27-2007 10:05 PM
gem.cmd install RMagick-win32-1.9.2-mswin32.gem: Buffer error Clifford Heath Ruby 7 06-09-2006 07:02 PM
[GEM PATCH] allow gem to install bin file to different location Ara.T.Howard Ruby 0 10-26-2005 11:52 PM
ERROR: While executing gem ... (Gem::GemNotFoundException) Could not find rubygems-upodate (> 0) in the repository han Ruby 1 10-24-2005 10:28 PM
[ANN] Getopt-Declare 1.12 (gem/zip) and GGEnv (gem/zip) gga Ruby 0 07-18-2005 03:21 PM



Advertisments