Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > "Bad file descriptor" with Webrick/Instiki service

Reply
Thread Tools

"Bad file descriptor" with Webrick/Instiki service

 
 
Daniel Berger
Guest
Posts: n/a
 
      08-29-2004
Hi all,

Ruby 1.8.2 R7
Windows 2000

I setup Instiki as a service on my home Windows box. For the most
part, it seems to work just fine. Every once and a while, however, it
flakes out and I get this error:

Internal Server Error
Bad File Descriptor
WEBrick/1.3.1 (Ruby/1.8.2/2004-07-29) at localhost:2500.

It appears only sporadically and seems to be harmless - going back and
forward again in the browser usually fixes it.

Any ideas? What little I saw in the .command_log wasn't helpful.

Regards,

Dan
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
InvocationTargetException when calling "new Service()" in Axis web service to call another web service Michael Averstegge Java 0 01-10-2006 11:05 PM
Calling a Web Service using Axis, from within an Axis Web Service running under Tomcat hocho888 Java 1 04-29-2005 08:26 PM
How to public a service behind a PIX changing the port of the service. AM Cisco 1 03-07-2005 05:57 PM
.NET C# service error 1053, service could not start in timely fash =?Utf-8?B?M2Ry?= ASP .Net 2 09-07-2004 09:50 AM
The World Wide Web Publishing Service service hung on starting Saber S ASP .Net 1 11-14-2003 03:32 PM



Advertisments