Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Ruby > I know I am beginning to sound whiney... but I need help :/

Reply
Thread Tools

I know I am beginning to sound whiney... but I need help :/

 
 
Mike J.
Guest
Posts: n/a
 
      03-07-2004
...but now I have rebuilt my system, and installed ruby, installed
sqlite (which I know works because I have created a database replete
with tables and data and other apps see it, like BeAccessible) but when
I try to install ruby-dbi or sqlite-ruby it bombs.

$ ruby -v
ruby 1.6.4 (2001-06-04) [i586-beos]

sqlite-ruby:

$ ruby extconf.rb
checking for main() in -lsqlite... no
checking for sqlite.h... yes
checking for sqlite_open() in -lsqlite... no

ruby-dbi:

$ ruby setup.rb show
bin-dir /boot/home/config/bin
rb-dir /boot/home/config/lib/ruby/site_ruby/1.6
so-dir /boot/home/config/lib/ruby/site_ruby/1.6/i586-beos
ruby-path /boot/home/config/bin/ruby
make-prog make
with dbi,dbd_sqlite
without (not specified)
$

$ ruby setup.rb setup
entering setup phase...
setting #! line to "#!/boot/home/config/bin/ruby"
setup.rb: skip bin/proxyserver(dbd_proxy) by user option
/boot/home/config/bin/ruby extconf.rb
checking for sqlite_open() in -lsqlite... no
make
make: *** No targets. Stop.
setup failed
'system make' failed
try "ruby setup.rb --help" for usage
$

I am at my wits end!! Does anyone have ANY idea what could be going
wrong?? As I said, other applications see sqlite just fine, why can't
ruby pick it up??


 
Reply With Quote
 
 
 
 
Jamis Buck
Guest
Posts: n/a
 
      03-07-2004
Mike J. wrote:
> ...but now I have rebuilt my system, and installed ruby, installed
> sqlite (which I know works because I have created a database replete
> with tables and data and other apps see it, like BeAccessible) but when
> I try to install ruby-dbi or sqlite-ruby it bombs.
>
> $ ruby -v
> ruby 1.6.4 (2001-06-04) [i586-beos]
>
> sqlite-ruby:
>
> $ ruby extconf.rb
> checking for main() in -lsqlite... no
> checking for sqlite.h... yes
> checking for sqlite_open() in -lsqlite... no
>


Try looking in the mkmf.log file -- it should explain why the last check
is failing. Or, email it (mkmf.log) to me (directly:
http://www.velocityreviews.com/forums/(E-Mail Removed)) and I'll take a look at it (I'm the author of
sqlite-ruby, so I suppose it's my responsibility...).

- Jamis

--
Jamis Buck
(E-Mail Removed)
http://www.jamisbuck.org/jamis

ruby -h | ruby -e
'a=[];readlines.join.scan(/-(.)\[e|Kk(\S*)|le.l(..)e|#!(\S*)/) {|r| a <<
r.compact.first };puts "\n>#{a.join(%q/ /)}<\n\n"'


 
Reply With Quote
 
 
 
 
daz
Guest
Posts: n/a
 
      03-07-2004

Jamis Buck wrote:
> Mike J. wrote:
> >
> > $ ruby -v
> > ruby 1.6.4 (2001-06-04) [i586-beos]
> >
> > sqlite-ruby:
> >
> > $ ruby extconf.rb
> > checking for main() in -lsqlite... no
> > checking for sqlite.h... yes
> > checking for sqlite_open() in -lsqlite... no
> >

>
> Try looking in the mkmf.log file -- it should explain why the last check
> is failing. Or, email it (mkmf.log) to me (directly:
> (E-Mail Removed)) and I'll take a look at it (I'm the author of
> sqlite-ruby, so I suppose it's my responsibility...).
>
> - Jamis
>


I added a dir_config to the extconf.rb file to install.

"D:/SQLite" <your path here> contains two sub-directories (include & lib)
which mkmf.rb uses to create the Makefile. Without this, sqlite.h and
sqlite.lib are sought in the <?>standard search path</?>.

#-----------------------
require 'mkmf'

dir_config("sqlite", "D:/SQLite") # <--- ADDED line

have_library( "sqlite" )
if have_header( "sqlite.h" ) and have_library( "sqlite", "sqlite_open" )
create_makefile( "_sqlite" )
end
#-----------------------

dir_config allows command line parameters of (e.g.) ...
--with-sqlite-lib=usr/local/env/dev/nul/blah
(That's one Windows user's idea of a non-Windows pathname)


daz



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
index of string from beginning of line vs beginning of file Jesse B. Ruby 9 03-27-2010 04:04 PM
Have a sound wav play from the beginning every time? OBAFGKM_RNS@yahoo.com Javascript 1 07-03-2008 02:58 AM
Device Manager shows sound, but no sound. Format from vista to xp. lbbss Computer Support 16 04-02-2008 06:34 AM
No sound in flash games/video, but sound on startup =?Utf-8?B?VGhlIFR3b2JhZG91cnM=?= Windows 64bit 3 08-22-2005 05:45 PM
I know, I know, I don't know Andries Perl Misc 3 04-23-2004 02:17 AM



Advertisments