Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > can anyone answer this

Reply
Thread Tools

can anyone answer this

 
 
Mike
Guest
Posts: n/a
 
      06-21-2004
Ok heres the issue. I have a copy of the production database localy on my
machine for developing, the DB has null values in some rows, now when i run
my code against the row of data that has NULL values in the columns, i get
no errors, Now here is the issue, when I go against the same database on our
test server and the asp.net code is on the web server I'm getting errors
when the value is NULL,

Why will NULLS work on my local copy of the db, and the vb.net/asp.net code
is the same on my local box as it is on the web server?

Confused


 
Reply With Quote
 
 
 
 
Craig Deelsnyder
Guest
Posts: n/a
 
      06-22-2004
Mike wrote:
> Ok heres the issue. I have a copy of the production database localy on my
> machine for developing, the DB has null values in some rows, now when i run
> my code against the row of data that has NULL values in the columns, i get
> no errors, Now here is the issue, when I go against the same database on our
> test server and the asp.net code is on the web server I'm getting errors
> when the value is NULL,
>
> Why will NULLS work on my local copy of the db, and the vb.net/asp.net code
> is the same on my local box as it is on the web server?
>
> Confused
>
>


Are you sure that you didn't accidentally have the NULLs transformed
into empty values (empty strings, etc.) by DTS or however you 'copied'
the database locally? Confirm that there are actually NULLs in your
local DB either thru Ent. Manager or debug the code and verify the
values are NULL. Might be overkill, but there's no reason I can think
of for the code to act differently....

BTW, I'm assuming SQLServer...

--
Craig Deelsnyder
Microsoft MVP - ASP/ASP.NET
 
Reply With Quote
 
 
 
 
M. Zeeshan Mustafa
Guest
Posts: n/a
 
      06-22-2004
It sometimes happen in release-mode build and not in debug-mode build, of
course
you can not debug your application that is compiled in release mode.

Solution: handle all fields for nulls.

--
Hope this helps,
Zeeshan Mustafa, MCSD


"Mike" <(E-Mail Removed)> wrote in message
news:Ol3h3I%(E-Mail Removed)...
> Ok heres the issue. I have a copy of the production database localy on my
> machine for developing, the DB has null values in some rows, now when i

run
> my code against the row of data that has NULL values in the columns, i get
> no errors, Now here is the issue, when I go against the same database on

our
> test server and the asp.net code is on the web server I'm getting errors
> when the value is NULL,
>
> Why will NULLS work on my local copy of the db, and the vb.net/asp.net

code
> is the same on my local box as it is on the web server?
>
> Confused
>
>



 
Reply With Quote
 
Trevor Benedict R
Guest
Posts: n/a
 
      06-22-2004
Can U give more information on this.
OS + SP
Framework Version
Database
SQL Provide or OleDBProvider

Regards,

Trevor Benedict R
MCSD

*** Sent via Devdex http://www.devdex.com ***
Don't just participate in USENET...get rewarded for it!
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrong answer equals to a blank answer or not? Zadkin Microsoft Certification 8 06-27-2006 01:51 PM
can anyone answer this tuff question? =?Utf-8?B?RGlmZmlkZW50?= ASP .Net 1 01-06-2005 09:04 PM
can anyone answer this for me? Joe Van Meer ASP .Net Web Controls 1 05-08-2004 05:43 PM
Client Side Javascript / DataGrid question - Can anyone answer this? James Radke ASP .Net Web Controls 1 10-27-2003 07:29 AM



Advertisments