Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP General > Fail to create IXSSO.Query object

Reply
Thread Tools

Fail to create IXSSO.Query object

 
 
csw
Guest
Posts: n/a
 
      06-08-2010
I'm moving classic asp sites from Windows 2000 / IIS 5 to Windows 2008 R2 /
IIS 7.

* We have the "Indexing Service" started.
* I have application pool in 32 bit mode.
* IXSSO.DLL is present in System32 directory. (dated 7/13/2009)
* Catalogs were created and looked OK.


However, I am unable to create an ixsso.Query object.
Get the following error message :

Microsoft VBScript runtime error '800a01ad'
ActiveX component can't create object
/HC/ECO/Announcements/Headlines/SearchResults.asp, line 39

my ASP code :
<%
Dim sSearchString
Dim oQuery
Dim results()
sSearchString = Request.Form("query")
Const SEARCH_CATALOG = "Headlines"

Set oQuery =
Server.CreateObject("IXSSO.Query")
oQuery.Catalog = SEARCH_CATALOG
oQuery.Query = "@all " & sSearchString &
" AND NOT #path *downloads* AND NOT #path *images* AND NOT #filename *.class
AND NOT #filename *.asa AND NOT #filename *.css AND NOT #filename
*postinfo.html AND NOT *.txt AND NOT #filename sendmail.asp, AND NOT
#filename *defaultpopup.asp"

oQuery.MaxRecords = 50
' sort by creation date
oQuery.SortBy = "Create[d]"
'oQuery.SortBy = "rank[d]"
oQuery.Columns = "Htmlhref, DocAuthor,
vpath, doctitle, FileName, Path, Write, Size, Rank, Create, Characterization,
DocCategory, HitCount"
Set oRS =
oQuery.CreateRecordSet("nonsequential")
%>


It crashed at " Set oQuery = Server.CreateObject("IXSSO.Query") "


My questions:
1)Can I copy IXSSO.DLL from W2K (6/19/2003) 32 Bit to W2K8? Thus the
"bitness" issue can be resolved.
2) If this permission issues, what kind of permission I need to grant
accounts and directory? I set up the web application with "Window
Authentication mode" and using IIS_IUSRS group (the new build in group).
 
Reply With Quote
 
 
 
 
Bob Barrows
Guest
Posts: n/a
 
      06-08-2010
csw wrote:
> I'm moving classic asp sites from Windows 2000 / IIS 5 to Windows
> 2008 R2 / IIS 7.
>
> * We have the "Indexing Service" started.
> * I have application pool in 32 bit mode.
> * IXSSO.DLL is present in System32 directory. (dated 7/13/2009)
> * Catalogs were created and looked OK.
>
>
> However, I am unable to create an ixsso.Query object.
> Get the following error message :
>
> Microsoft VBScript runtime error '800a01ad'
> ActiveX component can't create object
> /HC/ECO/Announcements/Headlines/SearchResults.asp, line 39
>
> my ASP code :


irrelevant

> It crashed at " Set oQuery = Server.CreateObject("IXSSO.Query")
> "
>
>
> My questions:
> 1)Can I copy IXSSO.DLL from W2K (6/19/2003) 32 Bit to W2K8? Thus the
> "bitness" issue can be resolved.


"bitness"? Is WS2008 necessarily 64-bit? If so, you will also need to either
find a 64-bit version of the dll is it exists, or force IIS to run in 32-bit
mode (I forget how to do that but google should supply the answer).
If you are using ADO, especially with Jet backend, you will likely to have
already forced IIS into 32-bit mode.

> 2) If this permission issues, what kind of permission I need to grant
> accounts and directory? I set up the web application with "Window
> Authentication mode" and using IIS_IUSRS group (the new build in
> group).


If it's not a "bitness" issue, then it's more likely a registration issue.
Have you registered the dll? Use regsvr32.exe to register it, unless WS2008
has a different tool.

If you still have issues and get no answers here, you might want post in the
iis group.

--
Bob Barrows


 
Reply With Quote
 
 
 
 
csw
Guest
Posts: n/a
 
      06-08-2010
Bob

Thanks for the reply. I already forced IIS into 32-bit mode. That's why I
thought to copy the w2k IXSSO.dll ( 32-bit) to replace the W2K8 version). I
was wondering if any one ever did that and succeeded??

I also will try to register the dll again. new version and old version.

csw



"Bob Barrows" wrote:

> csw wrote:
> > I'm moving classic asp sites from Windows 2000 / IIS 5 to Windows
> > 2008 R2 / IIS 7.
> >
> > * We have the "Indexing Service" started.
> > * I have application pool in 32 bit mode.
> > * IXSSO.DLL is present in System32 directory. (dated 7/13/2009)
> > * Catalogs were created and looked OK.
> >
> >
> > However, I am unable to create an ixsso.Query object.
> > Get the following error message :
> >
> > Microsoft VBScript runtime error '800a01ad'
> > ActiveX component can't create object
> > /HC/ECO/Announcements/Headlines/SearchResults.asp, line 39
> >
> > my ASP code :

>
> irrelevant
>
> > It crashed at " Set oQuery = Server.CreateObject("IXSSO.Query")
> > "
> >
> >
> > My questions:
> > 1)Can I copy IXSSO.DLL from W2K (6/19/2003) 32 Bit to W2K8? Thus the
> > "bitness" issue can be resolved.

>
> "bitness"? Is WS2008 necessarily 64-bit? If so, you will also need to either
> find a 64-bit version of the dll is it exists, or force IIS to run in 32-bit
> mode (I forget how to do that but google should supply the answer).
> If you are using ADO, especially with Jet backend, you will likely to have
> already forced IIS into 32-bit mode.
>
> > 2) If this permission issues, what kind of permission I need to grant
> > accounts and directory? I set up the web application with "Window
> > Authentication mode" and using IIS_IUSRS group (the new build in
> > group).

>
> If it's not a "bitness" issue, then it's more likely a registration issue.
> Have you registered the dll? Use regsvr32.exe to register it, unless WS2008
> has a different tool.
>
> If you still have issues and get no answers here, you might want post in the
> iis group.
>
> --
> Bob Barrows
>
>
> .
>

 
Reply With Quote
 
Dan
Guest
Posts: n/a
 
      06-09-2010
Don't forget that you can't just overwrite the 64-bit W2K8 version with the
32-bit DLL from W2K - 64-bit and 32-bit DLLs are in different folders in a
64-bit Windows install.

Can you switch IIS back to 64-bit mode and see if that then works? If you're
on W2K8 64-bit then that would explain why IXSSO.DLL can't be loaded - it's
a 64-bit DLL, and so your ASP application has to be running in 64-bit mode
to load it.

Dan


"csw" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Bob
>
> Thanks for the reply. I already forced IIS into 32-bit mode. That's why
> I
> thought to copy the w2k IXSSO.dll ( 32-bit) to replace the W2K8 version).
> I
> was wondering if any one ever did that and succeeded??
>
> I also will try to register the dll again. new version and old version.
>
> csw
>
>
>
> "Bob Barrows" wrote:
>
>> csw wrote:
>> > I'm moving classic asp sites from Windows 2000 / IIS 5 to Windows
>> > 2008 R2 / IIS 7.
>> >
>> > * We have the "Indexing Service" started.
>> > * I have application pool in 32 bit mode.
>> > * IXSSO.DLL is present in System32 directory. (dated 7/13/2009)
>> > * Catalogs were created and looked OK.
>> >
>> >
>> > However, I am unable to create an ixsso.Query object.
>> > Get the following error message :
>> >
>> > Microsoft VBScript runtime error '800a01ad'
>> > ActiveX component can't create object
>> > /HC/ECO/Announcements/Headlines/SearchResults.asp, line 39
>> >
>> > my ASP code :

>>
>> irrelevant
>>
>> > It crashed at " Set oQuery = Server.CreateObject("IXSSO.Query")
>> > "
>> >
>> >
>> > My questions:
>> > 1)Can I copy IXSSO.DLL from W2K (6/19/2003) 32 Bit to W2K8? Thus the
>> > "bitness" issue can be resolved.

>>
>> "bitness"? Is WS2008 necessarily 64-bit? If so, you will also need to
>> either
>> find a 64-bit version of the dll is it exists, or force IIS to run in
>> 32-bit
>> mode (I forget how to do that but google should supply the answer).
>> If you are using ADO, especially with Jet backend, you will likely to
>> have
>> already forced IIS into 32-bit mode.
>>
>> > 2) If this permission issues, what kind of permission I need to grant
>> > accounts and directory? I set up the web application with "Window
>> > Authentication mode" and using IIS_IUSRS group (the new build in
>> > group).

>>
>> If it's not a "bitness" issue, then it's more likely a registration
>> issue.
>> Have you registered the dll? Use regsvr32.exe to register it, unless
>> WS2008
>> has a different tool.
>>
>> If you still have issues and get no answers here, you might want post in
>> the
>> iis group.
>>
>> --
>> Bob Barrows
>>
>>
>> .
>>




 
Reply With Quote
 
csw
Guest
Posts: n/a
 
      06-09-2010
Dan
I switched back to 64-bit Application Pool, then it ran. Then,

it crashed on

set conn = server.createobject("ADODB.Connection")
conn.open "DBQ=" & Server.MapPath("/Employees/Directory/ldapexchange.mdb") &
";Driver={Microsoft Access Driver (*.mdb)};"

This is the reason that have to use 32-bit application pool. So, if I copy
32-bit IXSSO.dll to both 32 and 64 directories, will 64-bit processor run
32-bit dll???



"Dan" wrote:

> Don't forget that you can't just overwrite the 64-bit W2K8 version with the
> 32-bit DLL from W2K - 64-bit and 32-bit DLLs are in different folders in a
> 64-bit Windows install.
>
> Can you switch IIS back to 64-bit mode and see if that then works? If you're
> on W2K8 64-bit then that would explain why IXSSO.DLL can't be loaded - it's
> a 64-bit DLL, and so your ASP application has to be running in 64-bit mode
> to load it.
>
> Dan
>
>
> "csw" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > Bob
> >
> > Thanks for the reply. I already forced IIS into 32-bit mode. That's why
> > I
> > thought to copy the w2k IXSSO.dll ( 32-bit) to replace the W2K8 version).
> > I
> > was wondering if any one ever did that and succeeded??
> >
> > I also will try to register the dll again. new version and old version.
> >
> > csw
> >
> >
> >
> > "Bob Barrows" wrote:
> >
> >> csw wrote:
> >> > I'm moving classic asp sites from Windows 2000 / IIS 5 to Windows
> >> > 2008 R2 / IIS 7.
> >> >
> >> > * We have the "Indexing Service" started.
> >> > * I have application pool in 32 bit mode.
> >> > * IXSSO.DLL is present in System32 directory. (dated 7/13/2009)
> >> > * Catalogs were created and looked OK.
> >> >
> >> >
> >> > However, I am unable to create an ixsso.Query object.
> >> > Get the following error message :
> >> >
> >> > Microsoft VBScript runtime error '800a01ad'
> >> > ActiveX component can't create object
> >> > /HC/ECO/Announcements/Headlines/SearchResults.asp, line 39
> >> >
> >> > my ASP code :
> >>
> >> irrelevant
> >>
> >> > It crashed at " Set oQuery = Server.CreateObject("IXSSO.Query")
> >> > "
> >> >
> >> >
> >> > My questions:
> >> > 1)Can I copy IXSSO.DLL from W2K (6/19/2003) 32 Bit to W2K8? Thus the
> >> > "bitness" issue can be resolved.
> >>
> >> "bitness"? Is WS2008 necessarily 64-bit? If so, you will also need to
> >> either
> >> find a 64-bit version of the dll is it exists, or force IIS to run in
> >> 32-bit
> >> mode (I forget how to do that but google should supply the answer).
> >> If you are using ADO, especially with Jet backend, you will likely to
> >> have
> >> already forced IIS into 32-bit mode.
> >>
> >> > 2) If this permission issues, what kind of permission I need to grant
> >> > accounts and directory? I set up the web application with "Window
> >> > Authentication mode" and using IIS_IUSRS group (the new build in
> >> > group).
> >>
> >> If it's not a "bitness" issue, then it's more likely a registration
> >> issue.
> >> Have you registered the dll? Use regsvr32.exe to register it, unless
> >> WS2008
> >> has a different tool.
> >>
> >> If you still have issues and get no answers here, you might want post in
> >> the
> >> iis group.
> >>
> >> --
> >> Bob Barrows
> >>
> >>
> >> .
> >>

>
>
>
> .
>

 
Reply With Quote
 
Dan
Guest
Posts: n/a
 
      06-10-2010

There is no 64-bit Jet driver, so you've got no choice but to use 32-bit
mode with an Access database and ADO.

No, don't copy the 32-bit IXSSO.DLL to both the 32 and 64-bit system
folders. Put it in the 32-bit folder, which is c:\Windows\SysWOW64 (MS
decided to keep system32 on a 64-bit machine pointing to the native OS
files, and added a 32-bit layer - the WOW emulator - that looks for it's
DLLs in SysWOW64). I don't know if it will work, but if you put it in the
System32 folder then you'll break the 64-bit version of IXSSO.

Dan


"csw" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Dan
> I switched back to 64-bit Application Pool, then it ran. Then,
>
> it crashed on
>
> set conn = server.createobject("ADODB.Connection")
> conn.open "DBQ=" & Server.MapPath("/Employees/Directory/ldapexchange.mdb")
> &
> ";Driver={Microsoft Access Driver (*.mdb)};"
>
> This is the reason that have to use 32-bit application pool. So, if I
> copy
> 32-bit IXSSO.dll to both 32 and 64 directories, will 64-bit processor run
> 32-bit dll???
>
>
>
> "Dan" wrote:
>
>> Don't forget that you can't just overwrite the 64-bit W2K8 version with
>> the
>> 32-bit DLL from W2K - 64-bit and 32-bit DLLs are in different folders in
>> a
>> 64-bit Windows install.
>>
>> Can you switch IIS back to 64-bit mode and see if that then works? If
>> you're
>> on W2K8 64-bit then that would explain why IXSSO.DLL can't be loaded -
>> it's
>> a 64-bit DLL, and so your ASP application has to be running in 64-bit
>> mode
>> to load it.
>>
>> Dan
>>
>>
>> "csw" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>> > Bob
>> >
>> > Thanks for the reply. I already forced IIS into 32-bit mode. That's
>> > why
>> > I
>> > thought to copy the w2k IXSSO.dll ( 32-bit) to replace the W2K8
>> > version).
>> > I
>> > was wondering if any one ever did that and succeeded??
>> >
>> > I also will try to register the dll again. new version and old
>> > version.
>> >
>> > csw
>> >
>> >
>> >
>> > "Bob Barrows" wrote:
>> >
>> >> csw wrote:
>> >> > I'm moving classic asp sites from Windows 2000 / IIS 5 to Windows
>> >> > 2008 R2 / IIS 7.
>> >> >
>> >> > * We have the "Indexing Service" started.
>> >> > * I have application pool in 32 bit mode.
>> >> > * IXSSO.DLL is present in System32 directory. (dated 7/13/2009)
>> >> > * Catalogs were created and looked OK.
>> >> >
>> >> >
>> >> > However, I am unable to create an ixsso.Query object.
>> >> > Get the following error message :
>> >> >
>> >> > Microsoft VBScript runtime error '800a01ad'
>> >> > ActiveX component can't create object
>> >> > /HC/ECO/Announcements/Headlines/SearchResults.asp, line 39
>> >> >
>> >> > my ASP code :
>> >>
>> >> irrelevant
>> >>
>> >> > It crashed at " Set oQuery = Server.CreateObject("IXSSO.Query")
>> >> > "
>> >> >
>> >> >
>> >> > My questions:
>> >> > 1)Can I copy IXSSO.DLL from W2K (6/19/2003) 32 Bit to W2K8? Thus
>> >> > the
>> >> > "bitness" issue can be resolved.
>> >>
>> >> "bitness"? Is WS2008 necessarily 64-bit? If so, you will also need to
>> >> either
>> >> find a 64-bit version of the dll is it exists, or force IIS to run in
>> >> 32-bit
>> >> mode (I forget how to do that but google should supply the answer).
>> >> If you are using ADO, especially with Jet backend, you will likely to
>> >> have
>> >> already forced IIS into 32-bit mode.
>> >>
>> >> > 2) If this permission issues, what kind of permission I need to
>> >> > grant
>> >> > accounts and directory? I set up the web application with "Window
>> >> > Authentication mode" and using IIS_IUSRS group (the new build in
>> >> > group).
>> >>
>> >> If it's not a "bitness" issue, then it's more likely a registration
>> >> issue.
>> >> Have you registered the dll? Use regsvr32.exe to register it, unless
>> >> WS2008
>> >> has a different tool.
>> >>
>> >> If you still have issues and get no answers here, you might want post
>> >> in
>> >> the
>> >> iis group.
>> >>
>> >> --
>> >> Bob Barrows
>> >>
>> >>
>> >> .
>> >>

>>
>>
>>
>> .
>>




 
Reply With Quote
 
csw
Guest
Posts: n/a
 
      06-10-2010
Dan

After I copy w2k3 IXSSO.dll to sysWOW64, it crashed. I won't run.

: (

"Dan" wrote:

>
> There is no 64-bit Jet driver, so you've got no choice but to use 32-bit
> mode with an Access database and ADO.
>
> No, don't copy the 32-bit IXSSO.DLL to both the 32 and 64-bit system
> folders. Put it in the 32-bit folder, which is c:\Windows\SysWOW64 (MS
> decided to keep system32 on a 64-bit machine pointing to the native OS
> files, and added a 32-bit layer - the WOW emulator - that looks for it's
> DLLs in SysWOW64). I don't know if it will work, but if you put it in the
> System32 folder then you'll break the 64-bit version of IXSSO.
>
> Dan
>
>
> "csw" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > Dan
> > I switched back to 64-bit Application Pool, then it ran. Then,
> >
> > it crashed on
> >
> > set conn = server.createobject("ADODB.Connection")
> > conn.open "DBQ=" & Server.MapPath("/Employees/Directory/ldapexchange.mdb")
> > &
> > ";Driver={Microsoft Access Driver (*.mdb)};"
> >
> > This is the reason that have to use 32-bit application pool. So, if I
> > copy
> > 32-bit IXSSO.dll to both 32 and 64 directories, will 64-bit processor run
> > 32-bit dll???
> >
> >
> >
> > "Dan" wrote:
> >
> >> Don't forget that you can't just overwrite the 64-bit W2K8 version with
> >> the
> >> 32-bit DLL from W2K - 64-bit and 32-bit DLLs are in different folders in
> >> a
> >> 64-bit Windows install.
> >>
> >> Can you switch IIS back to 64-bit mode and see if that then works? If
> >> you're
> >> on W2K8 64-bit then that would explain why IXSSO.DLL can't be loaded -
> >> it's
> >> a 64-bit DLL, and so your ASP application has to be running in 64-bit
> >> mode
> >> to load it.
> >>
> >> Dan
> >>
> >>
> >> "csw" <(E-Mail Removed)> wrote in message
> >> news:(E-Mail Removed)...
> >> > Bob
> >> >
> >> > Thanks for the reply. I already forced IIS into 32-bit mode. That's
> >> > why
> >> > I
> >> > thought to copy the w2k IXSSO.dll ( 32-bit) to replace the W2K8
> >> > version).
> >> > I
> >> > was wondering if any one ever did that and succeeded??
> >> >
> >> > I also will try to register the dll again. new version and old
> >> > version.
> >> >
> >> > csw
> >> >
> >> >
> >> >
> >> > "Bob Barrows" wrote:
> >> >
> >> >> csw wrote:
> >> >> > I'm moving classic asp sites from Windows 2000 / IIS 5 to Windows
> >> >> > 2008 R2 / IIS 7.
> >> >> >
> >> >> > * We have the "Indexing Service" started.
> >> >> > * I have application pool in 32 bit mode.
> >> >> > * IXSSO.DLL is present in System32 directory. (dated 7/13/2009)
> >> >> > * Catalogs were created and looked OK.
> >> >> >
> >> >> >
> >> >> > However, I am unable to create an ixsso.Query object.
> >> >> > Get the following error message :
> >> >> >
> >> >> > Microsoft VBScript runtime error '800a01ad'
> >> >> > ActiveX component can't create object
> >> >> > /HC/ECO/Announcements/Headlines/SearchResults.asp, line 39
> >> >> >
> >> >> > my ASP code :
> >> >>
> >> >> irrelevant
> >> >>
> >> >> > It crashed at " Set oQuery = Server.CreateObject("IXSSO.Query")
> >> >> > "
> >> >> >
> >> >> >
> >> >> > My questions:
> >> >> > 1)Can I copy IXSSO.DLL from W2K (6/19/2003) 32 Bit to W2K8? Thus
> >> >> > the
> >> >> > "bitness" issue can be resolved.
> >> >>
> >> >> "bitness"? Is WS2008 necessarily 64-bit? If so, you will also need to
> >> >> either
> >> >> find a 64-bit version of the dll is it exists, or force IIS to run in
> >> >> 32-bit
> >> >> mode (I forget how to do that but google should supply the answer).
> >> >> If you are using ADO, especially with Jet backend, you will likely to
> >> >> have
> >> >> already forced IIS into 32-bit mode.
> >> >>
> >> >> > 2) If this permission issues, what kind of permission I need to
> >> >> > grant
> >> >> > accounts and directory? I set up the web application with "Window
> >> >> > Authentication mode" and using IIS_IUSRS group (the new build in
> >> >> > group).
> >> >>
> >> >> If it's not a "bitness" issue, then it's more likely a registration
> >> >> issue.
> >> >> Have you registered the dll? Use regsvr32.exe to register it, unless
> >> >> WS2008
> >> >> has a different tool.
> >> >>
> >> >> If you still have issues and get no answers here, you might want post
> >> >> in
> >> >> the
> >> >> iis group.
> >> >>
> >> >> --
> >> >> Bob Barrows
> >> >>
> >> >>
> >> >> .
> >> >>
> >>
> >>
> >>
> >> .
> >>

>
>
>
> .
>

 
Reply With Quote
 
Dan
Guest
Posts: n/a
 
      06-11-2010
What crashed? Or do you just mean you get errors? Did you also run
regvsr32.exe to update the registry so that the correct GUID is listed?

Dan


"csw" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Dan
>
> After I copy w2k3 IXSSO.dll to sysWOW64, it crashed. I won't run.
>
> : (
>
> "Dan" wrote:
>
>>
>> There is no 64-bit Jet driver, so you've got no choice but to use 32-bit
>> mode with an Access database and ADO.
>>
>> No, don't copy the 32-bit IXSSO.DLL to both the 32 and 64-bit system
>> folders. Put it in the 32-bit folder, which is c:\Windows\SysWOW64 (MS
>> decided to keep system32 on a 64-bit machine pointing to the native OS
>> files, and added a 32-bit layer - the WOW emulator - that looks for it's
>> DLLs in SysWOW64). I don't know if it will work, but if you put it in the
>> System32 folder then you'll break the 64-bit version of IXSSO.
>>
>> Dan
>>
>>
>> "csw" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>> > Dan
>> > I switched back to 64-bit Application Pool, then it ran. Then,
>> >
>> > it crashed on
>> >
>> > set conn = server.createobject("ADODB.Connection")
>> > conn.open "DBQ=" &
>> > Server.MapPath("/Employees/Directory/ldapexchange.mdb")
>> > &
>> > ";Driver={Microsoft Access Driver (*.mdb)};"
>> >
>> > This is the reason that have to use 32-bit application pool. So, if I
>> > copy
>> > 32-bit IXSSO.dll to both 32 and 64 directories, will 64-bit processor
>> > run
>> > 32-bit dll???
>> >
>> >
>> >
>> > "Dan" wrote:
>> >
>> >> Don't forget that you can't just overwrite the 64-bit W2K8 version
>> >> with
>> >> the
>> >> 32-bit DLL from W2K - 64-bit and 32-bit DLLs are in different folders
>> >> in
>> >> a
>> >> 64-bit Windows install.
>> >>
>> >> Can you switch IIS back to 64-bit mode and see if that then works? If
>> >> you're
>> >> on W2K8 64-bit then that would explain why IXSSO.DLL can't be loaded -
>> >> it's
>> >> a 64-bit DLL, and so your ASP application has to be running in 64-bit
>> >> mode
>> >> to load it.
>> >>
>> >> Dan
>> >>
>> >>
>> >> "csw" <(E-Mail Removed)> wrote in message
>> >> news:(E-Mail Removed)...
>> >> > Bob
>> >> >
>> >> > Thanks for the reply. I already forced IIS into 32-bit mode.
>> >> > That's
>> >> > why
>> >> > I
>> >> > thought to copy the w2k IXSSO.dll ( 32-bit) to replace the W2K8
>> >> > version).
>> >> > I
>> >> > was wondering if any one ever did that and succeeded??
>> >> >
>> >> > I also will try to register the dll again. new version and old
>> >> > version.
>> >> >
>> >> > csw
>> >> >
>> >> >
>> >> >
>> >> > "Bob Barrows" wrote:
>> >> >
>> >> >> csw wrote:
>> >> >> > I'm moving classic asp sites from Windows 2000 / IIS 5 to Windows
>> >> >> > 2008 R2 / IIS 7.
>> >> >> >
>> >> >> > * We have the "Indexing Service" started.
>> >> >> > * I have application pool in 32 bit mode.
>> >> >> > * IXSSO.DLL is present in System32 directory. (dated 7/13/2009)
>> >> >> > * Catalogs were created and looked OK.
>> >> >> >
>> >> >> >
>> >> >> > However, I am unable to create an ixsso.Query object.
>> >> >> > Get the following error message :
>> >> >> >
>> >> >> > Microsoft VBScript runtime error '800a01ad'
>> >> >> > ActiveX component can't create object
>> >> >> > /HC/ECO/Announcements/Headlines/SearchResults.asp, line 39
>> >> >> >
>> >> >> > my ASP code :
>> >> >>
>> >> >> irrelevant
>> >> >>
>> >> >> > It crashed at " Set oQuery =
>> >> >> > Server.CreateObject("IXSSO.Query")
>> >> >> > "
>> >> >> >
>> >> >> >
>> >> >> > My questions:
>> >> >> > 1)Can I copy IXSSO.DLL from W2K (6/19/2003) 32 Bit to W2K8? Thus
>> >> >> > the
>> >> >> > "bitness" issue can be resolved.
>> >> >>
>> >> >> "bitness"? Is WS2008 necessarily 64-bit? If so, you will also need
>> >> >> to
>> >> >> either
>> >> >> find a 64-bit version of the dll is it exists, or force IIS to run
>> >> >> in
>> >> >> 32-bit
>> >> >> mode (I forget how to do that but google should supply the answer).
>> >> >> If you are using ADO, especially with Jet backend, you will likely
>> >> >> to
>> >> >> have
>> >> >> already forced IIS into 32-bit mode.
>> >> >>
>> >> >> > 2) If this permission issues, what kind of permission I need to
>> >> >> > grant
>> >> >> > accounts and directory? I set up the web application with
>> >> >> > "Window
>> >> >> > Authentication mode" and using IIS_IUSRS group (the new build in
>> >> >> > group).
>> >> >>
>> >> >> If it's not a "bitness" issue, then it's more likely a registration
>> >> >> issue.
>> >> >> Have you registered the dll? Use regsvr32.exe to register it,
>> >> >> unless
>> >> >> WS2008
>> >> >> has a different tool.
>> >> >>
>> >> >> If you still have issues and get no answers here, you might want
>> >> >> post
>> >> >> in
>> >> >> the
>> >> >> iis group.
>> >> >>
>> >> >> --
>> >> >> Bob Barrows
>> >> >>
>> >> >>
>> >> >> .
>> >> >>
>> >>
>> >>
>> >>
>> >> .
>> >>

>>
>>
>>
>> .
>>




 
Reply With Quote
 
csw
Guest
Posts: n/a
 
      06-14-2010
Dan

Yes. Sorry I meant the program errored out. Oops, I forgot to run
regvsr32.exe. Let me try it again.

C

"Dan" wrote:

> What crashed? Or do you just mean you get errors? Did you also run
> regvsr32.exe to update the registry so that the correct GUID is listed?
>
> Dan
>
>
> "csw" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > Dan
> >
> > After I copy w2k3 IXSSO.dll to sysWOW64, it crashed. I won't run.
> >
> > : (
> >
> > "Dan" wrote:
> >
> >>
> >> There is no 64-bit Jet driver, so you've got no choice but to use 32-bit
> >> mode with an Access database and ADO.
> >>
> >> No, don't copy the 32-bit IXSSO.DLL to both the 32 and 64-bit system
> >> folders. Put it in the 32-bit folder, which is c:\Windows\SysWOW64 (MS
> >> decided to keep system32 on a 64-bit machine pointing to the native OS
> >> files, and added a 32-bit layer - the WOW emulator - that looks for it's
> >> DLLs in SysWOW64). I don't know if it will work, but if you put it in the
> >> System32 folder then you'll break the 64-bit version of IXSSO.
> >>
> >> Dan
> >>
> >>
> >> "csw" <(E-Mail Removed)> wrote in message
> >> news:(E-Mail Removed)...
> >> > Dan
> >> > I switched back to 64-bit Application Pool, then it ran. Then,
> >> >
> >> > it crashed on
> >> >
> >> > set conn = server.createobject("ADODB.Connection")
> >> > conn.open "DBQ=" &
> >> > Server.MapPath("/Employees/Directory/ldapexchange.mdb")
> >> > &
> >> > ";Driver={Microsoft Access Driver (*.mdb)};"
> >> >
> >> > This is the reason that have to use 32-bit application pool. So, if I
> >> > copy
> >> > 32-bit IXSSO.dll to both 32 and 64 directories, will 64-bit processor
> >> > run
> >> > 32-bit dll???
> >> >
> >> >
> >> >
> >> > "Dan" wrote:
> >> >
> >> >> Don't forget that you can't just overwrite the 64-bit W2K8 version
> >> >> with
> >> >> the
> >> >> 32-bit DLL from W2K - 64-bit and 32-bit DLLs are in different folders
> >> >> in
> >> >> a
> >> >> 64-bit Windows install.
> >> >>
> >> >> Can you switch IIS back to 64-bit mode and see if that then works? If
> >> >> you're
> >> >> on W2K8 64-bit then that would explain why IXSSO.DLL can't be loaded -
> >> >> it's
> >> >> a 64-bit DLL, and so your ASP application has to be running in 64-bit
> >> >> mode
> >> >> to load it.
> >> >>
> >> >> Dan
> >> >>
> >> >>
> >> >> "csw" <(E-Mail Removed)> wrote in message
> >> >> news:(E-Mail Removed)...
> >> >> > Bob
> >> >> >
> >> >> > Thanks for the reply. I already forced IIS into 32-bit mode.
> >> >> > That's
> >> >> > why
> >> >> > I
> >> >> > thought to copy the w2k IXSSO.dll ( 32-bit) to replace the W2K8
> >> >> > version).
> >> >> > I
> >> >> > was wondering if any one ever did that and succeeded??
> >> >> >
> >> >> > I also will try to register the dll again. new version and old
> >> >> > version.
> >> >> >
> >> >> > csw
> >> >> >
> >> >> >
> >> >> >
> >> >> > "Bob Barrows" wrote:
> >> >> >
> >> >> >> csw wrote:
> >> >> >> > I'm moving classic asp sites from Windows 2000 / IIS 5 to Windows
> >> >> >> > 2008 R2 / IIS 7.
> >> >> >> >
> >> >> >> > * We have the "Indexing Service" started.
> >> >> >> > * I have application pool in 32 bit mode.
> >> >> >> > * IXSSO.DLL is present in System32 directory. (dated 7/13/2009)
> >> >> >> > * Catalogs were created and looked OK.
> >> >> >> >
> >> >> >> >
> >> >> >> > However, I am unable to create an ixsso.Query object.
> >> >> >> > Get the following error message :
> >> >> >> >
> >> >> >> > Microsoft VBScript runtime error '800a01ad'
> >> >> >> > ActiveX component can't create object
> >> >> >> > /HC/ECO/Announcements/Headlines/SearchResults.asp, line 39
> >> >> >> >
> >> >> >> > my ASP code :
> >> >> >>
> >> >> >> irrelevant
> >> >> >>
> >> >> >> > It crashed at " Set oQuery =
> >> >> >> > Server.CreateObject("IXSSO.Query")
> >> >> >> > "
> >> >> >> >
> >> >> >> >
> >> >> >> > My questions:
> >> >> >> > 1)Can I copy IXSSO.DLL from W2K (6/19/2003) 32 Bit to W2K8? Thus
> >> >> >> > the
> >> >> >> > "bitness" issue can be resolved.
> >> >> >>
> >> >> >> "bitness"? Is WS2008 necessarily 64-bit? If so, you will also need
> >> >> >> to
> >> >> >> either
> >> >> >> find a 64-bit version of the dll is it exists, or force IIS to run
> >> >> >> in
> >> >> >> 32-bit
> >> >> >> mode (I forget how to do that but google should supply the answer).
> >> >> >> If you are using ADO, especially with Jet backend, you will likely
> >> >> >> to
> >> >> >> have
> >> >> >> already forced IIS into 32-bit mode.
> >> >> >>
> >> >> >> > 2) If this permission issues, what kind of permission I need to
> >> >> >> > grant
> >> >> >> > accounts and directory? I set up the web application with
> >> >> >> > "Window
> >> >> >> > Authentication mode" and using IIS_IUSRS group (the new build in
> >> >> >> > group).
> >> >> >>
> >> >> >> If it's not a "bitness" issue, then it's more likely a registration
> >> >> >> issue.
> >> >> >> Have you registered the dll? Use regsvr32.exe to register it,
> >> >> >> unless
> >> >> >> WS2008
> >> >> >> has a different tool.
> >> >> >>
> >> >> >> If you still have issues and get no answers here, you might want
> >> >> >> post
> >> >> >> in
> >> >> >> the
> >> >> >> iis group.
> >> >> >>
> >> >> >> --
> >> >> >> Bob Barrows
> >> >> >>
> >> >> >>
> >> >> >> .
> >> >> >>
> >> >>
> >> >>
> >> >>
> >> >> .
> >> >>
> >>
> >>
> >>
> >> .
> >>

>
>
>
> .
>

 
Reply With Quote
 
csw
Guest
Posts: n/a
 
      06-14-2010
Well Dan

It errored out after I registered DLL in WOW64. : (

Here is my quick solution. I created a new web application to run indexing
on 64-bit and kept 32-bit to run MS Access, ADO.

C

"csw" wrote:

> Dan
>
> Yes. Sorry I meant the program errored out. Oops, I forgot to run
> regvsr32.exe. Let me try it again.
>
> C
>
> "Dan" wrote:
>
> > What crashed? Or do you just mean you get errors? Did you also run
> > regvsr32.exe to update the registry so that the correct GUID is listed?
> >
> > Dan
> >
> >
> > "csw" <(E-Mail Removed)> wrote in message
> > news:(E-Mail Removed)...
> > > Dan
> > >
> > > After I copy w2k3 IXSSO.dll to sysWOW64, it crashed. I won't run.
> > >
> > > : (
> > >
> > > "Dan" wrote:
> > >
> > >>
> > >> There is no 64-bit Jet driver, so you've got no choice but to use 32-bit
> > >> mode with an Access database and ADO.
> > >>
> > >> No, don't copy the 32-bit IXSSO.DLL to both the 32 and 64-bit system
> > >> folders. Put it in the 32-bit folder, which is c:\Windows\SysWOW64 (MS
> > >> decided to keep system32 on a 64-bit machine pointing to the native OS
> > >> files, and added a 32-bit layer - the WOW emulator - that looks for it's
> > >> DLLs in SysWOW64). I don't know if it will work, but if you put it in the
> > >> System32 folder then you'll break the 64-bit version of IXSSO.
> > >>
> > >> Dan
> > >>
> > >>
> > >> "csw" <(E-Mail Removed)> wrote in message
> > >> news:(E-Mail Removed)...
> > >> > Dan
> > >> > I switched back to 64-bit Application Pool, then it ran. Then,
> > >> >
> > >> > it crashed on
> > >> >
> > >> > set conn = server.createobject("ADODB.Connection")
> > >> > conn.open "DBQ=" &
> > >> > Server.MapPath("/Employees/Directory/ldapexchange.mdb")
> > >> > &
> > >> > ";Driver={Microsoft Access Driver (*.mdb)};"
> > >> >
> > >> > This is the reason that have to use 32-bit application pool. So, if I
> > >> > copy
> > >> > 32-bit IXSSO.dll to both 32 and 64 directories, will 64-bit processor
> > >> > run
> > >> > 32-bit dll???
> > >> >
> > >> >
> > >> >
> > >> > "Dan" wrote:
> > >> >
> > >> >> Don't forget that you can't just overwrite the 64-bit W2K8 version
> > >> >> with
> > >> >> the
> > >> >> 32-bit DLL from W2K - 64-bit and 32-bit DLLs are in different folders
> > >> >> in
> > >> >> a
> > >> >> 64-bit Windows install.
> > >> >>
> > >> >> Can you switch IIS back to 64-bit mode and see if that then works? If
> > >> >> you're
> > >> >> on W2K8 64-bit then that would explain why IXSSO.DLL can't be loaded -
> > >> >> it's
> > >> >> a 64-bit DLL, and so your ASP application has to be running in 64-bit
> > >> >> mode
> > >> >> to load it.
> > >> >>
> > >> >> Dan
> > >> >>
> > >> >>
> > >> >> "csw" <(E-Mail Removed)> wrote in message
> > >> >> news:(E-Mail Removed)...
> > >> >> > Bob
> > >> >> >
> > >> >> > Thanks for the reply. I already forced IIS into 32-bit mode.
> > >> >> > That's
> > >> >> > why
> > >> >> > I
> > >> >> > thought to copy the w2k IXSSO.dll ( 32-bit) to replace the W2K8
> > >> >> > version).
> > >> >> > I
> > >> >> > was wondering if any one ever did that and succeeded??
> > >> >> >
> > >> >> > I also will try to register the dll again. new version and old
> > >> >> > version.
> > >> >> >
> > >> >> > csw
> > >> >> >
> > >> >> >
> > >> >> >
> > >> >> > "Bob Barrows" wrote:
> > >> >> >
> > >> >> >> csw wrote:
> > >> >> >> > I'm moving classic asp sites from Windows 2000 / IIS 5 to Windows
> > >> >> >> > 2008 R2 / IIS 7.
> > >> >> >> >
> > >> >> >> > * We have the "Indexing Service" started.
> > >> >> >> > * I have application pool in 32 bit mode.
> > >> >> >> > * IXSSO.DLL is present in System32 directory. (dated 7/13/2009)
> > >> >> >> > * Catalogs were created and looked OK.
> > >> >> >> >
> > >> >> >> >
> > >> >> >> > However, I am unable to create an ixsso.Query object.
> > >> >> >> > Get the following error message :
> > >> >> >> >
> > >> >> >> > Microsoft VBScript runtime error '800a01ad'
> > >> >> >> > ActiveX component can't create object
> > >> >> >> > /HC/ECO/Announcements/Headlines/SearchResults.asp, line 39
> > >> >> >> >
> > >> >> >> > my ASP code :
> > >> >> >>
> > >> >> >> irrelevant
> > >> >> >>
> > >> >> >> > It crashed at " Set oQuery =
> > >> >> >> > Server.CreateObject("IXSSO.Query")
> > >> >> >> > "
> > >> >> >> >
> > >> >> >> >
> > >> >> >> > My questions:
> > >> >> >> > 1)Can I copy IXSSO.DLL from W2K (6/19/2003) 32 Bit to W2K8? Thus
> > >> >> >> > the
> > >> >> >> > "bitness" issue can be resolved.
> > >> >> >>
> > >> >> >> "bitness"? Is WS2008 necessarily 64-bit? If so, you will also need
> > >> >> >> to
> > >> >> >> either
> > >> >> >> find a 64-bit version of the dll is it exists, or force IIS to run
> > >> >> >> in
> > >> >> >> 32-bit
> > >> >> >> mode (I forget how to do that but google should supply the answer).
> > >> >> >> If you are using ADO, especially with Jet backend, you will likely
> > >> >> >> to
> > >> >> >> have
> > >> >> >> already forced IIS into 32-bit mode.
> > >> >> >>
> > >> >> >> > 2) If this permission issues, what kind of permission I need to
> > >> >> >> > grant
> > >> >> >> > accounts and directory? I set up the web application with
> > >> >> >> > "Window
> > >> >> >> > Authentication mode" and using IIS_IUSRS group (the new build in
> > >> >> >> > group).
> > >> >> >>
> > >> >> >> If it's not a "bitness" issue, then it's more likely a registration
> > >> >> >> issue.
> > >> >> >> Have you registered the dll? Use regsvr32.exe to register it,
> > >> >> >> unless
> > >> >> >> WS2008
> > >> >> >> has a different tool.
> > >> >> >>
> > >> >> >> If you still have issues and get no answers here, you might want
> > >> >> >> post
> > >> >> >> in
> > >> >> >> the
> > >> >> >> iis group.
> > >> >> >>
> > >> >> >> --
> > >> >> >> Bob Barrows
> > >> >> >>
> > >> >> >>
> > >> >> >> .
> > >> >> >>
> > >> >>
> > >> >>
> > >> >>
> > >> >> .
> > >> >>
> > >>
> > >>
> > >>
> > >> .
> > >>

> >
> >
> >
> > .
> >

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fail to create IXSSO.Query object csw Windows 64bit 0 06-08-2010 09:25 PM
Making an object follow another object - FAIL! Lasse Svensson Ruby 4 02-15-2008 12:37 PM
Object creation - Do we really need to create a parent for a derieved object - can't the base object just point to an already created base object jon wayne C++ 9 09-22-2005 02:06 AM
javascript would fail to create a html element sometimes q2005 Javascript 1 01-10-2005 02:58 PM
if (f() != FAIL) or if (FAIL != f())? Wenjie C Programming 3 07-31-2003 09:54 PM



Advertisments